6.3 upgrade. Can't login and use tools

Issue Summary

Local 6.3. Can’t use any tool’s link - database or mailhog. Can’t log in to Local

Troubleshooting Questions

Trying to use database adminer or any active tool - link doesn’t active - nothing happened
Also can’t log in to Local account inside application. But can do that on web site.


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used? 6.3.0

  • What Operating System (OS) and OS version is being used?

    • For example: macOS Catalina or Windows 10 Professional MacOS 12.2.1
  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

1 Like

Ditto. The buttons for Admin and Open Site also do not work. I can, however, start a site, then type the info into the browser to work on it, rather than clicking the buttons.

Version of local: 6.3.0+5756
OS: MacOS Big Sur V 11.6.1
local-lightning.log (490.4 KB)

~ Tracy
e design studio, LLC

1 Like

I also cannot login to Local 6.3. The upgrade has make it unusable. I am using latest version of Windows 10.

1 Like

Me too!
Links don’t opens in browsers, only if I paste it by hand.
Adminer and Mailhog don’t works.
List of browsers (in settings) muted.
So created backup of all sites, reinstall Local and login to my account was successful. But only. Other bugs still on.

Local 6.3.0, Windows 10

Hello there! :slight_smile:
I’m posting this here, just in case somebody else have the same issue. I use window 7, but probably it is works for any OS versions as well.

1-. Uninstall local.
2-. Download past version https://localwp.com/releases.
3-. Install it and run.

Upgrade to the new version message appears, click ‘remind me later’ to ignore!

I hope help someone, it is works for me at least.


1 Like

Hi @Kris,

I’m sorry you were having issues with Local v6.3. What were you seeing after updating? I’m not sure what you meant by “can’t run”. I’m going to merge this into a thread with other users to see if we can track this down.


Hi all,

I’m digging into this thread right now to see if I can reproduce. I’m sorry that you’re having issues! I wonder if these are related or if they are separate issues.

@OlderFisher and @mattfraser - can you upload your Local log file? Here is a link for how to do so, which will help me track down the errors. OlderFisher, when you say links aren’t working, do they not open when clicked? Or what do you see in the browser?

@TracyTra thank you for sharing that log file. There are a few helpful lines in there - “Unhandled Rejection” with event IDs I will try to track down in our system. I’m curious, do you have a default browser set in your Local Preferences pane? It is located under Appearance & Behavior. I have Monterey 12.2.1 and am trying to reproduce.

@chemerys1 can you share a screenshot of the muted settings? I have Local v6.3 on Windows 10 and do not see the same issue.

My default browser is Chrome right now (Version 98.0.4758.102 (Official Build) (x86_64)), although I test in several different browsers to make sure it looks similar per each (Safari, Firefox, and a few other offshoots of Chrome like Brave, although I only use Brave for one thing and never for development).

~ Tracy

OH and FYI - it’s only the button clicking that doesn’t work. I can’t log in to local, and I can’t click the admin button or the open site button. But I am still using the latest version of local as it still works to run the sites as I dev them locally. I just have to type in the local site domain.

Also a side note on a completely separate issue which I should probably put somewhere else… LOL: For a while now, when I start up a site, and I hover over the push or pull cloud buttons in the bottom right of local window - to push or to pull - I get a message that says something like “Connect to Flywheel does not support multisite” and none of my sites in local are multi sites. I usually have to just click on the name of another site, then click back on the name of the site I’m running, and the buttons right themselves and I can then push or pull the site.

Feel free to move that other issue to an appropriate thread as need be.


~ Tracy


Hi, I mean every link click has nothing happened : Log into Local , Open adminer, Open mailhog
local-lightning-verbose.log (195.4 KB)
local-lightning.log (28.7 KB)
Thanks , Alex

1 Like

Hello @austinwendt, I mean ‘can’t open’ the app after the upgrade v6.3.
When I click on my desktop icon (as always) does nothing, I tried from website account “open local” button as well, but I had the same result. I cannot do more testing or copy Local log file, because was like the app doesn’t exist after upgrade. You click the desktop icon but nothing happens.

So I had to uninstall the new version and install 6.2.1 and everything works perfectly again.

1 Like

I have also filed this as a bug report.

Here is a sample of what the logs look like when connection to browsers fail…

{"thread":"main","reason":{},"p":{},"eventId":"dc6915335bf7487f96e78b82793fe869","level":"warn","message":"Unhandled Rejection.","timestamp":"2022-02-23T16:41:48.989Z"}
{"thread":"main","reason":{},"p":{},"eventId":"be8a5ff8bcbc45bfb46f1b8a515ba418","level":"warn","message":"Unhandled Rejection.","timestamp":"2022-02-23T16:41:50.541Z"}
{"thread":"main","reason":{},"p":{},"eventId":"5129c058241b45cf9f0207264bca9cf6","level":"warn","message":"Unhandled Rejection.","timestamp":"2022-02-23T16:42:25.601Z"}
{"thread":"main","reason":{},"p":{},"eventId":"e6fbfaafab4e4f7c8e380d7ae5a45a70","level":"warn","message":"Unhandled Rejection.","timestamp":"2022-02-23T16:42:26.102Z"}
{"thread":"main","reason":{},"p":{},"eventId":"3cffe3659db444d79f00a0eebc6e217f","level":"warn","message":"Unhandled Rejection.","timestamp":"2022-02-23T16:42:26.774Z"}
{"thread":"main","reason":{},"p":{},"eventId":"5b2c932544ed4e668a2b48ec5b137c57","level":"warn","message":"Unhandled Rejection.","timestamp":"2022-02-23T16:42:27.083Z"}
{"thread":"main","reason":{},"p":{},"eventId":"1d8fb0e74ec74417877534ee0abe84d7","level":"warn","message":"Unhandled Rejection.","timestamp":"2022-02-23T16:42:27.350Z"}
{"thread":"main","reason":{},"p":{},"eventId":"361933d20ec141f888663ba484c50fd1","level":"warn","message":"Unhandled Rejection.","timestamp":"2022-02-23T16:42:27.934Z"}
{"thread":"main","reason":{},"p":{},"eventId":"208120c97a844fa7990b88d5b3d20d23","level":"warn","message":"Unhandled Rejection.","timestamp":"2022-02-23T16:42:57.875Z"}
{"thread":"main","reason":{},"p":{},"eventId":"3bcbc862aa7b43198cf69706a64a7d68","level":"warn","message":"Unhandled Rejection.","timestamp":"2022-02-23T16:43:32.483Z"}
{"thread":"main","reason":{},"p":{},"eventId":"194a1eee002b454aa7870b27b656cf9b","level":"warn","message":"Unhandled Rejection.","timestamp":"2022-02-23T16:43:49.422Z"}
{"thread":"main","reason":{},"p":{},"eventId":"fdc6e93e4a9d4b1593da63ee5bb8a42e","level":"warn","message":"Unhandled Rejection.","timestamp":"2022-02-23T16:43:56.757Z"}

Just found a simple solution… the 6.3 update apparently borks the default browser selection. Go to Local > Preferences > Appearance & Behavior > Browser and reset the default browser. That seems to fix this.

1 Like

Hi @efc, thanks for sharing! I’m curious, when you went to the Preferences window, did you have a browser selected? Or did you have to select a new one and save?

1 Like

If someone who is experiencing the issue could help out before trying EFC’s fix - could you share what is in the defaultBrowser field of Local’s settings-default-apps.json file?

On Mac, this file lives at: ~/Library/Application Support/Local/settings-default-apps.json

On Windows, this file lives at: %APPDATA%/Roaming/Local/settings-default-apps.json

We’ve found the code where Local is running into issues, but would like to confirm the input it is struggling with.

Hi @austinwendt … when I got to the Preferences panel the dropdown menu for the browser was blank… it was about the width of a space and hand the disclosure icon only. When pressed, it revealed a list of browsers I have installed and I was able to pick Safari from the list. This fixed the issue for me.

1 Like

Muted list, but all browsers installed (regular, not portable versions)

Hi all,

Thank you for your help tracking this down. We have identified the fix and will have the patch in our next release of Local. In the meantime, the solution is as described above: Open Local’s Preferences and select a browser under Appearance & Behavior. Links should begin working inside Local again.

More context: A change in Local v6.3.0 started looking for the defaultBrowser field in Local’s app settings; for some users, if a default browser had never been selected, this field was empty and caused Local to be unable to open links. We will properly fallback to the System Default going forward.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.