# Accessing WP-Admin fails with SSL error

**URL:** <https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888>\
**Category:** Archived Support\
**Tags:** wp-admin\
**Created:** [March 9, 2023, 10:07pm UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888 "2023-03-09T22:07:38Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![Zeff](https://avatars.discourse-cdn.com/v4/letter/z/b77776/32.png) [@Zeff](https://community.localwp.com/u/Zeff)\
**Post date:** [March 9, 2023, 10:07pm UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888/1 "2023-03-09T22:07:38Z")

</div>

### Issue Summary

Accessing WP-Admin always uses SSL and it fails to connect.  
Changing the URL to HTTP causes it to redirect to HTTPS.

#### Troubleshooting Questions

- Does this happen for all sites in Local, or just one in particular?  
I only have one.

- Are you able to create a new, plain WordPress site in Local and access it in a Browser?  
yes

#### Replication

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

#### System Details

- Which version of Local is being used?  
Version 6.6.1+6281

- What Operating System (OS) and OS version is being used?

- Attach the Local Log. See this Help Doc for instructions on how to do so:

### Error

Secure Connection Failed

An error occurred during a connection to localhost:10004. SSL received a record that exceeded the maximum permissible length.

Error code: SSL\_ERROR\_RX\_RECORD\_TOO\_LONG

```
The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.

```

[local-lightning.log](https://community.localwp.com/uploads/short-url/sjq6tsBwoVlypNxoAWmRiIUYiRk.log) (29.1 KB)

---

<div class="post-metadata">

**Author:** ![sambrockway](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/sambrockway/32/18726_2.png) [@sambrockway](https://community.localwp.com/u/sambrockway)\
**Post date:** [March 10, 2023, 6:50pm UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888/2 "2023-03-10T18:50:24Z")

</div>

Hello @Zeff - welcome to the Local community! 👋

Have you reviewed this article about SSL + MacOS?

> **[Managing a Local site’s SSL certificate in macOS](https://localwp.com/help-docs/ssl/managing-local-sites-ssl-certificate-in-macos/)**
>
> In most cases, Local makes it easy to get your offline development environment running HTTPS by providing a one-click solution for trusting a site's SSL certificate. Occasionally, if that "trust"

There are also some troubleshooting steps I would recommend looking through here:

> **[SSL in Local](https://localwp.com/help-docs/ssl/ssl-in-local/)**
>
> Secure Sockets Layer (SSL) is a protocol for making secure connections. One of the more common uses of SSL is in conjunction with HTTP, where it's called HTTPS. This stands for "HTTP over SSL." Let'

Let’s start there!

Sam

---

<div class="post-metadata">

**Author:** ![Zeff](https://avatars.discourse-cdn.com/v4/letter/z/b77776/32.png) [@Zeff](https://community.localwp.com/u/Zeff)\
**Post date:** [March 10, 2023, 7:13pm UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888/3 "2023-03-10T19:13:40Z")

</div>

Hi Sam,

Thanks for these articles.  
However, there is no Trust link (see attached screenshot).  
The message “SSL Note! HTTPS is not available when using the localhost Routing Mode” and what is occurring, are confusing.

 ![CleanShot 2023-03-10 at 14.09.57](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/3X/f/0/f097b843675a48385eb190246c501a895fce3093.jpeg)

---

<div class="post-metadata">

**Author:** ![sambrockway](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/sambrockway/32/18726_2.png) [@sambrockway](https://community.localwp.com/u/sambrockway)\
**Post date:** [March 10, 2023, 7:15pm UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888/4 "2023-03-10T19:15:57Z")

</div>

Hi @Zeff -

Ah, understood. You can change your Router Mode by heading to `Local > Preferences > Advanced > Router mode > Site domains`

![Shared with CloudApp](https://p-DgFRdw9.t2.n0.cdn.getcloudapp.com/items/p9uQg6Ov/d447ddae-78e7-4d78-b904-2706a571c01b.jpg?source=social&v=c03c64c3f4da05165e170fa4752affd8)

Let me know if this helps!

Sam

---

<div class="post-metadata">

**Author:** ![Zeff](https://avatars.discourse-cdn.com/v4/letter/z/b77776/32.png) [@Zeff](https://community.localwp.com/u/Zeff)\
**Post date:** [March 10, 2023, 7:24pm UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888/5 "2023-03-10T19:24:03Z")

</div>

This is what I received on changing the Settings.  
Examining keychain and there is no certificate created.  
Learn more was not at all helpful.

 ![CleanShot 2023-03-10 at 14.22.16](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/3X/c/d/cd0e7acc82468ebff16b249f241725a96f1eb452.jpeg)

---

<div class="post-metadata">

**Author:** ![sambrockway](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/sambrockway/32/18726_2.png) [@sambrockway](https://community.localwp.com/u/sambrockway)\
**Post date:** [March 10, 2023, 7:25pm UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888/6 "2023-03-10T19:25:43Z")

</div>

Hi @Zeff -

Thanks for bearing with me here, now you’ll want to run through the keychain steps shown in this help doc I shared above:

> **[Managing a Local site’s SSL certificate in macOS](https://localwp.com/help-docs/ssl/managing-local-sites-ssl-certificate-in-macos/)**
>
> In most cases, Local makes it easy to get your offline development environment running HTTPS by providing a one-click solution for trusting a site's SSL certificate. Occasionally, if that "trust"

Can you try that and let me know if it works for you?

Sam

---

<div class="post-metadata">

**Author:** ![sambrockway](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/sambrockway/32/18726_2.png) [@sambrockway](https://community.localwp.com/u/sambrockway)\
**Post date:** [March 10, 2023, 7:26pm UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888/7 "2023-03-10T19:26:50Z")

</div>

Hi @Zeff -

I also didn’t ask earlier, was this an imported site or did you create a new site in Local?

Sam

---

<div class="post-metadata">

**Author:** ![Zeff](https://avatars.discourse-cdn.com/v4/letter/z/b77776/32.png) [@Zeff](https://community.localwp.com/u/Zeff)\
**Post date:** [March 10, 2023, 7:30pm UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888/8 "2023-03-10T19:30:31Z")

</div>

Hi Sam,

Same problem.  
I imported the site from WPEngine.

---

<div class="post-metadata">

**Author:** ![Zeff](https://avatars.discourse-cdn.com/v4/letter/z/b77776/32.png) [@Zeff](https://community.localwp.com/u/Zeff)\
**Post date:** [March 10, 2023, 7:31pm UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888/9 "2023-03-10T19:31:07Z")

</div>

BTW there are two files in the cert folder - cert and key. I deleted both. Perhaps the docs need updating?

---

<div class="post-metadata">

**Author:** ![sambrockway](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/sambrockway/32/18726_2.png) [@sambrockway](https://community.localwp.com/u/sambrockway)\
**Post date:** [March 10, 2023, 7:33pm UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888/10 "2023-03-10T19:33:31Z")

</div>

Hi @Zeff -

Got it. Thanks for those details!

**Are you able to create a new site in Local with default settings, and successfully enable SSL (following the guide I sent above)?**

If so, I’m wondering if maybe something about your imported site is redirecting `http://` to `https://` (like a plugin or override in a file) and causing issues.

Let me know,

Sam

---

<div class="post-metadata">

**Author:** ![Zeff](https://avatars.discourse-cdn.com/v4/letter/z/b77776/32.png) [@Zeff](https://community.localwp.com/u/Zeff)\
**Post date:** [March 10, 2023, 7:34pm UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888/11 "2023-03-10T19:34:31Z")

</div>

Created a test site and same issue.

---

<div class="post-metadata">

**Author:** ![Zeff](https://avatars.discourse-cdn.com/v4/letter/z/b77776/32.png) [@Zeff](https://community.localwp.com/u/Zeff)\
**Post date:** [March 10, 2023, 7:35pm UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888/12 "2023-03-10T19:35:44Z")

</div>

I am a noob when it comes to certs.  
Perhaps this is germane: I have a localhost cert for a NAS device.  
Could this be conflicting?

---

<div class="post-metadata">

**Author:** ![Zeff](https://avatars.discourse-cdn.com/v4/letter/z/b77776/32.png) [@Zeff](https://community.localwp.com/u/Zeff)\
**Post date:** [March 10, 2023, 8:47pm UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888/13 "2023-03-10T20:47:44Z")

</div>

Hi Sam, i restarted Local, and attempted to trust “test” again, and again, got the error.  
In keychain I found test.local and set the Trust to always.  
On returning to Local, test is now trusted.  
Then I went back to woodmood and it is also trusted.  
However, when I attempt to open the site, I get “there is a port conflict with the site’s domain”.

---

<div class="post-metadata">

**Author:** ![Zeff](https://avatars.discourse-cdn.com/v4/letter/z/b77776/32.png) [@Zeff](https://community.localwp.com/u/Zeff)\
**Post date:** [March 10, 2023, 9:00pm UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888/14 "2023-03-10T21:00:08Z")

</div>

I ran activity monitor and com.apple.geod appears to be listening on port 80.  
It appears that port 80 is used by numerous apple services: [TCP and UDP ports used by Apple software products - Apple Support](https://support.apple.com/en-us/HT202944)  
When I attempt to open site, I am taken to woodmood.local and the page displays “unknown app”.  
if I type “localhost:80” into the URL bar I also get “unknown app”.

---

<div class="post-metadata">

**Author:** ![Zeff](https://avatars.discourse-cdn.com/v4/letter/z/b77776/32.png) [@Zeff](https://community.localwp.com/u/Zeff)\
**Post date:** [March 14, 2023, 2:20pm UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888/15 "2023-03-14T14:20:53Z")

</div>

Sam, you’re MIA.  
I rebooted and tried again, but with the same result.  
Switching router mode to localhost, I was able to access the sites.

Is this a macOS issue, in general, or specific to my computer?

---

<div class="post-metadata">

**Author:** ![sambrockway](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/sambrockway/32/18726_2.png) [@sambrockway](https://community.localwp.com/u/sambrockway)\
**Post date:** [March 14, 2023, 2:45pm UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888/16 "2023-03-14T14:45:34Z")

</div>

Hi @Zeff -

Thank you for all of these details, it’s very helpful to see the various things you tried along the way.

Reading through - it sounds like switching router mode back to localhost everything is working okay, correct?

Yes, I think there might be an issue with something conflicting with Local (specifically when you’re in the Site domains mode, which allows you to use SSL).

Have you attempted to reboot your machine?

I’m looking at a similar thread about a port conflict with MacOS and this user found success after a reboot:

> [@Local 5.9.7: new sites all have Port conflict (solved)](http://community.localwp.com/t/local-5-9-7-new-sites-all-have-port-conflict-solved/23561):
>
> Issue Summary All sites created with Local 5.9.7+5156 show the red «There is a port conflict with this site’s domain» error. Troubleshooting Questions Does this happen for all sites in Local, or just one in particular? Any newly created domain. Old domains still work. Are you able to create a new, plain WordPress site in Local and access it in a Browser? Nope. Replication Just create a new site with any setting, domain name, URL, webserver, PHP version, blueprint or no blueprint – all…

Sam

---

<div class="post-metadata">

**Author:** ![sambrockway](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/sambrockway/32/18726_2.png) [@sambrockway](https://community.localwp.com/u/sambrockway)\
**Post date:** [March 14, 2023, 2:50pm UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888/17 "2023-03-14T14:50:27Z")

</div>

Hi @Zeff -

Also, I would suggest checking out this part of our article about Router Mode that discusses how to stop whatever is running on Port 80:

> **[What is Router Mode?](https://localwp.com/help-docs/advanced/router-mode/#stopping-whatever-is-listening-on-port-80)**
>
> Router Mode is Local's way of offering the best offline development experience possible while still "playing nice" with other, similar development applications.

Let me know if this helps!

Sam

---

<div class="post-metadata">

**Author:** ![Zeff](https://avatars.discourse-cdn.com/v4/letter/z/b77776/32.png) [@Zeff](https://community.localwp.com/u/Zeff)\
**Post date:** [March 14, 2023, 3:29pm UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888/18 "2023-03-14T15:29:51Z")

</div>

Hi Sam,

Thanks for that article—using lsof I found the process.  
I could kick myself—I’m a Rails developer and I had puma-dev running as a background job.  
Killing and unloading it did the trick!

Thanks so much for your help.

Cheers,  
Rob

---

<div class="post-metadata">

**Author:** ![sambrockway](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/sambrockway/32/18726_2.png) [@sambrockway](https://community.localwp.com/u/sambrockway)\
**Post date:** [March 14, 2023, 3:45pm UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888/19 "2023-03-14T15:45:27Z")

</div>

Hi @Zeff -

So, so glad you got there!

Please be sure to circle back if you need any more support while you use Local.

Sam

---

<div class="post-metadata">

**Author:** ![system](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/system/32/1_2.png) [@system](https://community.localwp.com/u/system)\
**Post date:** [March 16, 2023, 3:45am UTC](https://community.localwp.com/t/accessing-wp-admin-fails-with-ssl-error/35888/20 "2023-03-16T03:45:31Z")

</div>

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.
