# Another plugin update thread

**URL:** <https://community.localwp.com/t/another-plugin-update-thread/2341>\
**Category:** Support\
**Created:** [July 25, 2017, 3:57pm UTC](https://community.localwp.com/t/another-plugin-update-thread/2341 "2017-07-25T15:57:04Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![zforsman](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/zforsman/32/1225_2.png) [@zforsman](https://community.localwp.com/u/zforsman)\
**Post date:** [July 25, 2017, 3:57pm UTC](https://community.localwp.com/t/another-plugin-update-thread/2341/1 "2017-07-25T15:57:04Z")

</div>

I’ve been browsing around and finding people with issues updating plugins, but so far none have been quite what I’m experiencing.

I spun up a new site yesterday using a blueprint we created. It was running WP 4.7.x so I immediately was prompted to update to 4.8. I attempted to do this several times via the dashboard but the install kept hanging. The refresh icon in the Chrome tab on the update page would just spin and spin. I finally just downloaded new WP Core files from [wordpress.org](http://wordpress.org) and successfully updated that way.

Now I’m having a similar issue with the plugins I have installed with this blueprint. Clicking Update on them starts the update process by adding the .maintenance file to the root directory, and displaying the “Updating” text with the spinning orange arrows on the plugins page. But it just keeps spinning.

![](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/2X/4/4ea8a009e64e4fdfcfe103d9798d7dad045afc5a.png)

I have tried multiple reboots of Flywheel, updated my VirtualBox, and turned off Faster Docker Volumes. Nothing has worked. It sort of seems like maybe a lack of memory issue and it’s just taking FOREVER to unzip the files because I never see an update failed error. But that’s the best guess I have.

I am currently running Flywheel v 2.0.6

Hoping for some help!  
Thanks

---

<div class="post-metadata">

**Author:** ![zforsman](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/zforsman/32/1225_2.png) [@zforsman](https://community.localwp.com/u/zforsman)\
**Post date:** [July 25, 2017, 4:05pm UTC](https://community.localwp.com/t/another-plugin-update-thread/2341/2 "2017-07-25T16:05:14Z")

</div>

Well I sort of have an update. After about a half hour of waiting for Yoast SEO to update, I finally got an “Update Failed: Internal Server Error” error. So that’s something…

---

<div class="post-metadata">

**Author:** ![clay](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/clay/32/8248_2.png) [@clay](https://community.localwp.com/u/clay)\
**Post date:** [July 25, 2017, 4:18pm UTC](https://community.localwp.com/t/another-plugin-update-thread/2341/3 "2017-07-25T16:18:10Z")

</div>

Hi Zac,

Can you please check your PHP error log for indications of what went wrong? You can find the logs in the `logs` folder in the site folder.

---

<div class="post-metadata">

**Author:** ![zforsman](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/zforsman/32/1225_2.png) [@zforsman](https://community.localwp.com/u/zforsman)\
**Post date:** [July 25, 2017, 4:22pm UTC](https://community.localwp.com/t/another-plugin-update-thread/2341/4 "2017-07-25T16:22:01Z")

</div>

Hi Clay,

Here’s my fpm log, there is no php error log:

````auto
[24-Jul-2017 15:59:30] NOTICE: ready to handle connections
[24-Jul-2017 16:53:28] WARNING: [pool www] child 1233 exited with code 70 after 3019.567960 seconds from start
[24-Jul-2017 16:53:28] NOTICE: [pool www] child 1292 started
[24-Jul-2017 20:01:18] NOTICE: fpm is running, pid 75
[24-Jul-2017 20:01:18] NOTICE: ready to handle connections
[25-Jul-2017 14:04:23] NOTICE: fpm is running, pid 193
[25-Jul-2017 14:04:23] NOTICE: ready to handle connections
[25-Jul-2017 14:06:31] NOTICE: fpm is running, pid 488
[25-Jul-2017 14:06:32] NOTICE: ready to handle connections
[25-Jul-2017 14:13:49] NOTICE: Terminating ...
[25-Jul-2017 14:13:49] NOTICE: exiting, bye-bye!
[25-Jul-2017 14:13:54] NOTICE: fpm is running, pid 877
[25-Jul-2017 14:13:54] NOTICE: ready to handle connections
[25-Jul-2017 14:19:02] NOTICE: fpm is running, pid 568
[25-Jul-2017 14:19:02] NOTICE: ready to handle connections
[25-Jul-2017 15:39:13] NOTICE: fpm is running, pid 539
[25-Jul-2017 15:39:13] NOTICE: ready to handle connections```
````

---

<div class="post-metadata">

**Author:** ![zforsman](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/zforsman/32/1225_2.png) [@zforsman](https://community.localwp.com/u/zforsman)\
**Post date:** [July 25, 2017, 5:54pm UTC](https://community.localwp.com/t/another-plugin-update-thread/2341/5 "2017-07-25T17:54:50Z")

</div>

Also I just checked another site (one I built about a month ago) and the plugins fail to update there as well.

---

<div class="post-metadata">

**Author:** ![clay](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/clay/32/8248_2.png) [@clay](https://community.localwp.com/u/clay)\
**Post date:** [July 25, 2017, 6:10pm UTC](https://community.localwp.com/t/another-plugin-update-thread/2341/6 "2017-07-25T18:10:13Z")

</div>

Zac,

Are these sites running on the “Preferred” or “Custom” environment?

---

<div class="post-metadata">

**Author:** ![zforsman](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/zforsman/32/1225_2.png) [@zforsman](https://community.localwp.com/u/zforsman)\
**Post date:** [July 25, 2017, 6:20pm UTC](https://community.localwp.com/t/another-plugin-update-thread/2341/7 "2017-07-25T18:20:21Z")

</div>

I’m fairly certain they are on “Custom”. Is there a way to check once the project has been created?

The other site I tested is now able to update plugins. I have updated 5 plugins successfully on that site now after turning Faster Docker Volumes back on.

I was able to update Ninja Forms a few minutes ago on the site I started this thread for. So I tried another (Redirection), but now that’s just spinning.

---

<div class="post-metadata">

**Author:** ![clay](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/clay/32/8248_2.png) [@clay](https://community.localwp.com/u/clay)\
**Post date:** [July 25, 2017, 6:24pm UTC](https://community.localwp.com/t/another-plugin-update-thread/2341/8 "2017-07-25T18:24:39Z")

</div>

The easiest way to check is if there’s a “Dev Mode” toggle in the top-right of the site settings. If there is, then it’s using the Preferred environment.

If it’s Custom, do you see an `error.log` file in the PHP error log folder?

---

<div class="post-metadata">

**Author:** ![zforsman](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/zforsman/32/1225_2.png) [@zforsman](https://community.localwp.com/u/zforsman)\
**Post date:** [July 25, 2017, 6:29pm UTC](https://community.localwp.com/t/another-plugin-update-thread/2341/9 "2017-07-25T18:29:24Z")

</div>

Good to know. This site is using Custom then, based on that.

I don’t see an error.log file in project/logs/php/5.5.38/ only php-fpm.log

---

<div class="post-metadata">

**Author:** ![zforsman](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/zforsman/32/1225_2.png) [@zforsman](https://community.localwp.com/u/zforsman)\
**Post date:** [July 31, 2017, 4:58pm UTC](https://community.localwp.com/t/another-plugin-update-thread/2341/10 "2017-07-31T16:58:00Z")

</div>

Any other thoughts on this?

---

<div class="post-metadata">

**Author:** ![zforsman](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/zforsman/32/1225_2.png) [@zforsman](https://community.localwp.com/u/zforsman)\
**Post date:** [August 10, 2017, 5:59pm UTC](https://community.localwp.com/t/another-plugin-update-thread/2341/11 "2017-08-10T17:59:26Z")

</div>

After updating VirtualBox and restarting the site I was able to update one plugin. Then tried another and it failed. So I restarted the site again and was able to update another plugin. I tried this twice more with success, so I thought maybe I just needed to restart the site between updates. After trying a fifth plugin I’m now back to a hanging update no matter how many times I restart.

Not really sure how to proceed.

edit: getting “Update Failed: Internal Server Error” now if I wait long enough

---

<div class="post-metadata">

**Author:** ![zforsman](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/zforsman/32/1225_2.png) [@zforsman](https://community.localwp.com/u/zforsman)\
**Post date:** [August 10, 2017, 6:40pm UTC](https://community.localwp.com/t/another-plugin-update-thread/2341/12 "2017-08-10T18:40:54Z")

</div>

Turns out I can still update plugins, I have to disable Faster Docker Volumes, restart the site, enable Faster Docker Volumes, restart again, then run the update. This seems to work consistently, I was able to update 5 more plugins with this method.

Hopefully that shines some light for someone to do something.

---

<div class="post-metadata">

**Author:** ![system](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/system/32/1_2.png) [@system](https://community.localwp.com/u/system)\
**Post date:** [August 25, 2020, 6:32pm UTC](https://community.localwp.com/t/another-plugin-update-thread/2341/13 "2020-08-25T18:32:20Z")

</div>


