Application crashing

When launching application it says “Checking system…” for about 10 seconds then crashes. No error messages.

Hi @kirsten,

So sorry for the trouble!

Is this on macOS or Windows?

macOS Sierra, sorry i should have specified

No worries!

Please see Local 2.0.x Mac Quits Upon Launch

This is addressed in the next update.

thanks @clay - i successfully deleted the error-reporting.json file and selected no - but now it seems that i am just stuck on the “checking system…” i did try restarting the local machine and it said that it restarted but returned to this screen

1 Like

Can you please go to Help » Reveal Local’s Log and provide the log file?

1 Like

Yep! Here it is: local-by-flywheel.log (70.9 KB)

1 Like

Hi Kirsten,

I’m not seeing anything alarming in that log file at the moment.

We’re adding more verbose error logging in the upcoming update (due very soon) so we should be able to gather more information then.

Sorry about that!


I have the same issue; I found several threads about it on the forums with no solution, for example Checking system - Support - Local Community and Can't start Local. Stuck on "Checking System" - Support - Local Community.

Maybe this thread can become the preferred once, since it is followed by a support member?

Anyway, here’s my log: local-by-flywheel.log (773.8 KB)

I am on Local v2.0.7 (pre-release) on macOS Sierra, but I had the same problem with the stable v2.0.6 version.
The only solution I have found is to restart my MacBook Pro.
I tried deleting error-reporting.json and site-statuses.json in “Library/Application Support/Local by Flywheel” to no effect.


UPDATE: Looking in Activiy Monitor I found that VBoxHeadless was taking 100% CPU resources durint the “Checking System” phase. I terninated the process, restarted Local, and it worked! This seems more convenient than restarting the Mac.