Local Community

Can't update plugins running local on win10

Can’t update plugins running Local on win10.

Seems like every single thread about this has been abandoned/not answered. I’m having an issue updating plugins. I get a can’t create directory error, which seems to be a permissions issue. I have everything set to full control and the problem still exists.

Any ideas? Seems like this is a deal-breaker with developing locally if this can’t be resolved.

System Details

Local Version 6.1.0+5452


@phdeoliveira IMHO I think this app is dead. Have not had an answer for 20 hours on my simple question. I see you experiencing the same.
I am guessing it is just not supported anymore.

that’s a shame. I was really looking forward to using this for development. Weird that wpengine advertises something that doesn’t really work. The only reason I even knew about Local was because of my host provider.

That’s not entirely correct.

Local is definitely not dead and is seeing lots new users! As a free product, we’re juggling many things to both improve the core experience as well as ship new features.

You seem like you’re on the way to being an active member of this community (you’ve created two new topics since joining yesterday, hooray!) I encourage you keep it up!

Ask questions, review your own logs, search the forums for solutions, and find ways to make this place better!

Remember, our community is only as good as the members. Please leave the negativity at the door and instead, focus on solving problems and lifting others up!

1 Like

It’s hard to know what’s going on without more information – Can you expand a bit more on how the plugins aren’t being updated?

Are you seeing any specific errors? Where are those errors showing?

Can you please provide your Local Log? See this Community Forum post for instructions on how to do so:

I’m trying to upgrade plugins in the backend. Basically just updating in the plugins section of WP.

I have define('FS_METHOD', 'direct'); in my wp-config to bypass the FTP credentials issue.

When I try to update, I get an “Update failed: Could not create directory.” error.

Here’ is my logs
local-lightning.log (446.5 KB)

Thanks for that additional context as well as the Local log.

I’ve never seen this as a requirement for a site in Local. As a first step, you might also try removing this setting and re-try updating the plugin.

If you still have issues, then you might need to keep going with troubleshooting:

In this case, this less an error with Local and more an error with PHP and how it relates to the filesystem.

There’s probably more info in the php error log which can be found at ~/Local Sites/sitename/logs/php/error.log so you might take a look there.

the define('FS_METHOD', 'direct'); is to bypass the ftp credentials when you go and try to update a plugin in the backend.

@ben.turner also, in regards to the php error.logs… nothing is showing up.

This seems like a permissions issue with the wp-content/plugins folder

That’s what I thought too… I opened up permissions and I still get that error. Unless I didn’t set it correctly?

And what are the permissions for all of the folders inside of wp-content?

I’d double check what @afragen asked about – permissions of the folders within the wp-content folder.

A couple of other thoughts:

This is where I’m confused – I’ve never had that connection modal show up under Windows. That makes me think that there’s some sort of issue with this machine that’s making WordPress think it doesn’t have access to make changes to the files of this Local site.

I wonder if there’s something odd going on with the name of this site. In that screenshot of the file permissions, I see that the site is located at:


With that location, a couple of observations:

  • This site is on a different partition (ie, not on the C:\\ drive)
  • The site name has localhost in it. I wouldn’t think this is an issue, but you never know with windows!
  • The site name starts with an underscore. Again, I wouldn’t think this is an issue, but… windows!

As a test, can you try creating a new site on the C:\\ partition and have it named something that doesn’t doesn’t start with an underscore AND doesn’t include localhost in it?

Welp, looks like I need to go into special permissions and set ms account user to full control and that did it. I don’t quite understand Windows permissions, but that seemed to do the trick. I knew it was a permissions issue!

Thanks for the feedback and help.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.