Cgi-bin script does not run


I need to run a .cgi file inside cgi-bin folder. I put cgi-bin folder on app/public folder. When I run the browser downloads the files and the files never execute. I need to enable CGI run on cgi-bin folder.

Please help!

Thanks in advance.

Hi Deryck,

Unfortunately, Perl scripts are not supported by Local. The only server-side language supported is PHP via PHP-FPM.

Hi Clay.

I solved the issue. I created a custom install with php 5.6.x and Apache (not Nginx). Then, checking conf/apache/conf-enabled/serve-cgi-bin.conf I found:

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Require all granted

Tested and works!!!

Rock on! Glad you got it to work :smile:. Thanks for sharing the solution too!

I figured it was Perl considering it was a cgi script. That’s something I haven’t heard for quite a few years. :wink:

Yep. In fact, I’m migrating an older TPV (based con CGI) to a new web service based version. I need to keep working the old one until the new one works.


1 Like