# Configuration Error Your   \`wp-config.php\`  file has an empty database table prefix, which is not supported

**URL:** <https://community.localwp.com/t/configuration-error-your-wp-config-php-file-has-an-empty-database-table-prefix-which-is-not-supported/8451>\
**Category:** Support\
**Created:** [September 27, 2018, 3:27pm UTC](https://community.localwp.com/t/configuration-error-your-wp-config-php-file-has-an-empty-database-table-prefix-which-is-not-supported/8451 "2018-09-27T15:27:25Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![robertkollar](https://avatars.discourse-cdn.com/v4/letter/r/c37758/32.png) [@robertkollar](https://community.localwp.com/u/robertkollar)\
**Post date:** [September 27, 2018, 3:27pm UTC](https://community.localwp.com/t/configuration-error-your-wp-config-php-file-has-an-empty-database-table-prefix-which-is-not-supported/8451/1 "2018-09-27T15:27:25Z")

</div>

Hi there!

I managed to import a backup website into flywheel by dragging the ZIP file onto the app.  
The website works fine.

I did this with another website that I have backed up and when I open the view the site I get the following error message:

# Configuration Error

Your `wp-config.php` file has an empty database table prefix, which is not supported.

Do you think this can be fixed somehow or I have to rebuild the site from scratch?

---

<div class="post-metadata">

**Author:** ![atempel](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/atempel/32/4826_2.png) [@atempel](https://community.localwp.com/u/atempel)\
**Post date:** [September 27, 2018, 9:59pm UTC](https://community.localwp.com/t/configuration-error-your-wp-config-php-file-has-an-empty-database-table-prefix-which-is-not-supported/8451/2 "2018-09-27T21:59:28Z")

</div>

Hey @robertkollar,

That happens because somehow the variable “$table\_prefix” in your `wp-config.php` file seems to be empty , **which should be a fairly simple thing to solve, don’t worry** … Inside your site folder’s root you will find your “wp-config.php” file. Below there is an image that shows where this variable is located inside the file:

 ![image](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/2X/3/3429d77f55b7af5e856ad7907358296adf99a7e4.png)

**To know what to fill there** , you have to open your database.

The prefix, is the part of the table’s name that normally comes before the underline (an underline is often used to separate the table’s name from the prefix), in the example below, the prefix is “wp\_”.  
 ![image](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/2X/e/e0f5abbafc0ce0b04c08249e859121a1dc45467f.png)

So when filling the value, be sure to include the underline in it.  
For the example above the correct value is:  
`$table_prefix = 'wp_';`  
So fill your file with the prefix you see on the database and you should be good to go!

See if that solves your problem!  
If you need any further help just say it and I’ll be notified 😃

---

<div class="post-metadata">

**Author:** ![robertkollar](https://avatars.discourse-cdn.com/v4/letter/r/c37758/32.png) [@robertkollar](https://community.localwp.com/u/robertkollar)\
**Post date:** [September 28, 2018, 7:48am UTC](https://community.localwp.com/t/configuration-error-your-wp-config-php-file-has-an-empty-database-table-prefix-which-is-not-supported/8451/3 "2018-09-28T07:48:24Z")

</div>

Hi there,

Unfortunately my database seems to be completely missing.  
When I open the site in the Adminer there are no tables  
I also tried to search for the database sql file, but its also gone  
There is no sql folder in the app folder

I don’t understand why the sql file is missing because last time I opened up this site with to work on it with  
the previous version of local, it was working

---

<div class="post-metadata">

**Author:** ![teamits](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/teamits/32/6155_2.png) [@teamits](https://community.localwp.com/u/teamits)\
**Post date:** [September 28, 2018, 3:47pm UTC](https://community.localwp.com/t/configuration-error-your-wp-config-php-file-has-an-empty-database-table-prefix-which-is-not-supported/8451/4 "2018-09-28T15:47:13Z")

</div>

I am having this exact same problem.

We are taking over development of an existing Flywheel site but cannot edit it locally.

I am using the version 2.4.2 of Local on windows 10 and if I try to import a backup or I try and pull a flywheel site into local for editing, I end up with this error and the database is not there when I use Adminer to look at sql.

I have uninstalled and re-installed local but this still is happening every time!

Any response would be greatly appreciated.

-Simon

---

<div class="post-metadata">

**Author:** ![atempel](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/atempel/32/4826_2.png) [@atempel](https://community.localwp.com/u/atempel)\
**Post date:** [October 3, 2018, 2:33pm UTC](https://community.localwp.com/t/configuration-error-your-wp-config-php-file-has-an-empty-database-table-prefix-which-is-not-supported/8451/5 "2018-10-03T14:33:47Z")

</div>

@teamits

_Regarding your problem, Flywheel specific problems run out of my knowledge_, but if the site works fine live, in production, it should work on Local. Something wrong might be happening when pulling the database from Flywheel to Local.

You could try to make a different backup/migration to Local, using **All-in-One WP Migration** ([https://br.wordpress.org/plugins/all-in-one-wp-migration/](https://br.wordpress.org/plugins/all-in-one-wp-migration/)) or **Duplicator** ([https://wordpress.org/plugins/duplicator/](https://wordpress.org/plugins/duplicator/))  
That way you won’t use Local’s import feature, and rather use Wordpress import through one of those plugins.

---

<div class="post-metadata">

**Author:** ![system](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/system/32/1_2.png) [@system](https://community.localwp.com/u/system)\
**Post date:** [August 25, 2020, 6:35pm UTC](https://community.localwp.com/t/configuration-error-your-wp-config-php-file-has-an-empty-database-table-prefix-which-is-not-supported/8451/6 "2020-08-25T18:35:22Z")

</div>


