EPERM Error. Tried the suggested solutions, but it didn't work

Hi. I’m running in what appears to be a common error in the use of Local. Before asking here, i went to this link and followed every instructions, included the ones with my anti-virus (obv is Kaspersky Internet security) in the restriction category, and even in the external link in the post. None of the solutions proposed worked.

While trying to resolve the problem, I noticed these peculiarities, that maybe are correlated with the issue:

  1. I can’t turn off the property “Only read” from my folder “etc” (On the first try, the Host file was already turned off, so that’s why i’m thinking of the folder itself as a problem);
  2. I can’t find the directory C:\Windows\System32\drivers\etc\hosts if I try to browse it in “Add new exclusion”, if i try to search it manually (I tried to just paste the directory proposed in the post but it not worked, that’s why I tried to browse it manually)

Hope I get an answer soon

I would like an answer. It’s been 6 days without a reply

I’ve heard of Windows Defender locking the hosts file. Might need to look into that. Also, search this forum is a great resource.


Specifically Help! I'm running into an EPERM error with the hosts file on Windows

thanks for your reply, I’ll look into Windows Defender. As the other link is the one i put in “this link” on my post, so I have already looked into that and I had tried everything in that before making my post. In fact, the reason I made this post is that the solutions proposed didn’t work for my case

Take a look at Windows Defender, but if you still are having issues, can you please provide your Local Log so we can see the specific issues that Local is running into? See this Community Forum post for instructions on how to do so:

Also, what version of Windows is installed?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.