Local Community

Error 404 in Live Links

Hello!

I am a newbie to Local. Everything works like a charm, but I have problems with Live Links.

I can enable Live Links on all my sites and access them, but I get a blank page with a 404 printed on all of them.

I’m following this steps: https://localwp.com/help-docs/local-features/live-links/
Am I missing something? What am I doing wrong?

I’m using:

Local 6.0.0+5444
OS Big Sur 11.4

Thanks in advance

Hey @javigaar – Welcome to the Local Community Forums!

Can you take a screenshot of the whole browser so that we can see the error within context? Can you also please provide your Local Log? See this Community Forum post for instructions on how to do so:

1 Like

Thanks for the quick response, @ben.turner.
Attaching Log, and Firefox screenshot with Dev tools open

local-lightning.log (259.7 KB)

Nice! Thanks for the screenshot. That looks like the 404 that’s usually given if your Local account (ie, your account on hub.localwp.com) can’t make a full connection to the instance of Local running on your own machine.

The two things to investigate first:

  1. Is the site turned on in Local?
  2. Is the live link enabled for that site?

Note that these site tunnels close automatically and need to be re-enabled every so often (I think they are closed every 24hrs)

If the above things are correct (site turned on, live link enabled), then there’s likely something going on with how the computer is connecting to the internet and in particular, how the Local Account connects to the Local app on your computer.

Things that come to my mind are:

  1. Are you using a VPN to connect to the internet? Maybe they are preventing external connections to your computer.

  2. Is this a work computer? Maybe IT has some security settings in place preventing external connections.

  3. Any custom settings on the router for your LAN? again, maybe external connections are being prevented.

1 Like

Yes, @ben.turner ! :raised_hands:t4:

I had verified all the points you have listed EXCEPT the last last last one. I have found the responsible security check on my incoming connections.

I can acces now :slight_smile:

Thanks for your time

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.