# ERROR: $table\_prefix in wp-config.php

**URL:** <https://community.localwp.com/t/error-table-prefix-in-wp-config-php/1996>\
**Category:** Uncategorized\
**Created:** [June 28, 2017, 3:19pm UTC](https://community.localwp.com/t/error-table-prefix-in-wp-config-php/1996 "2017-06-28T15:19:35Z")\
**Posts on this page:** 15\
**Page:** 1

<div class="post-metadata">

**Author:** ![jellybeandigital](https://avatars.discourse-cdn.com/v4/letter/j/51bf81/32.png) [@jellybeandigital](https://community.localwp.com/u/jellybeandigital)\
**Post date:** [June 28, 2017, 3:19pm UTC](https://community.localwp.com/t/error-table-prefix-in-wp-config-php/1996/1 "2017-06-28T15:19:35Z")

</div>

Downloaded one of my sites from Flywheel and imported it on Local. I can’t access to the site from my local machine because of this error.

ERROR: $table\_prefix in wp-config.php can only contain numbers, letters, and underscores.

---

<div class="post-metadata">

**Author:** ![clay](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/clay/32/8248_2.png) [@clay](https://community.localwp.com/u/clay)\
**Post date:** [June 28, 2017, 4:43pm UTC](https://community.localwp.com/t/error-table-prefix-in-wp-config-php/1996/2 "2017-06-28T16:43:36Z")

</div>

Hi there,

Sorry for the trouble!

What type of environment are you importing the site into? Preferred or custom?

---

<div class="post-metadata">

**Author:** ![jellybeandigital](https://avatars.discourse-cdn.com/v4/letter/j/51bf81/32.png) [@jellybeandigital](https://community.localwp.com/u/jellybeandigital)\
**Post date:** [June 28, 2017, 5:01pm UTC](https://community.localwp.com/t/error-table-prefix-in-wp-config-php/1996/3 "2017-06-28T17:01:30Z")

</div>

I am importing it into Preferred

---

<div class="post-metadata">

**Author:** ![jellybeandigital](https://avatars.discourse-cdn.com/v4/letter/j/51bf81/32.png) [@jellybeandigital](https://community.localwp.com/u/jellybeandigital)\
**Post date:** [July 3, 2017, 11:07pm UTC](https://community.localwp.com/t/error-table-prefix-in-wp-config-php/1996/4 "2017-07-03T23:07:06Z")

</div>

Hey, Clay, it’s been 5 days since I replied to you. Can you help, please?

---

<div class="post-metadata">

**Author:** ![clay](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/clay/32/8248_2.png) [@clay](https://community.localwp.com/u/clay)\
**Post date:** [July 5, 2017, 6:15pm UTC](https://community.localwp.com/t/error-table-prefix-in-wp-config-php/1996/5 "2017-07-05T18:15:28Z")

</div>

I’m looking into this now.

Thanks for your patience!

---

<div class="post-metadata">

**Author:** ![jellybeandigital](https://avatars.discourse-cdn.com/v4/letter/j/51bf81/32.png) [@jellybeandigital](https://community.localwp.com/u/jellybeandigital)\
**Post date:** [July 5, 2017, 10:16pm UTC](https://community.localwp.com/t/error-table-prefix-in-wp-config-php/1996/6 "2017-07-05T22:16:40Z")

</div>

![](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/2X/6/629ff03b681ead1949e418cf42ef078a60436bab.png)

Here is the account

---

<div class="post-metadata">

**Author:** ![clay](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/clay/32/8248_2.png) [@clay](https://community.localwp.com/u/clay)\
**Post date:** [July 6, 2017, 3:14pm UTC](https://community.localwp.com/t/error-table-prefix-in-wp-config-php/1996/7 "2017-07-06T15:14:52Z")

</div>

Hi @jellybeandigital,

I just tried importing that site and it looks like there are 5 different sets of WordPress tables. Local couldn’t figure out which set to use since Flywheel backups only contain an SQL file and `wp-content` and any non-WordPress root file. This issue will be resolved when the Local/Flywheel connection is available.

So, to fix this you can simply open wp-config.php for that site and then change `$table_prefix` to `wp_`

---

<div class="post-metadata">

**Author:** ![jellybeandigital](https://avatars.discourse-cdn.com/v4/letter/j/51bf81/32.png) [@jellybeandigital](https://community.localwp.com/u/jellybeandigital)\
**Post date:** [July 6, 2017, 4:15pm UTC](https://community.localwp.com/t/error-table-prefix-in-wp-config-php/1996/8 "2017-07-06T16:15:14Z")

</div>

Hey Clay,

Thanks for your reply.

I did follow your instructions, but it’s till not working. Please see screenshots attached.

 ![](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/2X/7/7f3e846d8a28f46b9382c3aff7de13b5d43e9520.png) ![](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/2X/8/8e7c9a22c61d2ec60642bd268ffd8e1db7a0a7f2.png) ![](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/2X/4/40551bdca585d29307b023dfecef8e65581dc459.png)

---

<div class="post-metadata">

**Author:** ![clay](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/clay/32/8248_2.png) [@clay](https://community.localwp.com/u/clay)\
**Post date:** [July 6, 2017, 4:18pm UTC](https://community.localwp.com/t/error-table-prefix-in-wp-config-php/1996/9 "2017-07-06T16:18:19Z")

</div>

Ah, sorry about that! I wasn’t clear with what I said 🙂

Try changing that line to `$table_prefix = 'wp_';`

---

<div class="post-metadata">

**Author:** ![jellybeandigital](https://avatars.discourse-cdn.com/v4/letter/j/51bf81/32.png) [@jellybeandigital](https://community.localwp.com/u/jellybeandigital)\
**Post date:** [July 6, 2017, 4:40pm UTC](https://community.localwp.com/t/error-table-prefix-in-wp-config-php/1996/10 "2017-07-06T16:40:45Z")

</div>

I did that and still not working!

![](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/2X/0/0cf969c9ea2d3763d76140dd2fc11be814c02872.png)

 ![](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/2X/0/0adfba179fd375182abc29aa2648a25d83392979.png)

---

<div class="post-metadata">

**Author:** ![clay](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/clay/32/8248_2.png) [@clay](https://community.localwp.com/u/clay)\
**Post date:** [July 6, 2017, 4:50pm UTC](https://community.localwp.com/t/error-table-prefix-in-wp-config-php/1996/11 "2017-07-06T16:50:31Z")

</div>

Try removing `wp_847_usermeta` down to `wpve_usermeta';`

The only thing that should be in that screenshot is that grayed out text and then `$table_prefix = 'wp_';`

---

<div class="post-metadata">

**Author:** ![jellybeandigital](https://avatars.discourse-cdn.com/v4/letter/j/51bf81/32.png) [@jellybeandigital](https://community.localwp.com/u/jellybeandigital)\
**Post date:** [July 6, 2017, 5:33pm UTC](https://community.localwp.com/t/error-table-prefix-in-wp-config-php/1996/12 "2017-07-06T17:33:59Z")

</div>

Hooray!

Finally, it’s working now. Thank you Clay 🙂

---

<div class="post-metadata">

**Author:** ![jellybeandigital](https://avatars.discourse-cdn.com/v4/letter/j/51bf81/32.png) [@jellybeandigital](https://community.localwp.com/u/jellybeandigital)\
**Post date:** [July 6, 2017, 5:44pm UTC](https://community.localwp.com/t/error-table-prefix-in-wp-config-php/1996/13 "2017-07-06T17:44:36Z")

</div>

Hold on! Actually, I deleted COMPASS from my flywheel account and now the site on the local server isn’t working anymore!!

---

<div class="post-metadata">

**Author:** ![clay](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/clay/32/8248_2.png) [@clay](https://community.localwp.com/u/clay)\
**Post date:** [July 6, 2017, 6:39pm UTC](https://community.localwp.com/t/error-table-prefix-in-wp-config-php/1996/14 "2017-07-06T18:39:56Z")

</div>

I’ve passed this onto our support team.

Hang tight!

---

<div class="post-metadata">

**Author:** ![Luke](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/luke/32/4866_2.png) [@Luke](https://community.localwp.com/u/Luke)\
**Post date:** [July 6, 2017, 6:47pm UTC](https://community.localwp.com/t/error-table-prefix-in-wp-config-php/1996/15 "2017-07-06T18:47:21Z")

</div>

We’ve recreated COMPASS in your bulk plan. You can access it here:

[https://app.getflywheel.com/org/jellybean-digital/compass](https://app.getflywheel.com/org/jellybean-digital/compass)

It should be finished cloning here shortly, but let us know if you have any other issues!
