# Error upgrading o 8.2 on fedora 39

**URL:** <https://community.localwp.com/t/error-upgrading-o-8-2-on-fedora-39/40637>\
**Category:** Support\
**Created:** [December 30, 2023, 5:28pm UTC](https://community.localwp.com/t/error-upgrading-o-8-2-on-fedora-39/40637 "2023-12-30T17:28:07Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![Nick-B](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/nick-b/32/16140_2.png) [@Nick-B](https://community.localwp.com/u/Nick-B)\
**Post date:** [December 30, 2023, 5:58pm UTC](https://community.localwp.com/t/error-upgrading-o-8-2-on-fedora-39/40637/2 "2023-12-30T17:58:12Z")

</div>

Hi @adsf1324

There might be an issue with updating on Fedora relating to some reoccurring problems we’ve noted with this OS. If you want to update you might need to try saving your sites, uninstalling and then reinstalling with steps like these:

> [@Sites fail to boot or create on Fedora 39](https://community.localwp.com/t/sites-fail-to-boot-or-create-on-fedora-39/39923/7):
>
> Sorry that you encountered this, @mizaistom and @leichim. As a workaround for now, please could you try installing Local via yum or Fedora’s Software Installer as above, then also installing the missing dependency like this? sudo yum install libxcrypt-compat Restart Local, and you should find that MySQL runs when you create and start a new site. I tested this under Fedora 39 and all is then well for me: (The underlying issue is that the vendor-supplied version of MySQL …

You’re also free to remain on a lower version if that works for now. We plan to have some quality of life improvements out for Fedora in the future but no ETA to provide at this time.

---

_[View the full topic](https://community.localwp.com/t/error-upgrading-o-8-2-on-fedora-39/40637)._
