# Error When Starting Site - (HTTP code 500) server error

**URL:** https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580
**Category:** Uncategorized
**Created:** [May 31, 2017, 10:20am UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580 "2017-05-31T10:20:47Z")
**Posts on this page:** 20
**Page:** 1

<div class="post-metadata">

### Author: ![hoangsa2t](https://avatars.discourse-cdn.com/v4/letter/h/898d66/32.png) [@hoangsa2t](https://community.localwp.com/u/hoangsa2t)
#### Post date: [May 31, 2017, 10:20am UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580/1 "2017-05-31T10:20:47Z")

</div>

I’ve updated Local by Flywheel to 2.0.1 and now i can’t start any site.

 ![](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/1X/20c148a74126d1fa0f36a12bdc82dbde77765efc.png)

[local-by-flywheel.log](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/1X/49f892839efdfc6ee25e430ba80f93378e0176e1.log) (1.5 MB)

Please help.

---

<div class="post-metadata">

### Author: ![clay](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/clay/32/8248_2.png) [@clay](https://community.localwp.com/u/clay)
#### Post date: [May 31, 2017, 2:22pm UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580/2 "2017-05-31T14:22:52Z")

</div>

Hi @hoangsa2t,

Very sorry for the trouble!

Can you please try the following?

1. Quit Local
2. Open /Applications/VirtualBox.app
3. Right-click on `local-by-flywheel`
4. Select `Reset` (this is the same as restarting)
5. Re-open Local

---

<div class="post-metadata">

### Author: ![eric](https://avatars.discourse-cdn.com/v4/letter/e/898d66/32.png) [@eric](https://community.localwp.com/u/eric)
#### Post date: [May 31, 2017, 3:05pm UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580/3 "2017-05-31T15:05:02Z")

</div>

Tried the above and it doesn’t fix it. I get the message when I try to create a new site!

---

<div class="post-metadata">

### Author: ![eric](https://avatars.discourse-cdn.com/v4/letter/e/898d66/32.png) [@eric](https://community.localwp.com/u/eric)
#### Post date: [May 31, 2017, 3:23pm UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580/4 "2017-05-31T15:23:56Z")

</div>

Urgent help please!!  
Is there a way to download version 2 again ? as version 2.0.1 doesn’t work

---

<div class="post-metadata">

### Author: ![clay](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/clay/32/8248_2.png) [@clay](https://community.localwp.com/u/clay)
#### Post date: [May 31, 2017, 3:29pm UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580/5 "2017-05-31T15:29:24Z")

</div>

@eric,

1.4.2 is available here: [Local by Flywheel 1.4.2](https://local.getflywheel.com/community/t/local-by-flywheel-1-4-2/694)

Are you seeing the same error as @hoangsa2t?

---

<div class="post-metadata">

### Author: ![eric](https://avatars.discourse-cdn.com/v4/letter/e/898d66/32.png) [@eric](https://community.localwp.com/u/eric)
#### Post date: [May 31, 2017, 3:30pm UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580/6 "2017-05-31T15:30:55Z")

</div>

yes correct same error. Downgraded to version 2 and still no luck. will try 1.4.2 and let you know how i get on

 ![](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/1X/677ae3ddd141ec4339b75c0acceb1b46b68daa18.png)

---

<div class="post-metadata">

### Author: ![clay](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/clay/32/8248_2.png) [@clay](https://community.localwp.com/u/clay)
#### Post date: [May 31, 2017, 3:50pm UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580/7 "2017-05-31T15:50:14Z")

</div>

If you’re getting the container is missing error then that most likely means the VirtualBox VM was deleted at some point.

Downgrading won’t help in that case. You’re going to need to restore the site from the site folder and the SQL files in the `app/sql` directory.

---

<div class="post-metadata">

### Author: ![eric](https://avatars.discourse-cdn.com/v4/letter/e/898d66/32.png) [@eric](https://community.localwp.com/u/eric)
#### Post date: [May 31, 2017, 3:51pm UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580/8 "2017-05-31T15:51:01Z")

</div>

1.4.2 Still not working ☹  
Application gets stuck creating site container  
@clay do you know what could be causing this?  
Thanks ![](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/1X/7052615e624274254bf9990cfc1522f9664e11f7.png)

---

<div class="post-metadata">

### Author: ![eric](https://avatars.discourse-cdn.com/v4/letter/e/898d66/32.png) [@eric](https://community.localwp.com/u/eric)
#### Post date: [May 31, 2017, 3:52pm UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580/9 "2017-05-31T15:52:26Z")

</div>

But this is a new site I am trying to create? I never deleted the VM. Could it be caused by something else?

---

<div class="post-metadata">

### Author: ![clay](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/clay/32/8248_2.png) [@clay](https://community.localwp.com/u/clay)
#### Post date: [May 31, 2017, 3:54pm UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580/10 "2017-05-31T15:54:12Z")

</div>

Can you please provide your log?

Very sorry for the trouble!

---

<div class="post-metadata">

### Author: ![eric](https://avatars.discourse-cdn.com/v4/letter/e/898d66/32.png) [@eric](https://community.localwp.com/u/eric)
#### Post date: [May 31, 2017, 3:55pm UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580/11 "2017-05-31T15:55:56Z")

</div>

Thanks @clay where do i find the log?

---

<div class="post-metadata">

### Author: ![clay](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/clay/32/8248_2.png) [@clay](https://community.localwp.com/u/clay)
#### Post date: [May 31, 2017, 3:56pm UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580/12 "2017-05-31T15:56:48Z")

</div>

You can find it by going to Help » Reveal Local’s Log on macOS. Then, you can upload it here or e-mail it to [clay@getflywheel.com](mailto:clay@getflywheel.com).

---

<div class="post-metadata">

### Author: ![eric](https://avatars.discourse-cdn.com/v4/letter/e/898d66/32.png) [@eric](https://community.localwp.com/u/eric)
#### Post date: [May 31, 2017, 4:01pm UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580/13 "2017-05-31T16:01:36Z")

</div>

Thanks @clay email should be with you

---

<div class="post-metadata">

### Author: ![mitch827](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/mitch827/32/4382_2.png) [@mitch827](https://community.localwp.com/u/mitch827)
#### Post date: [May 31, 2017, 5:05pm UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580/14 "2017-05-31T17:05:09Z")

</div>

hi @clay I have the same exact problem  
 ![](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/1X/e6475823548b866b58dbde051cda8fa44e1f0464.png)

I tried to reset the images in Virtual Box, but it was already stopped. So I restarted wit no success.

I tried also with instructions in this post: [https://local.getflywheel.com/community/t/sites-refusing-to-start-after-latest-update-2-0-1/1568](https://local.getflywheel.com/community/t/sites-refusing-to-start-after-latest-update-2-0-1/1568) but with no success.

Don’t know what to do. Please help.

This is my log:  
[local-by-flywheel.log](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/1X/094b0ef8dfe6eecf695c671b8efb47709c295b63.log) (13.2 KB)

---

<div class="post-metadata">

### Author: ![clay](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/clay/32/8248_2.png) [@clay](https://community.localwp.com/u/clay)
#### Post date: [May 31, 2017, 5:09pm UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580/15 "2017-05-31T17:09:01Z")

</div>

Hi @mitch827,

Thanks for the info!

We’re currently looking into this issue and hope to have a solution soon.

---

<div class="post-metadata">

### Author: ![scottwyden](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/scottwyden/32/4743_2.png) [@scottwyden](https://community.localwp.com/u/scottwyden)
#### Post date: [May 31, 2017, 5:20pm UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580/16 "2017-05-31T17:20:02Z")

</div>

I have the same 500 code issue.

---

<div class="post-metadata">

### Author: ![hoangsa2t](https://avatars.discourse-cdn.com/v4/letter/h/898d66/32.png) [@hoangsa2t](https://community.localwp.com/u/hoangsa2t)
#### Post date: [June 1, 2017, 7:06am UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580/17 "2017-06-01T07:06:04Z")

</div>

> [@hoangsa2t](#):
>
> Local by Flywhee

Thanks @clay

I tried re-install Local by Flywheel and now i stuck on “Local Image” setup step.

```
Jun 1, 2017, 1:59 PM GMT+7 - info: [main/docker-create-machine] null 'About to remove pressmatic\nWARNING: This action will delete both local reference and remote instance.\n' 'Error removing host "pressmatic": Host does not exist: "pressmatic"\nCan\'t remove "pressmatic"\n'
Jun 1, 2017, 1:59 PM GMT+7 - info: [main/docker-create-machine] Creating Docker Machine... --virtualbox-boot2docker-url=file:///Applications/Local by Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/boot2docker.iso
Jun 1, 2017, 1:59 PM GMT+7 - info: [main/docker-create-machine] Creating machine with  
{ '0': 'create',
  '1': '--driver=virtualbox',
  '2': '--virtualbox-hostonly-cidr',
  '3': '192.168.86.1/24',
  '4': '--virtualbox-boot2docker-url=file:///Applications/Local by Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/boot2docker.iso',
  '5': '--virtualbox-disk-size',
  '6': '120000',
  '7': 'local-by-flywheel' }
Jun 1, 2017, 1:59 PM GMT+7 - error: [main/docker-create-machine] Host already exists: "local-by-flywheel"
Jun 1, 2017, 1:59 PM GMT+7 - info: [main/docker-create-machine] Unable to create Docker Machine.

```

---

<div class="post-metadata">

### Author: ![eric](https://avatars.discourse-cdn.com/v4/letter/e/898d66/32.png) [@eric](https://community.localwp.com/u/eric)
#### Post date: [June 1, 2017, 9:54am UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580/18 "2017-06-01T09:54:11Z")

</div>

This is what I get with 1.4.2 now. @clay have you made any progress on this as I am still trying to get it up and running?  
Thanks in advance for the update.  
 ![](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/1X/7c431f2b8f7be56aa2096997213d0135ebfa377f.png)

---

<div class="post-metadata">

### Author: ![clay](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/clay/32/8248_2.png) [@clay](https://community.localwp.com/u/clay)
#### Post date: [June 1, 2017, 9:26pm UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580/19 "2017-06-01T21:26:13Z")

</div>

Hi all,

2.0.2 for macOS is now available.

Please see [https://local.getflywheel.com/community/t/local-by-flywheel-2-0-2-macos-only](https://local.getflywheel.com/community/t/local-by-flywheel-2-0-2-macos-only)

---

<div class="post-metadata">

### Author: ![eric](https://avatars.discourse-cdn.com/v4/letter/e/898d66/32.png) [@eric](https://community.localwp.com/u/eric)
#### Post date: [June 2, 2017, 10:21am UTC](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580/20 "2017-06-02T10:21:25Z")

</div>

@clay Still no luck trying to import my site and nothing happened. Now the application just crashes when I try to start it!

[Next page](https://community.localwp.com/t/error-when-starting-site-http-code-500-server-error/1580.md?page=2)
