Local Community

Failed to obtain access token while logging in to local

My local for Windows not logging me in so I can’t use the live link function. What could be the issue? I’m using the latest local version 6.1.1+5468, encountered this error for the first time on this version of local

Hey @Localisation, Welcome to the Local Community Forums and sorry you’re encountering this!

Can you please provide your Local Log? See this Community Forum post for instructions on how to do so:

As an added way for us to get a better idea of what’s going on, can you record a short screencast for us to see what’s happening?

Hey @ben.turner, attached are my local logs as well as the error message on my screen

local-lightning.log (578.4 KB) error.log (905.8 KB)

Thanks for the screenshot! I haven’t seen that error before. Can you describe your environment a little more?

You mention that this is a Windows machine. What browser is that? MS Edge? Firefox?

If you have a different browser, can you try logging into your Local account using that browser?

Also, since the message deals with access tokens, I wonder if there’s something stripping out those values.

Do you have any antivirus or privacy software that might be stripping out cookies or session tokens? Maybe even a VPN installed?

I am having a similar error, in my case I assumed it might have come from having two accounts and trying to authenticate with one.

But has any resolution been found?

Getting the same error when trying to log into Local. I’ve tried restarting my Mac and Local…Magic Sync is off from a previous issue pushing. No dice. Any pointers?

local-lightning.log (665.8 KB)

We’re still not able to reliably replicate, but can you try activating the Local Web account again?

If you still have issues, can you try installing the latest version of Local and see if that fixes things?

If you still have issues, the latest version of Local, has a “Download Local Log” button on the “Support” tab. Can you upload the file that Local creates after clicking that button?

Thank for providing that Local log! The errors I’m seeing in the log seem to indicate some general network issues. For example, here’s on line that stands out to me:

{"thread":"main","reason":{"name":"InternalOAuthError","message":"Failed to obtain access token","oauthError":{"errno":-60,"code":"ETIMEDOUT","syscall":"connect","address":"","port":443}},"p":{},"level":"warn","message":"Unhandled Rejection.","timestamp":"2021-11-15T03:10:51.697Z"}

Note the part that says ETIMEDOUT – I think that could be general network issues and might be resolved.

Can you try activating your Local Web account again using the latest version of Local? If you still have issues, can you provide the zip file that you get when clicking the “Download Local Log” file from the “Support” tab of Local?

I’m having the same issues when trying to log into Local on Windows.

local-lightning.log (3.4 KB)

I’m having the same issue. I’m thinking it is associated with the zScaler proxy we are using. Can you tell me how we can add the local zScaler certs or what needs to happen to fix this? I think it’s this because when we disable zScaler it works.

Having the same issue here on my Windows 10 as well, please localwp help us fix this issue. Thanks!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.