Local Community

How do you add SSL on a Live Link?

I can’t use Live Links on mobile as SSL doesn’t work.

As far as I know, I can’t add SSL to a localhost page.

How do you add SSL to your pages on WIndows 10?

The latest version of Local gives you Live Links over HTTPS.

Just Create a Local Account and then Download the latest version of Local (at least 6.0.0)

If you have those things in place and you’re still running into problems, can you give us a little more info?

  • What version of Local are you using?
  • What Operating System and OS version is being used?
  • Can you please provide your Local Log? See this Community Forum post for instructions on how to do so:
  • Does this happen for all sites in Local, or just one?

Hm, yeah the SSL doesn’t seem to work as intended.

I’ve tried setting it up with the Really Simple SSL plugin but I get a cURL error 60 on all sites I try to create and background images doesn’t show up on mobile devices.

Local 6.0.0 (Signed in)

  • Windows 10 19041.1

It happens to all mobile sites, the desktop versions work fine.

local-lightning.log (255.1 KB)

What happens if you avoid using the Really Simple SSL plugin and instead update the urls within the database so that they are using the correct protocol?

The easiest way I know to make that update is to:

  1. Right-click on the site and select “Open site shell”
  2. Update the urls with wpcli:
wp search-replace 'http://example.local' 'https://example.local'

When I did that and tried to access my site using the default WordPress theme over a Live Link, everything was working as expected – secure lock in my Android browser.

To be explicit, here’s what I did:

  1. Create new WordPress site in Local
  2. Trust the site’s SSL certificate
  3. Search/Replace the url with the database
  4. Enable Live Link
  5. Access site from mobile device over Live Link

The command finished with 0 replacements. Looks like there’s some missing modules when I try to run that command.

I will try setting up a new site and test your command again.

Set everything up again, fixed an issue in the php.ini and ran the CLI.
Got 0 replacements with the command.

Got closer - This time the page loads, but I get I get mixed encryption status message for SSL on mobile browsers and background images are still not visible.

Also, no Really Fast SSL plugin is installed this time.

1 Like

SSL seem to be working now, but I still have issues with background images not showing up on mobile.

Nice! Good job sticking with it!

For the images that aren’t showing up, are you using something like a page builder to lay out the page?

Also, is it only on mobile, or do you have the same missing images if you try and access the Live Link from another computer?

Sometimes various page builders will save the css style rules for background images to a file on disk, and so if the style rule is referenceing example.local then those images won’t show for a site that is accessed over a Live Link. I think Local can handle this sort of thing in most cases, but it’s possible that this is an edge case for something where the background image is saved in a way that Local isn’t aware of.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.