# HTTP code 500) server error - Unknown runtime specified default

**URL:** https://community.localwp.com/t/http-code-500-server-error-unknown-runtime-specified-default/2766
**Category:** Support
**Created:** [August 31, 2017, 1:59pm UTC](https://community.localwp.com/t/http-code-500-server-error-unknown-runtime-specified-default/2766 "2017-08-31T13:59:01Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![jeremyjosey](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/jeremyjosey/32/5014_2.png) [@jeremyjosey](https://community.localwp.com/u/jeremyjosey)
#### Post date: [August 31, 2017, 1:59pm UTC](https://community.localwp.com/t/http-code-500-server-error-unknown-runtime-specified-default/2766/1 "2017-08-31T13:59:01Z")

</div>

Hi I moved from pressmatic to local today. My Sites won’t start i get the following error HTTP code 500) server error - Unknown runtime specified default . Any help would be appreciated. Thanks

---

<div class="post-metadata">

### Author: ![clay](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/clay/32/8248_2.png) [@clay](https://community.localwp.com/u/clay)
#### Post date: [August 31, 2017, 8:29pm UTC](https://community.localwp.com/t/http-code-500-server-error-unknown-runtime-specified-default/2766/2 "2017-08-31T20:29:01Z")

</div>

Hi Jeremy,

Please see [https://local.getflywheel.com/community/t/cant-start-any-existing-machines-after-upgrading-to-local-2-0-for-mac/1541/6?u=clay](https://local.getflywheel.com/community/t/cant-start-any-existing-machines-after-upgrading-to-local-2-0-for-mac/1541/6?u=clay)

You may need to swap out `local-by-flywheel` with `pressmatic`

---

<div class="post-metadata">

### Author: ![jeremyjosey](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/jeremyjosey/32/5014_2.png) [@jeremyjosey](https://community.localwp.com/u/jeremyjosey)
#### Post date: [September 2, 2017, 1:36pm UTC](https://community.localwp.com/t/http-code-500-server-error-unknown-runtime-specified-default/2766/3 "2017-09-02T13:36:38Z")

</div>

Hi Clay , i get this message when i try and view the thread

Sorry, you don’t have access to that topic!

---

<div class="post-metadata">

### Author: ![clay](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/clay/32/8248_2.png) [@clay](https://community.localwp.com/u/clay)
#### Post date: [September 5, 2017, 1:51pm UTC](https://community.localwp.com/t/http-code-500-server-error-unknown-runtime-specified-default/2766/4 "2017-09-05T13:51:52Z")

</div>

Hi Jeremy,

Sorry about that! Here are the steps:

1. Open Terminal

2. Run `eval $(/Applications/Local\ by\ Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine env local-by-flywheel)`

3. If you get an error on step two, run the following command and then repeat step #2: `/Applications/Local\ by\ Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine start local-by-flywheel`

4. Run `/Applications/Local\ by\ Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker run --rm -v /var/lib/docker:/docker cpuguy83/docker112rc3-runtimefix:rc3`

Also, you may need to swap out `local-by-flywheel` with `pressmatic` if you were an early Pressmatic user.

Once you run those commands, you can re-open Local.

---

<div class="post-metadata">

### Author: ![system](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/system/32/1_2.png) [@system](https://community.localwp.com/u/system)
#### Post date: [August 25, 2020, 6:32pm UTC](https://community.localwp.com/t/http-code-500-server-error-unknown-runtime-specified-default/2766/5 "2020-08-25T18:32:33Z")

</div>


