I cannot login to wordpress admin or wordpress sub-pages

Hi @Nick-B ,

I have used incognito browsing to try to log in before and I still cannot log into Wordpress.

I do not know how to login using a VPN.

I just created another new blank site, with a correct user name and password, but I am now getting an error message saying my password is incorrect, which it is not incorrect.

For the first site I created, when I login with the correct user name and password, nothing happens. The screen acts like it is going to let me in, but nothing happens. I do not even get an error message from it.

Hi @mrdurham

Can you share some further details here?

  • What is your OS?

  • What version of Local are you on?

  • Please attach a copy of your Local Logs

Keep us posted and we’d be happy to help further!

I am using Windows 10 Pro OS. The Local version I am using is 7.1.2+6410

local-logs.zip (71.6 KB)
I have attached the local logs file to this message as you have requested. Thank you.

If you change your Router Mode to Localhost are you able to get through to your site? This would be under Preferences>Advanced>Router Mode

It seems like you might have something blocking requests. This could another developer program or maybe a security feature.

I changed the preference to router mode. When I try to go to the WP Admin login screen I get this message

This site can’t be reached

testing-only-can-delete.local refused to connect.

Try:

ERR_CONNECTION_REFUSED

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

Do you have any antivirus, security, or firewall applications that could be blocking Local?

Check out these articles for further testing if you’re not sure:

I am not running any other developer apps like MAMP, XAMPP, or Docker.

I checked my firewall, and both mailhog and local all have green checks.

I used one-click-admin for the new site I created and I was able to login. If I turn this off, I will not be able to log in. If I create a new child site within wordpress, I will not be able to log into it at all.

It sounds like you’ve been working on a multisite install for your project is that right?

But even if you create a new blank site in Local that won’t let you login? Or have you only been testing making subsites?

For the first site I created, it is for a WP Developers course. I have the main site, a fictional university site. I can only login to the university site using the one-click-admin. I created one other site within the university site. There is no way to log into it because it resides within the main university site. The secondary site is like a user who is a part of the university. I cannot login to the user site.

I created a totally new site today and once again, it is a main site, and I can only login to it with the one-click-admin turned on.

Have you tried using the workflow outlined here to create new users or update passwords via WPCLI?

I tried it and I can now log into the new website I created yesterday, but for the fictional university site, I still cannot log in.

I’ve noticed that the new website that I created yesterday had an email of dev-email@wpengine.local. The fictional university site that I have has one of my personal gmail email addresses, and a fictional email address.

What did you try to do for the website you cannot get into? Did you try creating a new user or just changing the password? If you haven’t tried it, I would test using the workflow at the bottom of the article to create a new user:

Create a New User

I tried changing the current password for my fictional university site. I will try to create a new user for my fictional site.

I created a new username and password for the fictional university website and I still does not work. After I created the new username and password, I tried to change the password from the instructions of the page you told me to go to and I still cannot log in.

With the new user credentials are you able to test in a different browser or incognito window to rule out caching?

If you Start Site and then go to the Database Tab and Open Adminer, is there a Users table in the database?

I tried to log in using incognito mode and also using another browser and I still cannot log in.

There is a table called wp_user on the adminier screen

Does the site you can’t log into have any plugins on it?

Yes, it has some WP plug ins on it

Are there any security plugins or user/role manager ones? If you open site shell you should be able to run wp plugin list to see everything. As a test, you could also run wp plugin deactivate --all and then see if you’re able to login with all of the plugins deleted. That will show whether or not a plugin has been blocking progress here.

I have one that manages user roles