Local Community

I recently upgrade Local and now I can´t access my website or WP control panel

I´m not an expert so if you can help me the easiest way possible I´ll be grateful.

It says that “.local rejected the connection”, and in the browser something like (.local/?cache-buster=1382)

It started after I upgrade the new version of Local, By the way the live link is working.

Please HELP!

Hey @leoramos, Welcome to the Local Community Forums!

Do you have a screenshot of the browser when you see that error so we can get an idea of where the error is coming from?

Can you also please provide your Local Log? See this Community Forum post for instructions on how to do so:

Hi Ben,

Thanks for your quick response

I attached the Screenshots you request and the Local´s Log.

I Hope you can Help Me!!

Thanks again

local-lightning.log (152 KB)

Looking at the Local log, I’m seeing a line that looks like this:

{"thread":"main","class":"","stack":"Error: Command failed: %%resourcesPath%%/lightning-services/mysql-8.0.16+5/bin/darwin/bin/mysqld --defaults-file=%%site.runData%%/conf/mysql/my.cnf --initialize-insecure\ndyld: Library not loaded: @loader_path/../lib/libssl.1.0.0.dylib\n  Referenced from: %%resourcesPath%%/lightning-services/mysql-8.0.16+5/bin/darwin/bin/mysqld\n  Reason: no suitable image found.  Did find:\n\t%%resourcesPath%%/lightning-services/mysql-8.0.16+5/bin/darwin/bin/../lib/libssl.1.0.0.dylib: code signature invalid for '%%resourcesPath%%/lightning-services/mysql-8.0.16+5/bin/darwin/bin/../lib/libssl.1.0.0.dylib'\n\n\t%%resourcesPath%%/lightning-services/mysql-8.0.16+5/bin/darwin/bin/../lib/libssl.1.0.0.dylib: code signature invalid for '%%resourcesPath%%/lightning-services/mysql-8.0.16+5/bin/darwin/bin/../lib/libssl.1.0.0.dylib'\n\n\n    at ChildProcess.exithandler (child_process.js:304:12)\n    at ChildProcess.emit (events.js:223:5)\n    at ChildProcess.EventEmitter.emit (domain.js:475:20)\n    at maybeClose (internal/child_process.js:1021:16)\n    at Socket.<anonymous> (internal/child_process.js:430:11)\n    at Socket.emit (events.js:223:5)\n    at Socket.EventEmitter.emit (domain.js:475:20)\n    at Pipe.<anonymous> (net.js:664:12)","level":"error","message":"Unable to provision site.","timestamp":"2020-10-16T21:43:07.518Z"}

Note this part:

Library not loaded: @loader_path/../lib/libssl.1.0.0.dylib

This makes me think that there might be some missing libraries.

What version of macOS is installed?

One other question – do you get the same result if you try a different browser like Chrome?

I am getting the same behavior. Recently updated to latest version of Local on macOS 10.13.6 and neither local site nor WP-Admin load in Google Chrome. Getting ERR_CONNECTION_REFUSED

Same issue, here. running 10.13.16 - same error code.

UPDATE: After creating a “deleteme” test project in local, from scratch (which fired up fine) - the other sites seem to be running fine. :man_shrugging:

Happy holidays, ya’ll.

2 Likes

major thanks + cheers to you @aelonrench.
this solved the issue for me as well.

yikes.

This was the perfect solution!!!

Thanks!and Merry Christmas

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.