Local Community

Imported site not working (The requested URL was not found on this server)

I am new to Local.
I just imported my “live” site into Local, the import process went fine, but only the “Home” page of my local version is working, and none of the other pages/links do!?.
I get the “The requested URL was not found on this server error”) if I try another page/link.
I have a feeling that it has to do with “permalink” and or caching, but I can’t even get to the “Admin” login page of the local site to do anything, as if I try the Admin page link, I get the same error (The requested URL was not found on this server).
How do I fix this issue, please ?

I checked the local Apache config file (“apache2.conf.hbs” in …/conf/apache directory
and I see the “AllowOverride All” is there

Options FollowSymLinks AllowOverride All Require all denied

@rbeheshti I’m not sure if it helps, but try to add those two lines to your wp-config.php:

define( ‘WP_HOME’, ‘http://example.com’ );
define( ‘WP_SITEURL’, ‘http://example.com’ );

Of course you need to change example.com with your local domain name. Once you do that you should be able to get into dashboard. Install Velvet Blues plugin from WP repository and change your site urls there as well. Then reload your permalinks. After all of that done delete or comment out those two lines of code you initially wrote inside your wp-config.php.

Hope that helps. If not I’m out of ideas, sorry.

1 Like

Do you have a screenshot of the error?

The error message you mention sounds like the default error message for an Apache server. Local has its own settings that relate to error pages, so this makes me wonder if a different version of Apache is serving up the response.

One other thing – Can you please provide your Local Log? See this Community Forum post for instructions on how to do so:

This happened to me again, I forgot I had already posted about it, and saw this thread.

This can be fixed by toggling the web server to nginx and back to apache.

I don’t have a great reason to use apache if it is going to act like this, I’m just trying to mimic the production environment as closely as possible.

@ben.turner I have a copy of the local-lighting.log where this should have happened in the last few minutes. Is there a way to get it to you other than posting here?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.