Local Community

Live link is throwing an error when I attempt to enable it

I received the following error when attempting to enable the Live Link feature. It worked previously and I changed nothing in the configuration.

Error: connect ECONNREFUSED 34.121.54.145:443

at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1146:16)

1 Like

Hi all! Thank you for bringing this to our attention so quickly - I merged several different threads in the forums into here so that we keep conversation in the same place.

This is an initial “ACK” to the issue. It looks like something changed on our remote infrastructure sometime this morning that started refusing connections.

The engineering team is on it, and I will post updates back here as I have them.

7 Likes

Updating here - we’re digging into some errors in our remote infrastructure that show the connection being refused. Based on the documentation, we think the issue lies in the API between Local and the remote server, but we haven’t pinpointed it yet. We’re going to keep researching.

Sorry in advance for the down-time here! I understand the frustration.

7 Likes

Thanks for the update! Hopefully, it resolve soon.

1 Like

I’m having the same issue. Thank you for looking into it! Look forward to it being resolved.

1 Like

Same issue here, I have got local updated and my operating system Mac 12.5.1 Monterey.

1 Like

Hello, I’ve a problem with starting Live Links. It started yesterday and when I click on Enable after 1 or 2 minutes, Local give me this error. It happens on all of my website installed. My connection works very well and I can’t figure out where is the problem. Someone can tell me something about and how to fix this?

See this topic: https://community.localwp.com/t/live-link-is-throwing-an-error-when-i-attempt-to-enable-it/33166/14

I think it’s due to an expired SSL certificate as there’s a closed topic about a similar issue from last September.

This is the error I’m getting.

Screenshot 2022-09-11 at 19.41.07

Hello @Tegolante - welcome to the Local community! :wave:

Thank you for sharing your issue! It looks like something changed on our remote infrastructure sometime last week that started refusing connections.

The Local team is looking into it, we’ve been merging all related threads into the following to keep conversations in one place:

I invite you to follow along there!

Thank you,

Sam

Issue Summary

When I click on ‘enable live link’, after a time I get the following error message:
“Error: connect ETIMEDOUT 34.121.54.145:443
at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1146:16)”

yesterday I wanted to continue working on the construction of my site locally, and impossible to activate live link. I imported the site, nothing.

Troubleshooting Questions

Does this happen for all sites in Local, or just one in particular? All sites

Are you able to create a new, plain WordPress site in Local and access it in a Browser? Yes

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!
System Details

Which version of Local is being used? 6.4.2

What Operating System (OS) and OS version is being used? Windows 10 Family


Attach the Local Log. See this Help Doc for instructions on how to do so:

local-lightning.log (282.2 KB)

1 Like

Hey all - we’ve worked with our remote infrastructure partner (Google), and traced the issue to a mismatch in some API versioning. We’re getting this fixed up and should have an update here shortly.

6 Likes

Same for me as of 13:00 9/9/2022. I got the following error when I tried to enable the Live Link feature. It was working before and I didn’t change anything in the configuration.
Error: Connect ECONNREFUSED 34.121.54.145:443
at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1146:16)

Mac OS Monterey
Apache
PHP 7.4.1
MySQL 8. 0.16

1 Like

When I try to use the Live Link option, this error comes up:
connect ETIMEDOUT 34.121.54.145:443 at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1146:16)

Tried changing PHP version or Web server, nothing worked.

Windows 10, Local version 6.4.1
Screenshot_22

2 Likes

I think I’m getting a similar error to everyone else in this thread. Below is my error. Logs attached.

Error: Client network socket disconnected before secure TLS connection was established
at connResetException (internal/errors.js:607:14)
at TLSSocket.onConnectEnd (_tls_wrap.js:1544:19)
at TLSSocket.emit (events.js:327:22)
at TLSSocket.EventEmitter.emit (domain.js:467:12)
at endReadableNT (internal/streams/readable.js:1327:12)
at processTicksAndRejections (internal/process/task_queues.js:80:21)
local-lightning-verbose.log (251.4 KB)

Would love a status update. This is seriously impacting my workflow.

1 Like

LiveLink-Error

Having the same issue. Hope you resolve it soon!

We’ve made the updates to the API and working on redeploying the servers that power Live Links, and we’re working with Google to make sure they come up appropriately and the errors we were seeing are resolved.

All hands on deck until it is resolved.

6 Likes

Any further updates on this?

1 Like