Local Community

Local is requesting administrative privileges to modify your /etc/hosts file.

Local is requesting administrative privileges to modify your /etc/hosts file.

what must I do?

Hey @Casi, Welcome to the Local Community Forums!

The Hosts file is a file that lets the computer know where to look for a site when you try to access it in a Web Browser. You should let Local do that if you are wanting Local to register human-readable domains like mysite.local to your computer.

You can always prevent Local from doing that, however, if you do, then you’ll need to manually add those domains to the hosts file.

Thank You Ben. I still do have the following message on top of the page (see screenshot). I can hit the button TRUST but nothing is changing. Can you advise?

PS: I love this application!!

Screenshot_1|690x28

Thanks for taking Local for a spin and I’m glad you like it!

If the Local site is using HTTPS, you’ll also need to click the “Trust” button. This basically creates an SSL certificate and registers it with your computer’s browsers.

For more info about SSL and how Local helps you out, see this help doc: https://localwp.com/help-docs/ssl/ssl-in-local/

Thank you Ben. The problem is I can press this button as many times and actually, nothing happens. It is simply remaining there…

Can you give a little more detail about the system that Local is running on?

  • What version of Local are you using?
  • What Operating System and OS version is being used?
  • Can you please provide your Local Log? See this Community Forum post for instructions on how to do so:
  • Does this happen for all sites in Local, or just one site in particular?
  • What version of Local are you using? 6.0.0+5444
  • What Operating System and OS version is being used? Win10
  • Can you please provide your Local Log? See this Community Forum post for instructions on how to do so: Attached
  • Does this happen for all sites in Local, or just one site in particular? All sites. I have to press the SSL button every single time once to engage SSL which then works. But the HOST button on the top appears later and I can press as many times for any local sites and it simply remains (nothing happens)

I might be missing something, but I’m not seeing that Local log. Can you try re-uploading it to this topic?

This sounds like expected behavior. You do need to click the “trust” button in order for the SSL certificate to be created for a site.

If I’m thinking about it correctly, that button shows when the url within the DB doesn’t match what it should be. In order for me to visualize a bit better, can you record a screencast of the behavior that you’re seeing?

My apologies Ben, I forgot to add the log file. This time it is attached and a screencast as well. Hope 3MB will go throughlocal-lightning.log (393.0 KB) ? I trust this is a private ticket and not open to the public?

ok, mp4 I cannot upload, let me add a link to youtube: https://youtu.be/2hdoZx3t6LU

Kind regards
Thomas

I’m not seeing anything obviously preventing the url from being updated. One thing I do see is that for some reason, access is being denied to the database for the root user on localhost:

{"thread":"main","service":{},"serviceBinVersion":{},"stack":"Error: Command failed: %%resourcesPath%%\\lightning-services\\mariadb-10.4.10+4\\bin\\win32\\bin\\mysql.exe --password= -e ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'root';\nERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)\r\n\n    at ChildProcess.exithandler (child_process.js:317:12)\n    at ChildProcess.emit (events.js:315:20)\n    at ChildProcess.EventEmitter.emit (domain.js:467:12)\n    at maybeClose (internal/child_process.js:1048:16)\n    at Process.ChildProcess._handle.onexit (internal/child_process.js:288:5)","level":"error","message":"Error setting up MySQL user","timestamp":"2021-07-24T07:07:39.162Z"}

That feels like the same issue as something like security setting or antivirus preventing Local from working with a site.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.