Local is too slow with wordpress and windows 10

This is really great info, thanks for sharing!

In addition to responding here in the forums, I’m trying to improve the automated testing Local has for the various build targets we support.

I’m curious how your are testing performance – is it mostly just a “it feels slow” process, or are you using some hard numbers, like a ?

Both are fine approaches, but in terms of trying to automate this sort of testing, I’d really love to zero in on a process that is scriptable and has real performance metrics associated with it.

I haven’t tried these tools under Windows yet, but in case you are inspired and curious about what I’m exploring, you might take a look at these two tools:

Well I am back on Local after Serverpress got unusable too. Local is currently loading pages between 1-2 seconds… so not as good as a linux droplet, but a big improvement from my earlier post! I think one thing that made a big difference was nuking my database and starting from scratch. Per the above suggestion I’ve also downgraded my PHP to 7.4.1.

It still feels like there’s a delay in resolving the DNS… but that’s purely a hunch since Query Monitor doesn’t say there are any slow queries or API calls (usually in Airplane mode)

I’m curious about the RAMdisk situation. 1. I can’t get it to run. and 2. doesn’t anything you store on RAM delete every time you shut down the computer? So wouldn’t you then have to reinstall Local every time you restart?

DNS feels like a good hunch, I’d also be curious about DB queries.

If you feel comfortable recording a screencast so I can see the specifics of your workflow, maybe I can spot something to help me replicate what you’re experiencing?

I’ve also successfully run WordPress on docker container while building plugins and all looks good and very fast too as I was running it on WSL2 on windows 10.

This way, I am able to use any version of WordPress I want and run as many as I want, and the speed is great.

So it solves the speed issue with local except that I’ve not been able to get xdebug to work with IntelliJ (my IDE) while running the docker containers.

For what it’s worth, one of the things that was making the sites crawl to a standstill was WooCommerce’s admin. As a Woo dev I always have Woo active and can’t disable the whole plugin

However, I installed Disable WooCommerce Bloat – WordPress plugin | WordPress.org and it helped IMMENSELY. I am running Local again on Win 11 and pages load normally again. I am still looking at running local in WSL though as that is blazing fast, but I can’t get site domains working just yet.

1 Like

Another problem I think I am noticing… when i trust the SSL for my site, Firefox is attempting to perform a TLS handshake which feels like it’s pretty slow. It’s also completely unnecessary since it’s a local site. So far I don’t see a way to disable that for a specific domain/cert without disabling it entirely which may not be the safest choice.

Since this thread seems active, I’ll throw in here too.

I’m running Local on three different Windows PC’s, I’ll provide specs below. On each one I’m experiencing drastic slowdowns with basic usage of Local and WordPress, I’ll also provide a list of common plugin/theme I use should that help diagnose the problem.

i7 8700K
Windows 11 Pro 21H2 (does not have WSL2 installed)

Laptop 1
i7 7820HK
Windows 10 Home 21H2 (has WSL2 installed, Ubuntu)

Laptop 2
i7 1065G7
Windows 11 Home 21H2 (has WSL2 installed, Ubuntu)

All three are running Local 6.3 and are logged in with a Local account (doubt this matters). In all cases, Local is installed on a different drive than the sites are stored on; this seems to mean that I must use Nginix instead of Apache as the web server of choice. My default setup is as follows:

Web server: Nginx
PHP: 7.4
Database: MariaDB 10.4.10

A typical WP install for me consists of the following:
WP Core
Current version (5.9.1 as of 2022-03-07)
Astra-child theme (usually setup by running wp scaffold child-theme)
Astra Advanced Addon
Beaver Builder
Ultimate Beaver Builder Addons
Disable Comments

There is also a warning that pops up when I create a new site saying that /etc/hosts can’t be written to. I’d read this is due to my antivirus/firewall; unless this is a performance problem, I have no problem editing C:\Windows\System32\drivers\etc\hosts myself to set: mysitename.local I trust the above mention of /etc/hosts is a placeholder from Mac/Linux systems? Or is Local actually unable to edit the hosts file on Windows?

Additionally, I notice when right clicking on a site in Local and choosing Open in Site Shell I’m prompted with a series of warning messages stating:

Setting Local environment variables…

WP-CLI: Warning: PHP Startup: Unable to load dynamic library ‘php_imagick.dll’ (tried: D:/Program Files (x86)/Local/resources/extraResources/lightning-services/php-7.4.1+16/bin/win64/ext\php_imagick.dll (The specified module could not be found.), D:/Program Files (x86)/Local/resources/extraResources/lightning-services/php-7.4.1+16/bin/win64/ext\php_php_imagick.dll.dll (The specified module could not be found.)) in Unknown on line 0
WP-CLI: WP-CLI 2.5.0
Composer: Warning: PHP Startup: Unable to load dynamic library ‘php_imagick.dll’ (tried: D:/Program Files (x86)/Local/resources/extraResources/lightning-services/php-7.4.1+16/bin/win64/ext\php_imagick.dll (The specified module could not be found.), D:/Program Files (x86)/Local/resources/extraResources/lightning-services/php-7.4.1+16/bin/win64/ext\php_php_imagick.dll.dll (The specified module could not be found.)) in Unknown on line 0
Composer: Warning: PHP Startup: Unable to load dynamic library ‘php_imagick.dll’ (tried: D:/Program Files (x86)/Local/resources/extraResources/lightning-services/php-7.4.1+16/bin/win64/ext\php_imagick.dll (The specified module could not be found.), D:/Program Files (x86)/Local/resources/extraResources/lightning-services/php-7.4.1+16/bin/win64/ext\php_php_imagick.dll.dll (The specified module could not be found.)) in Unknown on line 0
Composer: Composer version 2.1.5 2021-07-23 10:35:47
PHP: Warning: PHP Startup: Unable to load dynamic library ‘php_imagick.dll’ (tried: D:/Program Files (x86)/Local/resources/extraResources/lightning-services/php-7.4.1+16/bin/win64/ext\php_imagick.dll (The specified module could not be found.), D:/Program Files (x86)/Local/resources/extraResources/lightning-services/php-7.4.1+16/bin/win64/ext\php_php_imagick.dll.dll (The specified module could not be found.)) in Unknown on line 0
PHP: 7.4.1
MySQL: mysql Ver 15.1 Distrib 10.4.10-MariaDB, for Win32 (AMD64), source revision c24ec3cece6d8bf70dac7519b6fd397c464f7a82

Loaded Shell for Local Site: My Site

These same warnings will appear again when running most wp cli commands like “wp plugin list” I had thought any needed dependencies would be installed with Local for Windows; should these be installed externally?

On first load of a clean Local WP install, the page will load in 2 seconds or less. However, moving to /wp-admin to log in for the first time begins to cause slow down. Once the above plugins and child theme are activated, page navigation and saving can take anywhere from 2-10 seconds on average.

Are there any metrics or tools I can provide to assist in the diagnosis? It’s gotten to the point where any serious WP development I’m forced to move to a dev server rather than working locally which would be much preferred.

Thanks for your time

1 Like

It’s been several months, are we to assume this means Windows users should simply look elsewhere for their local development? I see in another thread the promise of finally updating PHP versions is in the works, but without an ETA is not encouraging.

I am a relatively new user to Local, however it does seem after the decision to make the product free was made, much of the development has either stopped or slowed. In the case of this issue, the only replies I’ve seen from the developers was more in confusion as to what the problem may be without any suitable method of testing/tracking performance.

1 Like

I have the same question as ArashiInteractive, above–should Windows 10 / Windows 11 users simply look elsewhere for their local development?

And does anyone have alternative suggestions for relatively easy to set-up local development environments? …Maybe Laragon? It has benchmarks specifically advertising it as faster than Local WP: Benchmark | Laragon - portable, isolated, fast & powerful universal development environment for PHP, Node.js, Python, Java, Go, Ruby.

Local WP is unusable in how slow pages load, unfortunately, and I’ve tried a lot of the suggestions in this thread, but none have worked. I had to purchase an additional server for dev and staging purposes, as real work on Local WP was impossible.

Hi guys, I have a simple but good solution that worked for me.

I had a similar issue with speed. The website (including wordpress dashboard) was so slow and I didn’t know what to do for roughly a couple of hours because it was fast.
I stumbled on this thread after I exhausted all my options in the site performance setting.

Just when I was about trying the first suggestion, the power was restored and I noticed a distinctive difference in speed. Hence, I experimented further to conclude that the speed of your local website is very much dependent on your processor’s speed.

To improve this:

  • Ensure your laptop isn’t on power saving mode when on battery
  • Or most preferrably, always use local with your laptop plugged to a power source.
    The difference in overall speed is night and day.

By the way, I am using an HP OMEN 17 with Intel Core i7 7700HQ (Windows 10 21H2). So I thought it would handle local pretty fine on battery but it didn’t.

I had a 10 second delay trying to resolve pages too. Windows 10, any browser. Was getting frustrated.

I created a new site “redesign”, with twentytwenty2 theme, no plugins and it was still slow. Redesign.local

Tried pinging my site like “ping redesign.local” and found it was taking a lot longer to resolve the IP than if I just typed “ping google.com”.

Found some general stuff on google regarding windows dns and “.local” stuff and delays for mac, windows, servers, etc…

Found that if I just changed the host name to “redesign.abc”, it renamed the site and the SSL and then came up immediately!

So after creating the sites, rename the extension from .local to .abc (or any other domain extension not in use), and it should work as expected.

Hope it helps.

It may be nice if the LocalWP people stop using “.local” by default.


Same here

Used local only with few sites during the last 1,5 years with win 10 and what a pain it has been!
first the sites stopped working
and now when I updated local to the most new (6.?) wp site tried to load with mysql and not mysqli.
After got it working the site loads 10 seconds! this is not a problem with the site, its old and simple site that should load in less than a second.

Seems like Local is not jus made for windows.

Anybody knows any good alternatives ?

I can confirm that this solution solved my slow site, and fixed my localhost:3000 live reloading website as well. Flywheel should choose a different default than .local going forward.

That works for me. Thanks ifsteve. I changed .local to .net. :crazy_face:

Confirming this solution has worked for me. After the longest time of having incredibly slow dev sites this simple change has completely sped up all my local sites. I used .localsite as the extension since I didn’t want to use a live TLD.

Recently tried localwp on a macbook and was amazed how fast it reacted to clicks. Was used to waiting at least 5 seconds for anything to happen on Windows.

Googled “windows slow dns localhost” and was eventually led to this article Configure IPv6 for advanced users - Windows Server | Microsoft Docs

Changed the dword value from hex 8 to hex 20, meaning “prefer IPv4 over IPv6”, and after a machine restart, my localwp is reacting to clicks like it should, without that weird delay.

1 Like

I too can confirm this works. My site is badly optimized and it took literally 30 secs on local for pages to start appearing. Changed the .local to other name like .localwp. Now it only took like 5 secs to load. Still slow but at least I can work figuring out what cause the slow load, much better than waiting 30 secs every time.

WooCommerce was having the same effect on my site, too. Just decactivated it and now the site is working normally on Local again.

Oh my goodness. Thanks for figuring this one out! The slow speed on Windows was driving me bonkers.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.