Local on Surface Pro 4 - Can't Install

Hey there,

I’ve been using Local for months now on my main development machine at the office and haven’t had any problems! It’s revolutionized my development cycle and I am so grateful.

Conversely, I’ve been trying to install Local on my home computer, which is a Surface Pro 4 running Windows 10 Pro. Here’s what I’ve tried so far (based on research from the forum):

  1. Uninstall and reinstall Local
  2. Uninstall Local and VirtualBox w/ Revo Uninstaller and Reinstall Local
  3. Uninstall VirtualBox with Revo and reinstall VirtualBox independently from Local, then install local
  4. Install Docker manually from their site.
  5. Hyper-V is turned off
  6. My computer runs NordVPN but I’ve tried it multiple times with the VPN turned off and the app off. I can’t imagine this is the issue though because my office computer has NordVPN as well and Local works when Nord is turned on.

Here’s the error I’m receiving constantly:
error: [main/docker-create-machine] Error creating machine: Error checking the host: Error checking and/or regenerating the certs: There was an error validating certificates for host “”: dial tcp connectex: An attempt was made to access a socket in a way forbidden by its access permissions.

Here’s my log:
local-by-flywheel.log (126.6 KB)

Help! I don’t know what to do and really really want Local on my home computer so I can develop my plugins at home!

Thanks guys and great work on an AWESOME product, one of the best I’ve used in many years that revolutionizes the way I work.


Hey @mintunmedia!

First off, welcome to the community! For your issue with Local on Surface Pro, a few possible troubleshooting ideas:

  1. Possibly related to internet security
  2. It might be worth trying to disconnect from the internet entirely and then running the Local installer


hi @NathanK, Sorry for the delay on my end, work has been nuts (a great thing!) I tried installing on my Surface with internet disconnected. The install worked great. However when I created my first site, I got through all the settings (enter username/password/email) and upon creating site, it gives me this error message:
Uh oh. It looks like we couldn’t retrieve the requested Docker image.

The first time I was disconnected from the internet, so I connected to the internet again and tried the install and still got the same error.

Thanks for the help!

1 Like

No worries @mintunmedia, we’re both working off of a delay! :joy: I’m glad to hear that work is good busy.

There should be a log line associated with that error. Would you be so kind as to reproduce that error and send over another log?