Local ran into an EPERM

I don’t speak english, but I need help when I try to get started local, in Windows 10, I get this error:

Uh-oh! Could not update hosts file
Local ran into an EPERM error when trying to update hosts file.
Please contact a support if this persists

Please help me

I understand that local is free, but a bit of support would be the least for credibility, after a week, you did not even dare to answer zero!

Même problème chez moi… Toujours en recherche de solution mais à voir les commentaires de beaucoup d’utilisateurs, c’est un problème récurrent…

J’ai trouvé !!!

In my context the issue was because of the host file was in read only.

To fix :

  • go on C:/Windows/system32/drivers/etc
  • Right clic on “Host” file
  • Properties
  • Cancel the selection of “read only”
  • Confirm admin rights
  • Retry to fix in LOCAL

Problem solved :wink:
3 days to find this “easy” thing…



Hi @IMone7,

Sorry for missing your post!

@audreysky’s solution should help out. Please let me know if otherwise.

I’m sorry but it still does not work the same mistake


Do you have any type of internet security, anti-virus, or anti-malware software other than Microsoft Defender?

Here I solved by disabling the antivirus. Tks

1 Like

I am also running into EPERM error at startup. I’ve tried disabling Norton AV and Firewall (although under the firewall rules, the Local by Flywheel has complete program access) and Malwarebytes, but so far I am unable to connect to my localhost or site.

What else can I do?

Solution was removing the “Read-Only” attribute from the "hosts file (ref. Help! I’m running into an EPERM error with the hosts file on Windows).

1 Like

I Got the solution by exclusion from Kaspersky Internet Security following this link


and added my local directory

C:\Users\“Your UserName”\AppData\Local\Programs\local-by-flywheel

and Voilla!!

Note: Replaced the “Your UserName” with your windows user account Name

Thank you it works very well

I’m on Windows 10, and on version 5.5.3+3667 of Local and came across this error when importing a new site. My hosts file was fine, my anti-virus was off, and still had the problem.

Since both of those things are related to permissions, my workaround was to run Local with Admin privileges and use the File > Import method instead of drag-n-drop import method. Worked smoothly then.

Thanks I solved…

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.