Local Community

Losing internet connection constantly

Hi. I’m using a late 2016 MacBook Pro 15" with all the latest OS updates (Mojave 10.14.5) and running the latest iteration of Local By Flywheel (3.2.1) to make my wordpress sites offline.

The problem I’m having is that I keep losing my wifi internet connection. Though I’m using Local By Flywheel (LBF) for offline wordpress website development, I still use the internet during that time. Only when I use LBF do I lose my wifi connection. I’ve that it always happens when I leave one location (work) and go to another location (home). Once I’ve changed locations, I open up my laptop to work and the internet connection is gone. Everything shows that I have an active wifi connection (full signal bars, etc.), yet nothing loads - no internet. The only solution that works is restarting my computer every time this happens.

I’ve been using your platform for about a year now and have just put up with this problem the whole time, but now that I’m ramping up my web development, I can’t keep losing time restarting my laptop and reloading all of my previously active applications because of LBF’s effect on my wifi connection.

And no, before you ask, I have no active plugins running on wordpress. Not yet.

Would love some help with this please.

Hey @seamus – welcome to the community forums!

Do you always need to restart the computer, or have you tried manually turning off Wifi and then turning it back on again?

What the description of this problems sounds like, is some sort of connection is still being registered with the computer’s Wifi driver and isn’t correctly being restored when on a new network.

There might not be much info in it, but can you please provide your local-by-flywheel.log file? See this Community Forum post:
How do I retrieve Local's log file? for instructions on how to do so.

Finally, one other question I would be curious about – do you have any sort of VPN software or something that might be handling the network connection besides the Operating System?

Let us know a little more detail about this setup and we should be able to get you pointed in the right direction!

Hey Ben. Thank you for your reply. Yes, I have to restart the computer. Turning the wifi off and then on again doesn’t fix the problem.

Here is the log file:

local-by-flywheel.log (734.9 KB)

And I do not normally use a VPN.

Let me know if you need any other info and thank you for your help :pray:t3:

The only other thing that I can think of is that somehow the virtual network is keeping the connection in a state that the OS thinks that you are connect to the Internet.

I wonder if using Local Lightning would fix this issue. If you are unfamiliar with what Lightning is – it’s the name of the Private Beta effort to remove VirtualBox and Docker as dependencies of Local.

If you’d like to take the Private Beta for a spin to see if the same issue is present, you can ask for access here:

Note that there are still bugs, since this is a piece of beta software, so be careful with having it be the main program for Local development at this time. That being said, if the issue doesn’t persist, then sometime soon, this issue won’t be a problem for you once Lightning moves out of Beta!

Hi Ben. I’m such a rookie in the realm of everything freelance and wordpress so using the beta is probably a bad idea. For example, I wouldn’t know how to use multiple platforms for development of the same site (in reference to your advice to not put all my eggs in the beta basket).

Recently I tried the following steps: Log out of wordpress, stop the site via FlyWheel, quit Flywheel, and then turn off my wifi before putting laptop to sleep to move locations. The step of turning off my wifi is something I hadn’t done previously and I think it did the trick as my connection worked fine for a couple days with multiple wifi connections and no resetting of the OS. It should be noted, I didn’t use FlyWheel at all during those couple of days. It wasn’t until I again used FlyWheel and forgot to take those steps that the problem repeated. So, I’ll keep testing and report back if the above mentioned steps are the solution.

I appreciate you sticking with me on this Ben :+1:t3:

1 Like