Lots of new errors creating new site

I’ve been happily using Local for years, with the latest versions on this Windows 11, and no recent issues. However, Local 10.1.1+6939 now seems to be grumpy about creating new sites. I’m trying to diagnose this but hoping for tips.

Error messages of interest when creating site for Apache/MariaDB/PHP 8.4 and 8.5:

  1. "AH00558: httpd.exe: Could not reliably determine the server's fully qualified domain name, using fe80::de55:5174:0000:ffff. Set the 'ServerName' directive globally to suppress this message"
    
  2. Access denied for user 'root'@'localhost' (using password: NO)","process":"mariadb"
    
  3. "Error setting up MySQL user"
    
  4. genericNodeError (node:internal/errors:985:15)
    
    • Why does an error that can be anticipated throw?
  5. --require=\"%%resourcesPath%%\\bin\\wp-cli\\local-wpcli-error-reporting.php\" Required file 'local-wpcli-error-reporting.php' doesn't exist (from runtime argument).\n\n    at WordPressInstaller.<anonymous> (%%appPath%%\\main\\sites\\wp\\WordPressInstaller.js:377:27)
    
    • OK, that one justifies a throw, and it’s what brought me here today. Research says that file might have been removed by Avast.

I run as administrator.
I disabled Avast (but the files are already gone).
Sites are being loaded to C: and all software and configs are there.
I’ve tried to use different PHP versions, hoping it would force a component re-install (without Avast interference) and use a new/different local-wpcli-error-reporting.php file.

I was tempted to re-install wp-cli and position it under resources … but I can’t find the resourcesPath that it needs! Also, that’s what this product does, so I won’t monkey with manual patches.

When the app complains that core/installed files are missing, I’m inclined to re-install the app. What terrifies me however is that I might lose configurations somewhere.

I’m hoping someone can verify that an uninstall/re-install will only update the software and not perform cleanup outside of the AppData/Roaming/Local folder tree.
OR - maybe there’s a patch mechanism or some other trick?

Thanks!


From local-lightning.log:

{"class":"Process","level":"warn","message":"Version: '10.6.23-MariaDB'  socket: ''  port: 10081  mariadb.org binary distribution","process":"mariadb","thread":"main","timestamp":"2026-08-11T20:11:45.300Z"}
{"class":"Process","level":"warn","message":"AH00558: httpd.exe: Could not reliably determine the server's fully qualified domain name, using fe80::de55:5174:0000:ffff. Set the 'ServerName' directive globally to suppress this message","process":"httpd","thread":"main","timestamp":"2026-08-11T20:11:45.888Z"}
{"class":"Process","level":"warn","message":"2026-08-11 13:11:46 4 [Warning] Access denied for user 'root'@'localhost' (using password: NO)","process":"mariadb","thread":"main","timestamp":"2026-08-11T20:11:46.507Z"}
{"class":"Process","level":"warn","message":"2026-08-11 13:11:46 5 [Warning] Access denied for user 'root'@'localhost' (using password: NO)","process":"mariadb","thread":"main","timestamp":"2026-08-11T20:11:46.548Z"}
{"level":"error","message":"Error setting up MySQL user","service":{},"serviceBinVersion":{},"stack":"Error: Command failed: %%userDataPath%%\\lightning-services\\mariadb-10.6.23+0\\bin\\win32\\bin\\mysql.exe --password= -e ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'root';\nERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)\r\n\n    at genericNodeError (node:internal/errors:985:15)\n    at wrappedFn (node:internal/errors:539:14)\n    at ChildProcess.exithandler (node:child_process:417:12)\n    at ChildProcess.emit (node:events:509:28)\n    at maybeClose (node:internal/child_process:1124:16)\n    at ChildProcess._handle.onexit (node:internal/child_process:306:5)","thread":"main","timestamp":"2026-08-11T20:11:46.553Z"}
{"class":"WordPressInstaller","level":"error","message":"Error installing WordPress","stack":"Error: ExecError: Command failed: \"%%userDataPath%%\\lightning-services\\php-8.4.16+1\\bin\\win64\\php.exe\" \"%%resourcesPath%%\\bin\\wp-cli\\wp-cli.phar\" --path=\"C:\\Users\\tonyg\\Documents\\LocalSites\\legends\\app\\public\" --require=\"%%resourcesPath%%\\bin\\wp-cli\\local-wpcli-error-reporting.php\" --skip-plugins --skip-themes \"core\" \"config\" --skip-check --dbname=local --dbuser=root --dbpass=root\nError: Required file 'local-wpcli-error-reporting.php' doesn't exist (from runtime argument).\n\n    at WordPressInstaller.<anonymous> (%%appPath%%\\main\\sites\\wp\\WordPressInstaller.js:377:27)\n    at Generator.throw (<anonymous>)\n    at rejected (%%appPath%%\\main\\sites\\wp\\WordPressInstaller.js:29:65)\n    at process.processTicksAndRejections (node:internal/process/task_queues:104:5)","thread":"main","timestamp":"2026-08-11T20:11:59.764Z"}
{"eventId":"3406176be60d4074b1e850782f62b93b","level":"warn","message":"Unhandled Rejection.","p":{},"reason":{},"thread":"main","timestamp":"2026-08-11T20:12:14.960Z"}

Regarding error #5. Yes, apparently Avast did recently delete that wpcli PHP file. I opened Avast Quarantine, restored the file, and Local created a new site.

I have not checked back yet for the other errors. I don’t care for now. I need to move forward.

I’m marking this as Resolved, leaving the other error notes for posterity.

Thank you for sharing updates here @TonyGman! Glad that you’re able to progress now.