Local Community

Mac High Sierra - Local hangs on "Starting up Site Services"

For those of you that are still around, can you help test something for me?

Is there any difference between creating a “Preferred” site and creating a “Custom” site? I’ve heard some reports that users have success creating a custom site under High Sierra.

In particular, can you try using an older version of MySQL – I’m wondering if there’s an issue with MySQL 8 on High Sierra.

Hi @ben.turner

I tried with following,

but same thing, cannot add a new site.

1 Like

@Demo – would be able to pass along your Local log for me to take a look at?

UPDATE
Have installed latest update (Version 5.7.2+4801) and I can now create new sites!

Here it goes @ben.turner.

local-lightning.log (17.1 KB)

@owenwestlake you are the MAN!!! Thank You Sooooooo Much! I was sitting and been pulling my hair (whatever is left) for the past 4 hours trying to figure out Now I can progress.

1 Like

Nice!! I’m glad the latest version of Local is working for you!

@Demo @Not2Day @dedevillela @mo7s @hovhanneshovakimyan – Can you try updating to the latest version of Local and see if that fixes things for you?

1 Like

Yup, the latest release fixes everything, thank you for your kindness and patience.

Edit: After shutting down the app, and reopening later, the bug remains… only creating a ‘dummy’ site finishes the previous site installation.

Any thoughts?

Best regards,
Andre

That’s very odd. When opening Local again, can you verify that it’s the latest version of Local?

One other question would be how the app is being shut down: are you quitting Local, or is there some other pattern to it, for example, is the computer being put to sleep before Local can fully quit?

1 Like

Just installed Local. Getting the following error similar to others in the thread. Running macOS High Sierra. version 10.13.6

Local Log
local-lightning.log (244.7 KB)

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

myusername       2626   0.0  0.0  4277540    720 s000  S+    1:02PM   0:00.00 grep mysql

Same problem here. macOS 10.13.6, Local 5.7.4+4876.

Already tried different environment setups, and all of them get stuck on this stage. Any updates on this?
For information, I can get the first site ready after creating a “throw-away” one.

Still experiencing the same issue after updating to Local 5.7.4+4876.

I’m on macOS 10.13.6

If I open cmd and type ps aux | grep mysql I get:

JMBP:~ myusername$ ps aux | grep mysql
myusername 85872 0.5 0.5 4539980 39668 ?? S 1:47AM 0:10.91 /Applications/Local.app/Contents/Resources/extraResources/lightning-services/mysql-8.0.16+5/bin/darwin/bin/mysqld --defaults-file=/Users/myusername/Library/Application Support/Local/run/xR5kc9k9i/conf/mysql/my.cnf
myusername 86351 0.0 0.0 4267768 828 s000 S+ 2:08AM 0:00.00 grep mysql


Also I got new error message that seems to be connected with the workaround mentioned in this thread. I previously created a site called “tester” and i was now creating site called “aefaef” with custom environment. Got the following error doing that:

I would also like to add one more thing I noticed:

When deleting a site and checking the “Move Site Files To Trash” checkbox, Local Lightning does not delete the app folder. I have to delete it manually for each site I remove from Local.

Also found out by examining the app/sql folder that the local.sql file says Lightning is using MySQL dump 10.13 Distribution 8.0.16 for macos10.14.

We are on macos10.13. Here’s a screenshot:

Hope any of this helps. Sorry for the long post and lots of edits.

Still getting the problem here.
Please, @ben.turner, can anyone help us with this?

I know that this isn’t really an answer, but is this still happening with the latest (5.9.0) version of Local?

Since this workaround seems to be working, that makes me think that there’s something preventing Local from cleaning up the MySQL sockets.

Can you please provide your Local Log? See this Community Forum post for instructions on how to do so:

The output from the terminal command you gave ( ps aux | grep mysql ) indicates that a MySQL process was running, but the popup dialog seems to indicate that Local is having issues connecting to the MySQL process.

In that screenshot, I don’t see any site called “Tester” in the sites list. Did you already delete it before creating the AEFAEF site?

Hi @ben.turner! Thanks for your response!

Yes, I can confirm that everything is fine with the 5.9.0 version.

1 Like

Hi @ben.turner

I just bought a new laptop and moved all my sites there. So now I’m running local on 2015 macbook pro and catalina instead.

No problems there.

I’m bit busy at the moment but i will try to remember install the latest local on the old laptop and will let you know how it went.

I’m glad it’s working on the new laptop. No need to dig in deeper on the old laptop unless you really want to!

Sometimes it’s best to just scrap the OS and start over! :smiley: