macOS Ventura WP-CLI fatal error TypeError: implode()

Hi @andfinally,
I bumped into this thread after having exactly the same error message - I am on mac Monterey 12.5.1.
In my case, I have been able to fix this after disabling the config file .bashrc which I had added recently to use it instead of .bash_profile. Obviously wp-cli did not like that change although both files have identical directives. Not sure what the difference between the two config files is but it worked again instantly. I hope that helps, Best, Henri

2 Likes

Hi @ben.turner, sorry for the slow response. Success! With the paths moved to .zprofile I’m able to run WP-CLI and the MySQL CLI. Really appreciate the effort you and everybody else has put into helping me with this. Thanks @wohlfarth, sounds like your experience with Bash was similar. Judging from Ben’s advice, when Local fires up a shell, it loads up its own profile, with paths pointing to its own PHP installation. Our global profiles were presumably overriding those paths.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.