Mailpoet not working on windows10 local

Issue Summary

I am running local 5.9.8+5191 on windows with php 7.4.1 and mariadb 10.4.10. Trying to install mailpoet version 3 on a clean wordpress website (from local installed). After installing mailpoet version 3 i am getting
MailPoet Error: Unable to connect to the database (the database is unable to open a file or folder), the connection is likely not configured correctly.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    Yes, for all website. in local. Don’t have it when i install mailpoet on my website with my hoster
  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    I can access wordpress with a clean installation but after installing mailpoet 3 on it i am getting this error


  • Create clean wordpress version 5.6 via local with php version 7.4.1. and mariaDB10.4.10
  • Login to wordpress and download and install mailpoet version 3
    -> see the error after activation

System Details

  • Which version of Local is being used?
    see above
  • What Operating System (OS) and OS version is being used?
    windows version 10
    Localfile: i don’t see any error in it

ok, did some research on this issue myself (know php and apache / mysql DB so …)

  1. if i use local and a mysql version 8.0 (so NOT a mariaDB) it is still not working on windows
  2. looking into the configuration files of local php and mariaDB tells my the patches are set like / where on windows it should be \ . Anyway… i know that windows can more or less work with both. But i try to change the patches… still not working
  3. next i was looking a the socket. After a lot of manuals i can tell that you don’t need to set the socket on windows. Next to this if you set localhost to mariaDB will by pass the socket (on any OS). Local already use next to this i have set this in wp_config.php (change localhost to but still not working.
  4. ok… change i connect to the mariaDB? Yes i can using DBeaver for example but is it possible through mysql prompt?
    Well…yes and no
    Yes i can run command like
    C:\Users\rijn2\Local Sites\agknew\app\public>mysql --host= --protocol=tcp --port=10010 test
    Welcome to the MariaDB monitor. Commands end with ; or \g.
    Your MariaDB connection id is 105
    Server version: 10.4.10-MariaDB binary distribution

Copyright © 2000, 2018, Oracle, MariaDB Corporation Ab and others.

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the current input statement.

MariaDB [test]>

but when i run
C:\Users\rijn2\Local Sites\agknew\app\public>wp db check****
i get
mysqlcheck: Got error: 2002: Can’t connect to MySQL server on ‘’ (10061) when trying to connect

  1. checking if the extention is loaded / installed which is default for local and to my believe (based on php.ini in the run directory) it loads
    (and i can see these files in the php directory as well)

  2. disabled my windows firewall and did a retry. Still same issue

So checked a lot but what did i miss?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.