"Missing Undefined" errors after update to 6.5.1

Issue Summary

After updating to Local 6.5.1 (Nov 2022 release), all sites (*except one) when clicked on in the left column now show a red header that warns of Missing Undefined v1.0, v8.0 and v.8.1. It says the issue will be resolved when I start the site but this is false. I’ve stopped and started all sites multiple times and quit the app. This warning does not go away.

Troubleshooting Questions

It happens for all sites except the one where I only have a blank Divi theme installed (no content).
It also happens whether the site is SSL (trusted) or not.


System Details

Local 6.5.1

Windows 11

Side Note: Even with 6.5.1, I still encounter issues with Connection not Private when trying to use SSL locally. Likely unrelated but just putting it in case. For this reason, I’ve gone back to not using SSL certificates on local for most sites.

Hi @metrosuperstar - this is a new one. Can you share your entire .zip log file as shown at the top of this doc? Retrieving Local’s Log File - Local You can download it quickly from the Support tab in the app.

This .zip will include some additional info on the services Local say it has/is missing.

Have you created any new sites with this version of Local?

Secondary question, to clarify - you mention the banner isn’t going away. Does the site load and operate normally? I’m trying to understand if this is impacting the site or if it is just the UI not dismissing the banner.

Hi Austin, thank you for looking into this.

Here is the full log as requested
local-logs.zip (50.0 KB)

Also, as per your request, I just tried to create a new site (based on my Wordpress and Divi blueprint) and the site does NOT have the issue.

As for the possibility that the banner may just not being going away for some reason on the sites that DO have content (posts, pages, plugins), it could be that it is just the GUI being problematic. The sites seem to be fine on both the WP backend AND the public side.

I look forward to hearing about your findings!

Of course, happy to help! Thanks for sharing that.

I think we traced this one down - an edge case we missed with that missing services banner. I compared the services you have to my own, and we have all the same things including being on the latest version.

If you open your sites.json file (this should live in %APPDATA%/Local on your machine), Local maintains a list of your sites and the services they reference. I’ve attached a picture of mine - as you can see, I have various services and all of them have a name field in the JSON. If you check yours, my hunch is your name field is missing for some reason. Am I right?

That banner relies on the name field being present, which we assumed should always be the case. If that isn’t true, the banner appears and shows the name “undefined” for everything it can’t find!

We can fix that and release a patch, the engineers are taking a look at it now. If you dismiss that banner, does it stay away or just come right back?

Thanks for your help in bringing this to us, we really appreciate it!

1 Like

Hi again - the banner will come back if I dismiss it. That’s what prompted me to create this thread. I thought that wasn’t normal.

But I think you’re right about the missing “name” fields, although on my end, it opens up as one long jumbo of text, whether I use Atom or Notepad++.

May I ask what software you are using to open it up (like your screenshot)? It would make it much easier for me to investigate…

@metrosuperstar You’re probably just needing some sort of JSON formatter. There are plenty out there; I am using Firefox to open the file, which does it by itself quite nicely.

1 Like

OK, here’s mine.
You were spot on.
Should I wait for the patched release or add the fields myself?

Sweet! Well, sweet that we understand it, not sweet the banner is annoying you :slight_smile:

Up to you - if you really want the banner gone, you can add those values, although that will be cumbersome. Or you can safely ignore it for now until the patch is out!

1 Like

I’ll keep an eye out for the patched version. Thanks for the quick action on this!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hi all,

I was DM’ing with the author here, but the fix for this issue is out and released with the latest Local version - www.localwp.com/releases/6.5.2 - and he has confirmed the issue is resolved.

I’ll mark this thread as solved!