No input file specified using PHP 7.3.5 or 7.4.1 ... 5.6.39 works

I upgraded to the latest version of Local and now my sites have stopped working with anything but PHP 5.6.39

Even clicking the info icon beside the PHP Version will only work if using 5.6.39.

Not sure what is going on here … was working with the previous version of Local 5.2.x I think


Never mind … changed the Web Server to Nginx and it works … guess I won’t be using Apache after all

Yes, it works with Nginx. But it would be nice to fix this problem on Apache server. Maybe someone know a solution?

This issue is still not resolved…
Another thread was created here: Error access with APACHE + PHP 7.4/7.3

Any ETA?

Using Apache, only sites that have PHP 5.6 work.
If PHP 7.4 / 7.3 is configured all pages return the message “No input file specified”.

It seems a common problem since there are other topics with the same problem:
Ref: No input file specified using PHP 7.3.5 or 7.4.1 ... 5.6.39 works

1 Like

Same story. This should be resolved…

Hey everyone, thanks for letting us know!

This should be working, and when I tried replicating on my version of Local 5.7.5 within MacOS Catalina – I was able to successfully create and use a WordPress site in Apache on each version of PHP.

There was an issue with older versions of the PHP service that Local uses. I know this isn’t as streamlined of a process as other things in Local, but can you try manually re-downloading the PHP service and let us know if that fixes things?

If that doesn’t work for you, can you help me understand a little more about the environment you are using so that I can try and replicate?

  • What version of Local are you using?
  • What Operating System and OS version is being used?
  • Does this happen for all versions of PHP or just one specific version?
  • Does the MySQL version matter?

I tried this idea of ​​removing the services and re-downloading them and had the same result.
My system in Windows anyway, so I don’t know if the same solution would apply.

Same issue here, Win10 running LocalWP 5.7.5+4909
NGINX works fine but Apache doesn’t, tried with PHP 7.4.1 and 7.3.5 it made no difference.
WP: 5.5.1
MySQL 8.0.16 and Maria 10.4.10 also makes no difference.

Same issue here as well; php 7.X.X only shows the ‘no input file specified’-message, directly after adding and starting a site.
Changes in the .htaccess file do not solve anything and switching to NGINX is not relevant for this project I’m working on.

Windows 10, LocalWP 5.8.2+4949

Same here…

My environment:

php 7.4.1
Windows 10

Hey @uniqueshort @duncank and @Zoker

Were you able to manually delete and re-install the PHP services as is outlined in the above FAQ doc?

If you have done that already and are still experiencing this, can you please provide your Local Log? See this Community Forum post for instructions on how to do so:

Also, can you provide a zip of the logs folder under the site’s folder? You should see logs next to app. This should allow us to get a better idea of what Apache is complaining about.

Hi Ben,

I’ve deleted and reinstalled apache and php, just to be sure, and the problem still remains.
Here are the requested logs:
local-lightning.log (160.9 KB) (1.6 KB)

BTW: you’re linking to a FAQ doc that only talks about Mac OS in a forum topic on windows problems. Also, the path to the log in the other FAQ doc you’ve linked is incorrect for Windows.

For the next one to see this:

For deleting Lightning Services on Windows, open the file explorer and enter this as the path:

And when you want to retrieve Local’s log, enter %Appdata%\Local\local-lightning.log

Thanks for the heads-up on those documentation pieces!

In the local-lightning.log file, I’m seeing a number of messages that relate to MySQL. For example, things like this:

mysqld: Could not create or access the registry key needed for the MySQL application
to log to the Windows EventLog. Run the application with sufficient
privileges once to create the key, add the key manually, or turn off
logging for that application.
2020-10-12T18:10:15.181160Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2020-10-12T18:10:15.181327Z 0 [Note] --secure-file-priv is set to NULL. Operations related to importing and exporting data are disabled
2020-10-12T18:10:15.181731Z 0 [ERROR] Cannot open Windows EventLog; check privileges, or start server with --log_syslog=0
2020-10-12T18:10:15.181762Z 0 [Note] %%userDataPath%%\\lightning-services\\mysql-5.7.28+4\\bin\\win64\\bin\\mysqld.exe (mysqld 5.7.28) starting as process 22396 ...
2020-10-12T18:10:15.196131Z 0 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2020-10-12T18:10:15.196167Z 0 [Note] InnoDB: Uses event mutexes
2020-10-12T18:10:15.196182Z 0 [Note] InnoDB: _mm_lfence() and _mm_sfence() are used for memory barrier
2020-10-12T18:10:15.196194Z 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
2020-10-12T18:10:15.197491Z 0 [Note] InnoDB: Number of pools: 1
2020-10-12T18:10:15.197780Z 0 [Note] InnoDB: Not using CPU crc32 instructions
2020-10-12T18:10:15.203283Z 0 [Note] InnoDB: Initializing buffer pool, total size = 32M, instances = 1, chunk size = 32M
2020-10-12T18:10:15.207333Z 0 [Note] InnoDB: Completed initialization of buffer pool
2020-10-12T18:10:15.599971Z 0 [Note] InnoDB: Highest supported file format is Barracuda.
2020-10-12T18:10:15.605271Z 0 [Note] InnoDB: Log scan progressed past the checkpoint lsn 3476900
2020-10-12T18:10:15.605303Z 0 [Note] InnoDB: Doing recovery: scanned up to log sequence number 3476909
2020-10-12T18:10:15.605325Z 0 [Note] InnoDB: Database was not shutdown normally!
2020-10-12T18:10:15.605335Z 0 [Note] InnoDB: Starting crash recovery.
2020-10-12T18:10:16.038454Z 0 [Note] InnoDB: Removed temporary tablespace data file: "ibtmp1"
2020-10-12T18:10:16.038491Z 0 [Note] InnoDB: Creating shared tablespace for temporary tables
2020-10-12T18:10:16.041365Z 0 [Note] InnoDB: Setting file '.\\ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
2020-10-12T18:10:16.375100Z 0 [Note] InnoDB: File '.\\ibtmp1' size is now 12 MB.
2020-10-12T18:10:16.402930Z 0 [Note] InnoDB: 96 redo rollback segment(s) found. 96 redo rollback segment(s) are active.
2020-10-12T18:10:16.402966Z 0 [Note] InnoDB: 32 non-redo rollback segment(s) are active.
2020-10-12T18:10:16.403637Z 0 [Note] InnoDB: Waiting for purge to start
2020-10-12T18:10:16.457324Z 0 [Note] InnoDB: 5.7.28 started; log sequence number 3476909
2020-10-12T18:10:16.458416Z 0 [Note] Plugin 'FEDERATED' is disabled.
2020-10-12T18:10:16.460608Z 0 [Note] InnoDB: Loading buffer pool(s) from %%userDataPath%%\\run\\S23DJPIDe\\mysql\\data\\ib_buffer_pool
2020-10-12T18:10:16.533035Z 0 [Note] Found ca.pem, server-cert.pem and server-key.pem in data directory. Trying to enable SSL support using them.
2020-10-12T18:10:16.533079Z 0 [Note] Skipping generation of SSL certificates as certificate files are present in data directory.
2020-10-12T18:10:16.535732Z 0 [Warning] CA certificate ca.pem is self signed.
2020-10-12T18:10:16.536096Z 0 [Note] Skipping generation of RSA key pair as key files are present in data directory.
2020-10-12T18:10:16.536585Z 0 [Note] Server hostname (bind-address): ''; port: 10004
2020-10-12T18:10:16.536903Z 0 [Note]   - '' resolves to '';
2020-10-12T18:10:16.537016Z 0 [Note] Server socket created on IP: ''.
2020-10-12T18:10:16.585533Z 0 [Note] InnoDB: Buffer pool(s) load completed at 201012 20:10:16
2020-10-12T18:10:16.641075Z 0 [Note] Event Scheduler: Loaded 0 events
2020-10-12T18:10:16.641324Z 0 [Note] %%userDataPath%%\\lightning-services\\mysql-5.7.28+4\\bin\\win64\\bin\\mysqld.exe: ready for connections.

I’m not 100% sure what it all means, but does this happen for every Apache site that you try to create? The part that mentions Cannot open Windows EventLog; makes me think that there may be a permissions issue. Did you notice if there are system prompts opening correctly when creating the new site?

I’m still using the latest Flywheel version that really supported Apache on windows (3.3.0), and every now and then I do a fresh install of the latest Local Lightning release to check if it is usable with apache already, and it turns out to be this same error every time.

I’m the administrator-user on my pc, and allowed every permission that I was asked for. I just create one site, start it, run into this error, delete everything again and start googling if someone has made Docker easy-to-use already.

For the last hour, I’ve created several new sites, even while running Local as Administrator. I’ve had a few cases where the default wordpress loaded, but when I tried it again with a new site it just didn’t, and now I can’t get it to work anymore.

1 Like

I had this issue when trying to have the site locally on a different hard drive.

If the site was saved on my C drive it worked fine.

If I created a site on my E drive in a dropbox folder I would run into this problem.

Hopefully this helps.


Thanks so much for your reply, this is 100% the case here as well! I would have never found this by myself.

@ben.turner is this something you can look into?

That’s a great insight @lilsleep – thanks for pointing us in the right direction!

@uniqueshort, @Zoker, @daniel.skowronski, @lunestudio, @blash, @martin-orchard

Where are you saving the site? Is it on a different partition – something like what was described here:

I think being able to save a site to a different partition is an interesting idea! I’d be curious to know if certain processes would allow that to happen under Windows. Either way, can you create a feature request describing what you’d like Local to be able to do?

Hey @lilsleep

I’d be curious to know if the issue was specifically with the site being on a different partition, or if Dropbox was causing issues.

As a test, is there any way you can have Dropbox watch a site that is created on your C:\\ partition, and then see if the issue is still present?