Performance issues with Local on Windows 10

Kevin,

Have you enabled Faster Docker Volumes in Preferences » Advanced?

If so, please make sure your internet security or firewall (if installed) isn’t blocking it.

Hi Clay,
Yes I enabled the faster docker volumes. There is not firewall of some sort enabled.

@AlwaysQuads,

Got it.

If you go back to Preferences » Advanced, is it still enabled?

Hi Clay,

yes its still enabled.

I am having the above issue and none on windows 10 also . Pretty disappointing that nobody seems to be able to rectify a major fault.

It took 5 minutes to change theme and navigating between pages takes nearly a minute.

1 Like

@AlwaysQuads,

Thanks for the screenshot!


@mikewadewebdesign @AlwaysQuads,

Depending on your setups, the information here may be useful: Slow on Windows 10

Clay, you are a genius - that article helped massively, it turns out Avast was causing the issue! (first part of the topic!)

1 Like

@mikewadewebdesign,

Great, I’m glad to hear @Iws’s solution worked! :smiley:

That makes us both Geniuses :slight_smile:

Steve

1 Like

Just in case this helps someone else, this was running extremely slow for me when I installed. I read all the other complaints that I could find and tried every solution with no luck. Finally I figured out my problem. I have my local websites folder mapped to a drive (eg: W:\example.local) and was using that as my default sites path. When I changed that to the location on my C drive it finally sped up. Maybe obvious to people smarter than me, but I didn’t know this would matter.

Note, I actually had to change the default sites path in the settings to get it to install to that location… for some reason if I changed the site location manually when adding a new site, it would still always install to whatever I had set as the default sites path.

1 Like

@rian80 Interesting. Can you tell me what settings you changed exactly? Was it global settings, or per site settings. I can’t find where to edit the site path(s). Thanks.

When I first installed Local by Flywheel, I had manually changed my default sites path under Preferences > New Site Defaults > Site Paths.

When I had the idea that maybe this was causing my problem, I first tried setting a different site path per site manually when setting up a new test site. That seems to be only possible to do when first setting up a new site. When you click Add site, there’s an expandable area called “Advanced” where you can set the Local Site Path. However, for some reason that manual change wasn’t working, it kept installing into my global default path. I wonder if that may be a bug?

So I went back to the global defaults and changed it, then set up a new site, and finally everything was nice and fast. It went from sometimes taking over a minute to load a page to about 1 second or less.

Actually, the site path is exactly the same, it’s just that I was defining it as w:\example.com instead of c:\users…\example.com.

Since it doesn’t look like there’s an easy way to change the site path after a site is already created, I had to export the sites I had already set up, then import them into the “correct” location.

Thanks for explaining.

So this is 2019, and I am having all of the issues that has been described in this thread. The only differences is that My “WinNFSd.exe” is fine… it’s not being quarantined by avast and I can find it the “extraRsources” folder… I have combed through every thread on this issue in the forums and tried every suggested solution and none seems to work for me…

So, pleeeeease. Can somebody help me?

1 Like

Have you tried this solution: Super Slow on Windows 10

Faster Docker Volumes won’t stay enabled. Flywheel takes it upon itself to disable it a short time after I enable it. It then restarts the servers.

Not sure why Flywheel does this, or if it would even help, if it would stay enabled. Basically, though, this is no solution. Neither is restarting, re-importing, etc. And I do not have Avast.

Flywheel has become unusable!!

I am also having the same issue. I have tried enabling Faster Docker Volumes, IPV6 setting, restarting VM, restarting computer, completely uninstalling and reinstalling Local. I do not have Avast. I have also tried re-importing sites. Checking on the directory where the files are saved, ensuring the paths match.

Is incredibly show and seems to actually just be getting slower, initially it was about a 2-3 second page reload, and now its more like 15-60 secs to load a page. Its painful process to work with, I love this program and have used it for sometime now, but its become unbearable to use right now, as it just feels like my work flow is stunted by waiting :frowning:

2 Likes

We’ve been working this year to rebuild everything under the hood of Local. It’s way faster and runs all services natively without VirtualBox. Try v5 today! https://localbyflywheel.com/?download

It seems the better link, to get the latest release, would be: https://localbyflywheel.com/community/c/releases
Download “Local” (Beta) versions (>5.x), Not “Local by Flywheel” versions (<3.3).
Currently the latest release of this new version is Local 5.0.7.

hi, i have done everything, it is very slow… why?