# PHP Warning: PHP Startup: Unable to load dynamic library 'php\_xmlrpc.dll

**URL:** <https://community.localwp.com/t/php-warning-php-startup-unable-to-load-dynamic-library-php-xmlrpc-dll/45715>\
**Category:** Support\
**Tags:** windows-10\
**Created:** [November 24, 2024, 6:26am UTC](https://community.localwp.com/t/php-warning-php-startup-unable-to-load-dynamic-library-php-xmlrpc-dll/45715 "2024-11-24T06:26:41Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![rashedk](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/rashedk/32/23246_2.png) [@rashedk](https://community.localwp.com/u/rashedk)\
**Post date:** [November 24, 2024, 6:26am UTC](https://community.localwp.com/t/php-warning-php-startup-unable-to-load-dynamic-library-php-xmlrpc-dll/45715/1 "2024-11-24T06:26:41Z")

</div>

### What issue or error are you experiencing?

I am using Apache which php version is 8.1.23. This warring error is display in the error log file. How to fix this error. I am not align about this error please tell me how to fix this ?

* * *

### What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

* * *

### System Details

- **Local Version:**

- **Operating System (OS) and OS version:**

* * *

### Local Logs

Attach your Local Logs here ([Help Doc - Retrieving Local’s Log](https://localwp.com/help-docs/troubleshooting/retrieving-locals-log-file/))

* * *

_ **Security Reminder** _  
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

---

<div class="post-metadata">

**Author:** ![Nick-B](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/nick-b/32/16140_2.png) [@Nick-B](https://community.localwp.com/u/Nick-B)\
**Post date:** [November 25, 2024, 3:22pm UTC](https://community.localwp.com/t/php-warning-php-startup-unable-to-load-dynamic-library-php-xmlrpc-dll/45715/3 "2024-11-25T15:22:41Z")

</div>

Hi @rashedk

Is this happening with a new Local site that you just created? Or is this a site that you imported into Local or already have been working on?

The XML-RPC dll was [removed from the default PHP distribution in PHP 8](https://www.php.net/manual/en/migration80.incompatible.php#migration80.incompatible.xmlrpc)+, so Local’s PHP no longer includes it beyond version 8.

I was able to replicate your error in Windows 11 but only when I manually added `extension=php_xmlrpc.dll` to my `php.ini` file. So if a site you tried to work on or import has an altered `php.ini` like this, then you may need to remove that if you’re simply wanting to get rid of the error and don’t need that in place.

---

<div class="post-metadata">

**Author:** ![system](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/system/32/1_2.png) [@system](https://community.localwp.com/u/system)\
**Post date:** [February 23, 2025, 3:23pm UTC](https://community.localwp.com/t/php-warning-php-startup-unable-to-load-dynamic-library-php-xmlrpc-dll/45715/4 "2025-02-23T15:23:02Z")

</div>

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
