# Sites fail to boot or create on Fedora 39

**URL:** <https://community.localwp.com/t/sites-fail-to-boot-or-create-on-fedora-39/39923>\
**Category:** Support\
**Tags:** mysql-8, linux-fedora, mysql\
**Created:** [November 10, 2023, 5:10pm UTC](https://community.localwp.com/t/sites-fail-to-boot-or-create-on-fedora-39/39923 "2023-11-10T17:10:55Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![leichim](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/leichim/32/20055_2.png) [@leichim](https://community.localwp.com/u/leichim)\
**Post date:** [November 10, 2023, 5:10pm UTC](https://community.localwp.com/t/sites-fail-to-boot-or-create-on-fedora-39/39923/1 "2023-11-10T17:10:55Z")

</div>

### What issue or error are you experiencing?

- mysql service is spewing out errors, and can not start

 ![Screenshot from 2023-11-10 12-17-39](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/3X/4/7/476499e7ff0f0737cf72634258a4b28d30f63781.png)  
 ![Screenshot from 2023-11-10 16-07-19](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/3X/d/2/d20b7f1e38fe9e1111bbb531123d8cf96c822e92.png)

- The error does not exist when using MySql 5.7.
- I have reinstalled Local
- I have tried it on existing sites that worked fine in Fedora 38
- I have tried adding a fresh site, it still does not work
- I have run a fresh, clean install of Fedora 39 in a VM, and it fails there as well. It’s a bit different though, but still related to the MySQL service
- I have tested it with a VM and Fedora 38, and there Local works fine.

If anyone knows a solution or quick fix, it would be greatly appreciated.

* * *

### What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

- Install Fedora 39 on your machine, or in a VM
- Install the latest Local release
- Just add a new site in Local and start it, or start an existing site, and the error will pop-up.

* * *

### System Details

- **Local Version:**

- 8.1.0

- **Operating System (OS) and OS version:**

- Fedora 39
- I am using docker for other development need, but during testing no containers were running

* * *

### Local Logs

Attach your Local Logs here ([Help Doc - Retrieving Local’s Log](https://localwp.com/help-docs/troubleshooting/retrieving-locals-log-file/))  
[local-lightning-verbose.log](https://community.localwp.com/uploads/short-url/d6MhWqzhls6sqwUfG9Rd3NF0q9A.log) (55.5 KB)

* * *

_ **Security Reminder** _  
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

---

<div class="post-metadata">

**Author:** ![Nick-B](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/nick-b/32/16140_2.png) [@Nick-B](https://community.localwp.com/u/Nick-B)\
**Post date:** [November 16, 2023, 2:10pm UTC](https://community.localwp.com/t/sites-fail-to-boot-or-create-on-fedora-39/39923/2 "2023-11-16T14:10:03Z")

</div>

Cross sharing this thread with one of our Local Devs that might provide some helpful information as well. If you have related questions or concerns you can also share over there as well:

> [@Obsolete ncurses-compat-libs](https://community.localwp.com/t/obsolete-ncurses-compat-libs/33598/5):
>
> @aliasifabro @secmurph @garrett If you install via yum or Fedora’s Software Installer, does that work for you? Both methods also install/update dependencies on Fedora 36 in my tests. Via yum First, download the latest Local rpm from the [Local releases page](https://localwp.com/releases/). cd ~/Downloads sudo yum localinstall local-6.6.0-linux.rpm Or via Software Install Either method results in Local running for me

---

<div class="post-metadata">

**Author:** ![leichim](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/leichim/32/20055_2.png) [@leichim](https://community.localwp.com/u/leichim)\
**Post date:** [November 16, 2023, 2:51pm UTC](https://community.localwp.com/t/sites-fail-to-boot-or-create-on-fedora-39/39923/3 "2023-11-16T14:51:55Z")

</div>

Thanks Nick for sharing some information. I will look into that.

(Interesting addition that came accross: the default Docker image of WordPress does not work well on Fedora 39 either in most docker-compose setups I have seen, the container is running, but it will result in err\_connection\_reset. From Locals perspective, this will return a 502 as nginx can not connect to the container)

---

<div class="post-metadata">

**Author:** ![mizaistom](https://avatars.discourse-cdn.com/v4/letter/m/a87d85/32.png) [@mizaistom](https://community.localwp.com/u/mizaistom)\
**Post date:** [December 10, 2023, 7:50pm UTC](https://community.localwp.com/t/sites-fail-to-boot-or-create-on-fedora-39/39923/4 "2023-12-10T19:50:19Z")

</div>

![Screenshot from 2023-12-10 19-05-50](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/3X/2/a/2a4eaf7a098c9a8ed58786268552b368f3ea87d3.png)  
in Fedora 39 it doesnt create site

---

<div class="post-metadata">

**Author:** ![Nick-B](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/nick-b/32/16140_2.png) [@Nick-B](https://community.localwp.com/u/Nick-B)\
**Post date:** [December 12, 2023, 6:55pm UTC](https://community.localwp.com/t/sites-fail-to-boot-or-create-on-fedora-39/39923/5 "2023-12-12T18:55:51Z")

</div>

Hi @mizaistom

Did you catch this thread above and test using those steps?

> [@Obsolete ncurses-compat-libs](https://community.localwp.com/t/obsolete-ncurses-compat-libs/33598/5):
>
> @aliasifabro @secmurph @garrett If you install via yum or Fedora’s Software Installer, does that work for you? Both methods also install/update dependencies on Fedora 36 in my tests. Via yum First, download the latest Local rpm from the [Local releases page](https://localwp.com/releases/). cd ~/Downloads sudo yum localinstall local-6.6.0-linux.rpm Or via Software Install Either method results in Local running for me

---

<div class="post-metadata">

**Author:** ![mizaistom](https://avatars.discourse-cdn.com/v4/letter/m/a87d85/32.png) [@mizaistom](https://community.localwp.com/u/mizaistom)\
**Post date:** [December 19, 2023, 11:56am UTC](https://community.localwp.com/t/sites-fail-to-boot-or-create-on-fedora-39/39923/6 "2023-12-19T11:56:38Z")

</div>

yes i did do all the steps but keeps on giving me the same error , can you try in fedora 39 because thats fedora 36

---

<div class="post-metadata">

**Author:** ![nickc](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/nickc/32/21209_2.png) [@nickc](https://community.localwp.com/u/nickc)\
**Post date:** [December 19, 2023, 5:12pm UTC](https://community.localwp.com/t/sites-fail-to-boot-or-create-on-fedora-39/39923/7 "2023-12-19T17:12:46Z")

</div>

Sorry that you encountered this, @mizaistom and @leichim.

As a workaround for now, please could you try installing Local via yum or Fedora’s Software Installer as above, then also installing the missing dependency like this?

```sh
sudo yum install libxcrypt-compat

```

Restart Local, and you should find that MySQL runs when you create and start a new site. I tested this under Fedora 39 and all is then well for me:

 ![local-on-fedora39](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/3X/9/5/951acd1f2af1e5cac61282611ffe19c3577cc4e9.jpeg)

(The underlying issue is that the vendor-supplied version of MySQL that Local defaults to (8.0.16) is linked against a dynamic library (libcrypt.so.1) that was removed in newer versions of Linux/Fedora. We’ll look at upgrading to a newer version of MySQL (8.2.x) that links to later libcrypt versions, but I don’t yet have a timeline for this work. I hope the workaround helps you for the time being.)

---

<div class="post-metadata">

**Author:** ![mizaistom](https://avatars.discourse-cdn.com/v4/letter/m/a87d85/32.png) [@mizaistom](https://community.localwp.com/u/mizaistom)\
**Post date:** [December 24, 2023, 10:21am UTC](https://community.localwp.com/t/sites-fail-to-boot-or-create-on-fedora-39/39923/8 "2023-12-24T10:21:12Z")

</div>

thank you it worked

---

<div class="post-metadata">

**Author:** ![system](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/system/32/1_2.png) [@system](https://community.localwp.com/u/system)\
**Post date:** [December 27, 2023, 1:56pm UTC](https://community.localwp.com/t/sites-fail-to-boot-or-create-on-fedora-39/39923/9 "2023-12-27T13:56:07Z")

</div>

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.
