Slow on Windows 10


Local is fast enough, but wp sites in Local are slow, sometimes painfully slow. I thought Local was supposed to speed up wp development? Working on live/remote sites is much faster.

I have two new sites and only run one at a time.

Is there anything I can do to speed this up?


1 Like

Hi Steve,

Sorry for the slowdown!

There are a few reasons this may be happening:

  1. Faster Docker Volumes may not be enabled. Navigate to Preferences » Advanced to enable Faster Docker Volumes
  2. There is DNS delay. Enable IPv6 Loopback under Preferences » Advanced
  3. There is a slow query, slow outbound request, or something of that nature causing the pages to load slower. Query Monitor is a great tool to check.
  4. In some cases, the computer running Local can cause a slowdown due to other applications running, lack of an SSD, slower processor, etc.

Hi Clay,

I tried the settings 1 and 2 but they did not help.

I installed Query Monitor, but what am I looking for?

My PC has a SSD, a good processor and decent spec.


1 Like


is there anything else I can do to try and speed things up please?



Feel free to take some screenshots of the results and then upload them here. The number in the top WP admin bar usually provides some good information.

Have you tried the steps in this FAQ? Help! My Local site cannot establish a connection to - Local Classic FAQs - Local Community

Hi Clay,

Two screenshots of Query Monitor attached.



thought this might help too:


Thanks for those!

It looks like there’s an HTTP API Call in the Query Monitor screenshot. Can you click on “HTTP API Calls” and provide a screenshot of what you see there?

Hi Clay,

I don’t think its anything to do with the HTTP API Call(s). I logged back into WP, slow as usual, navigated a few menu items and no HTTP API Calls show up this time.

This time all I see is this…

FYI, everything is slow, not just navigating and editing in WP. Local is slow to launch, although I expect this is normal/takes a while, in my case over 10 seconds to launch. Then when I click on Admin it takes over 10 seconds for the login page to appear :frowning:

I have a pretty good spec pc, only 1 site in Local with less than 15 plugings, and only 1 page, a very small site indeed.



Thanks again for the screenshot!

I’ve sent you a private message regarding this.

Hi Clay,

Thanks for your help on this, much appreciated.

Avast Business Security is causing the slow down.

I would occasionally, not always, get Avast prompts to Delete or Create an Exclusion for: WinNFSd.exe

I created/allowed the Exclusion many times, however, the exclusion would never save/stay active. Even if I launched Avast and entered the exclusion/path manually the exclusion would not stick.

The exclusion prompts could happen at anytime, even after login to WordPress and editing several pages. I turned off Avast several times to try to over come the issue but strangely WP sites on Local still did not speed up.


Avast Business Security has issues - if your using the Cloud Console to manage several pc’s it doesn’t matter how many times you create an exclusion in your local Avast program, it will not save it. You have to login to the cloud console and edit or set up a new global template and from within that template create your exclusion there. Ain’t that amazing or stupid? :slight_smile:

Why Avast doesn’t inform you of this issue when prompting an exclusion is beyond me.

The path/file that I had to exclude is: C:\Users\bob\AppData\Local\Programs\local-by-flywheel\resources\extraResources\WinNFSd.exe

hth someone else.

Thanks Clay, great support :-):smiley:



No problem! Thanks for providing a write-up of the solution! :slight_smile:

So this is 2019, and I am having all of the issues that has been described in this thread. The only differences is that My “WinNFSd.exe” is fine… it’s not being quarantined by avast and I can find it the “extraRsources” folder… I have combed through every thread on this issue in the forums and tried every suggested solution and none seems to work for me… So, pleeeeease. Can somebody help me?

Have you tried this solution: Super Slow on Windows 10 ?