Special characters not supported on Windows username/password

Hi, I had the same problem and solved it with the version 5.2.8 when I executed the installer as admin.

Even running installer and app with admin privileges and changing Local Sites directory location didn’t work for me. Changing directory name using Registry seems to risky because it might break other apps or licenses. I’m working on a company computer at this time.

Still not fixed on 5.3.1…

My operating system is Windows 10 and I’m trying to install Local 5-2-8.
During the installation, I get a first error message.
2020-04-11_21-43-20 - 1er message
After clicking OK, I get a second error message.
2020-04-11_21-43-20 - 2eme message
I have tried to install the program several times, but I keep getting the same error messages.
Could someone help me to find a solution?
Thank you in advance.
PS: I’m attaching the “local-lightning” file
local-lightning.log (43.7 KB)

Hi all,

So sorry we haven’t had a recent update for this! We’re still working out the details on how to fix this for all of the site services that Local utilizes.

In the meantime, if you have ran into this bug, please upvote it on our public bug tracker: https://feedback.localwp.com/bug-reports/p/local-is-unable-to-provision-sites-on-windows-when-there-are-special-characters

Hi there,

i met the same problem (last local version (5.4.1)) and I fixed the issue. You have 2 solutions :

  1. Change your username windows without any special characters ( https://www.tenforums.com/tutorials/89060-change-name-user-profile-folder-windows-10-a.html ) ==> Thanks to @danniemite for the tuto


  1. Add a new windows account (name it without any special characters)

And it works !!

By the past, I met the same problem with another soft and I recommend to not use special characters (neither Windows or Gmail or another account if you want to use some software)


1 Like

2 posts were split to a new topic: Missing dependencies in Ubuntu 20.04

this fix my error… thanks man

They managed to find a solution


What can I do?.
I think my problem is something a bit different, because says the database ‘local’ exists, what is that?
How to fix it?

imagelocal-lightning.log (157.5 KB)

I’m having the same issue for more than six months. All along I had been using Local with no issues until it started with this notification. I haven’t been able to use Local for about seven months. Are there any plans to fix it in a future version? Every time a new update comes I rush to get it in the hope that it will solve the problem. But until now nothing has happened.

Hi Clay and everyone having the same challenge, I managed to fix the issue by using an old version of Local. I had to download and install version 3.2.1 of Local by Flywheel and is now working perfectly. I guess that is the only way one can use Local without the benefit of the current updates. So, if people don’t mind, the best solution could be using an earlier version of the software.

Hey @chauque – do you have the exact error that mentions errors related to special characters within the Window’s username?

Can you provide an example of your username on the Bug Tracker for this bug:

As a workaround, if you are wanting to use the latest version of Local, you can create a new user or try editing the folder name for the user. See the updated topic description for more details:

Sorry for the frustration but:

HOW LONG WILL IT TAKE TO FIX THIS??? Do you want your software to be used?

I mean it’s been such a long time and still not fixed… At least admint you are not planning to do it then we can move to another software. This way you are just deciving customers.

I hate this kind of threatment.

Sincere regards,

Hey @Atalol, Welcome to the Local Community Forums and I’m sorry for the frustration that this is causing!

Due to the difficulty of fixing something like this it isn’t on our immediate roadmap of things to be worked on, but by upvoting the bug report mentioned in the opening topic, you can help increase the priority of getting something like this worked on.

Using Windows 10 ver. 2004 whenever I install LOCAL and try to create a new local site I get an error message: initialize-insecure

Also mysqld can not create directory (OS err no 2 - No such file or directory).

It can be due to the spanish letter “ñ” which is in my root because my name is “Iñigo”: I also get the message “The character set UTF8MB3 is deprecated and will be removed in a future release. Please consider using UTF8MB4 instead”.

I suggest that using the “ñ” should NOT be a problem because there are many different languages out there with special character sets and Local should work with all of them.

Is it me or is it the program? Anybody can Help? Thank you in advance.

Hey @ICP – Welcome to the community! I’ve moved the post to this topic since it’s a known issue.

You should be able to get an idea of a workaround by reading the summary at the top of this topic.

I recently installed the Local 5.7.2 and when I create a New Site I get this message error: Uh-oh! Unable to provision site. Error: Error: Command failed:…, here I put the print screen of this error. By the way, I have Kaspersky Antivirus, but I closed it before installing Local. Can you please tell me what I am doing wrong, in order to create a new site, please?, thanks a lot.
Sofia Perez

Hey @sofia.perez – Thanks for joining the Local forums and writing in! Since this is a known bug, I’ve merged your topic into this one. You should be able to review this topic’s description and upvote the bug as well as find a work around:

Than you Ben. Windows has this problems. And many more. The virtual Linux machine is just for coding. So what I will do is something different. I have tried using Ubuntu with a USB (https://ubuntu.com/tutorials/create-a-usb-stick-on-windows#1-overview) and it works. In some days I will install Ubuntu in my PC (two operative alternative systems, i.e. without unistalling Windows) and install Local version for Linux. Done. No Windows. Thanks anyway. I´ll tell you and the community how it runs. Not done yet. Iñigo.

1 Like