SSL No longer trusted

What’s odd is, Local is working fine on my other machine running Big Sur 11.2.1. I got a new machine and none of the SSLs are working anymore with a fresh install of Local (5.9.8+5191 on both machines). It seems, if it was a browser issue, it would be consistent across both of my machines running the latest version of macOS and the latest version of Chrome/FF/Safari.

1 Like

@redbranchmedia – can you try the solution in this forum topic:

For a more visual walkthrough of the process, this help doc should point you in the right direction:


Success!! So glad to have this fixed. Thank you!

1 Like

I suspect the SSL issues could be due to the fact that Chrome (and chromium based browsers) now limit the the validity of SSL certificates to one year where as Local issues 10 year certs.

How would I go about reducing the time for which a self-signed cert is valid?

Thanks for your responses.
So basically setting up / trusting the SSL doesn’t work for me.
Do you think @nigelmrodgers could be right ? Is it possible to edit SSL’s settings somewhere ?
Thanks a lot !


Thank you @christiantjl for finding a way to get sites loading at all in Chrome. This is more than anyone from Local seems capable of doing. I’m hoping that getting enough attention to the problem will get someone working on a proper fix for it.

It really seems like the Local team doesn’t really care about this issue.
This is NOT a new problem and the usually the Local team completely ignores posts about it as seen in my post here from last April that never got a response. Other similar issues here, here, and here also have been posted without any real progress towards fixing this problem. It’s a very frustrating issue that keeps coming up with no good solution.


The thing is, this is the best tool I’ve used for WP development so far, and it works pretty damn well on Linux up until we get into this SSL issue.

@ben.turner, I highly recommend open-sourcing the Local source code so that we could contribute to these issues and help resolve them. This software is wonderful, but because nobody can contribute, these bugs persist for months and months.


Is there any progress on this issue?
At this point I would rather pay a license fee to use Local if that would mean bugfixes get done quicker

I have removed cert and pem files for the site I try to fix from at least 3 different locations now, removed the SSL part from the router config for this site, removed the certifcate from my browers and…
Local just keeps serving a certificate to my browser…

I was able to successfully modify Local to issue certs for 1 year instead of 10, it didn’t make a difference on my setup. Just thought that might be useful for you or anyone else following this thread.

any progress???

Replying to kick that stupid 3 month bot out. So many unanswered threads in this forum it makes me irate. What could possibly be more important than getting basic functionality working? I don’t get it!

Hey @OMGDayKildKenny – thanks for keeping this topic alive!

There’s lots of things going on under the hood with Local. I know that it may not look like many user-facing issues are being solved, but there’s been much effort going towards upgrading Local to be more secure and more performant. As part of this, there’s a lot of tech debt that’s having to be paid down, so issues like this haven’t been able to be worked on.

I know it’s not the solution you want, but if Local doesn’t have a solid base, then issues like these won’t ever be fixed!

No problem ! I know how development projects are done. And the issue doesn’t prevent me from working either !

1 Like

Thank you, thank you, thank you. This worked for me. What an easy fix to such an annoying problem

1 Like

Isn’t developers supposed to be in here?

I thought so too, but I have since moved on to ddev. MUCH better, it actually works! :smile:

Sounds like you guys are very very overwhelmed given the sheer number of items unresolved years after being reported. Maybe it’s time to let Local die or open source it so you get more developers working on it?

Personally, I had my fill when I updated local only to find that the services delivered from your servers were misconfigured and what used to work no longer did. That’s not something I’m willing to deal with - if I have to manually set up services or debug faulty configs I might as well just do things myself! Being at your mercy and dependent on what mistakes you may make when packaging services, without any kind of possibility of getting whatever version of the service I want/need - bah, very much not worth it.

Although I like the UI and features, I took a hard look at my workflow and your software is costing me time instead of saving it. I’ve moved on to another solution. I wish you good luck with getting that “solid base” completed this decade (just extrapolating from the number of closed issues without a response and their age).

1 Like

Yeah, Local might not be the tool for everyone, so if you’ve found something that fits your workflow, then I think that’s awesome!

I still fire up other offline dev tools to see what’s out there, but for almost all the WP work I do, I come back to Local. For me, I keep finding that the friction of “just getting a WordPress site running” is much less in Local than it is in other tools.

And that’s not me being afraid of CLIs, VPSes, Docker, or any of the new hotness in DevOps. For some projects, I agree, it’s nice to be able to track infrastructure changes in code and scaffold up new instances in completely isolated containers with exact adherence to configuration.

But most projects don’t need that kind of precision. There’s something to be said for having an idea, clicking a button, and being seconds away from having a sandbox clone of production to tinker with. What I’ve found when using other tools is that I end spending too much time fiddling with environment configs and not enough time to just diving in and exploring an idea.

1 Like

Yes, I do agree with that: for simplistic, vanilla projects it’s perfect, and it almost works perfectly everywhere (linux cert trusting is an issue). But as soon as you need something more specific - like php-gd, Local becomes a nightmare.

You can’t compile your own services, they’re packaged in a non-standard way and do not ship with the executable, they come from your servers directly (no control, no option to get older versions in). I’d have to dig hard into how you compile these things per OS, then try to mimic it.

Whereas with ddev for example, all I do is ddev config && ddev start. In fact, I don’t even do that anymore, I have a script I just type “n site.url” in the console and it creates the folder for me, pulls in db dump, configures ddev, and starts it. If I need anything extra on top of php 5.6 to php 8.0 with all available extensions, sudo apt install. Standard system no matter where I am - windows, macos, linux. Want xdebug? I don’t have to edit some config in an obscure location to get it enabled and configured. I just issue a command “ddev xdebug enable”.

Speaking of, you should give blackfire a looksie, it’s rather nice.

1 Like