Local Community

The requested resource is not found

HI I have just downloaded and setup successfully the software from Localbyflywheel.com

I am on a Windows10 environment

I have created two WordPress sites just using default settings. Both of them give me this error message when I click on View site or when I click on Admin from the buttons in the upper right corner

HTTP: Error 404. The requested resource is not found.

The sites are there as I can see them in the folders but something must be amiss. What I can I do to give you more information?



Still waiting for support on this. I’ve read all the forum posts for anything like this but can’t find anything. I’ve looked in my log files but they seem blank, although I can’t find the localbyflywheel log files. Perhaps there aren’t any in this version. So sure hope someone can help me so I can get on with this. Thanks, Daryl

Hi @darylf,

Sorry for the trouble!

Here’s how you can retrieve the log files: How do I retrieve Local's log file?

Also, can you provide a screenshot of what you’re seeing in your web browser? I realize it’s a 404, but the styling of the 404 can also provide a surprising amount of context. :slight_smile:

Here is the logfile

local-lightning.log (25.5 KB)

Hope I did that right.

Trying to get a screen capture for you.

Hopefully here is the screen capture


Thanks for both the screenshot and log file! There are some great clues in both :slight_smile:

It looks like Local’s routing layer is failing to start due to a conflict with IIS. To resolve the conflict, here’s what you can do (assuming you don’t need IIS):

  1. Open Control Panel > Programs and Features

  2. Click Turn Windows features on or off

  3. Scroll down to Internet Information Services

(Credit: https://superuser.com/a/1377078)

  1. Click on the square next to Internet Information Services so it becomes empty

(Credit: https://superuser.com/a/1377078)

  1. Click OK and reboot if required.

  2. Lastly, re-open Local and try to create a site.

Hi Clay

It was already off unfortunately.


Interesting. That 404 page is the IIS default.

Can you please try running the following in Command Prompt or PowerShell and see if it makes a difference? Be sure to open either Command Prompt or PowerShell as an administrator.

IISReset /Stop

Thanks for your patience!

It says it is not recognized as an internal or external command. operable program or batch file.

I made sure my case was proper and syntax was exactly as you said.

Thanks for trying that command. I’ll do some more digging.

I think I will do another install on my main computer. I did this one on my laptop just to see what it was like. So should I select Linux or nginx when I set it up? What are your thoughts?

Are there any other potential programs on your PC that would be running IIS such as Visual Studio for ASP.NET?

Awesome! Curious to hear the results.

If you’re installing it on Windows, you’ll want to be sure to select the Windows download. As far as the web server goes, Local Lightning currently only ships with nginx. Apache will be coming later this year.

On my laptop, no I don’t think so. It is just used as something to view sites while I develop.

Curious but I can’t find where to download the zip file for your software without entering my name again, etc… And I can’t seem to log into the site anywhere.

Could you provide a link for me please so I can download it for my main computer.


Nevermind I just did a new download.

May as well keep the same thread.

I did a fresh install on my main computer: Windows 10 with lots of horsepower.

Same problem as my laptop install.

Get a Not found error message and here are the log files for you.

local-lightning.log (7.0 KB)

IIS was turned on. I turned it off and rebooted and still get the same error messages as I originally did.

I have tried Chrome, Firefox and IE.

Over to you Clay.


And to be clear, you’re still seeing the same exact error as the screenshot below?


Here are a few things to try:

  1. Try a hard browser refresh. Ctrl + Shift + R on Windows

  2. Try accessing directly in your browser and see what it shows.

Clay my bad, IIS was turned on, I turned it OFF and rebooted.

My bad

1 Like

Yes, screen shot is identical.
I did a hard browser refresh, no change.
I tried accessing it directly from the IP you showed there.
Still no luck on all.

Also I checked my hosts file and the statements WERE added.

Got it. Thanks again for being receptive to my endless questions and suggestions. :slight_smile:

One more thing to try for the sake of gathering information:

  1. Open PowerShell
  2. Run the following command to list out what process is running on port 80.
Get-Process -Id (Get-NetTCPConnection -LocalPort 80).OwningProcess

Here’s an example of what you might see.

No problem Clay I am at my computer and just waiting for you to feed me things to try.

I ran it and the results are (I can’t copy and paste it)

handles = 6689
NPM (K) = 0
PM(K) = 196
WS(K) = 1800
ID = 4
SI = 0