Trying to fix Warning! Missing hosts entry. This site may be inaccessible

I get this Warning! Missing hosts entry. This site may be inaccessible. error.

When I click on “FIX IT” & node.js give me this error.

Local ran into an EPERM error when trying to update the hosts file.

What do I do?

Do I re-install node.js?

Is this node.js related issue?

Hi Matthew,

Please make sure you don’t have Host Files locking enabled in your anti-virus/security software such as Spybot Search & Destroy, ZoneAlarm, etc.

In my context the issue was because of the host file was in read only.

To fix :

  • go on C:/Windows/system32/drivers/etc
  • Right clic on “Host” file
  • Properties
  • Cancel the selection of “read only”
  • Confirm admin rights
  • Retry to fix in LOCAL

Problem solved :wink:
3 days to find this “easy” thing…


Hi @audreysky,

Thanks for sharing!

I went ahead and created an FAQ with a screenshot :slight_smile:

Thank you so much, problem solved :slight_smile:
local by flywheel is requesting administrative privileges to modify your /etc/hosts file

I encountered similar error during the site setup , and resolved with the suggested hosts file change.

Is it reaquired for this read only attribute to remain disabled ?

Thanks in advance.