Uh oh the requested site id does not exist in local, this is embarassing

Hello, I am an user of Local by Flywheel. I have a Mac OS, recently updated to Mojave.
On average once every week this message pop up “uh oh the requested site id does not exist in local” and there is not a single way to having the website back again. I checked in the forum and all these posts were basically not answered. Moreover, when I try to create a new website and copy the old one in the new the local stops at “checking system” and is stucked here. On average I lose about 2-3 hours on this stupid error instead on focusing on website development.
Is embarassing for you and your service and very frustrating for me

news, if you try to open a new website it says “uh-oh, it looks like we couldnt retrieve the docker image”. You could have at least add a way to solve this very annoying bug

I’m sorry you had these troubles with Local. I’d recommend you try to manually re-install it. You can find instructions on doing that here: How do I manually upgrade Local? (similar process for upgrade).

If the issue persists, could you post the log file as a result? That will help us further diagnose the troubles you are having.

I’m having the exact same issue, I’ve so far lost 2 of the 3 sites I’ve tried to build with Local.

Have tried removing and reinstalling the app, no difference.

I would happily pay for this product, but its a joke in the current state its in, why would I risk loosing any more hours on this?