# Uh-oh we ran into an issue when pulling from WP engine

**URL:** <https://community.localwp.com/t/uh-oh-we-ran-into-an-issue-when-pulling-from-wp-engine/37653>\
**Category:** Support\
**Tags:** mac\
**Created:** [June 21, 2023, 6:53pm UTC](https://community.localwp.com/t/uh-oh-we-ran-into-an-issue-when-pulling-from-wp-engine/37653 "2023-06-21T18:53:05Z")\
**Posts on this page:** 1\
**Showing post:** 17

<div class="post-metadata">

**Author:** ![unitof](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/unitof/32/19011_2.png) [@unitof](https://community.localwp.com/u/unitof)\
**Post date:** [July 24, 2023, 9:30pm UTC](https://community.localwp.com/t/uh-oh-we-ran-into-an-issue-when-pulling-from-wp-engine/37653/17 "2023-07-24T21:30:43Z")

</div>

I had this same error message (as well as [Local couldn’t load the file list!](https://community.localwp.com/t/local-couldnt-load-the-file-list/27010) when trying to pull a new site) weirdly _only_ on WP Engine sites. Flywheel sites continued to push and pull fine.

Thanks to this thread I discovered `/Library/Logs/local-lightning.log` where I saw

```auto
{"thread":"main","class":"RsyncService","message":"/Users/jacob/.ssh/config line 2: garbage at end of line; \"#\".\r\n","level":"warn","timestamp":"2023-07-24T21:12:40.766Z"}
{"thread":"main","class":"RsyncService","message":"rsync: connection unexpectedly closed (0 bytes received so far) [Receiver]\nrsync error: unexplained error (code 255) at io.c(226) [Receiver=3.1.3]\n","level":"warn","timestamp":"2023-07-24T21:12:40.767Z"}
{"thread":"main","class":"ConnectManifestWpeService","sentryEventId":"6552717388124a9aa27e22a16cd98858","level":"error","message":"Error creating manifest for WPE Service","timestamp":"2023-07-24T21:12:40.769Z"}
{"thread":"main","class":"ConnectManifestWpeService","level":"error","stack":"Error: rsync process existed with code 255\n at ChildProcess.<anonymous> (%%appPath%%/main/rsync/RsyncService.js:1:1548)\n at ChildProcess.emit (node:events:527:28)\n at ChildProcess.emit (node:domain:475:12)\n at ChildProcess._handle.onexit (node:internal/child_process:291:12)","message":"rsync process existed with code 255","timestamp":"2023-07-24T21:12:40.769Z"}

```

Helped me discover a line in my `~/.ssh/config` that had both config **and** a comment:

```auto
IdentityFile ~/.ssh/id_rsa # set default so it doesn't just use newest

```

Turns out some programs (like rsync apparently) really need comments to be strictly on their own line starting with `#` so I edited my `~/.ssh/config` and now Local is pushing and pulling to WP Engine again.

```auto
# set default so it doesn't just use newest
IdentityFile ~/.ssh/id_rsa

```

---

_[View the full topic](https://community.localwp.com/t/uh-oh-we-ran-into-an-issue-when-pulling-from-wp-engine/37653)._
