# Unable to add a new site

**URL:** https://community.localwp.com/t/unable-to-add-a-new-site/44912
**Category:** Support
**Tags:** windows-10
**Created:** [October 8, 2024, 1:35pm UTC](https://community.localwp.com/t/unable-to-add-a-new-site/44912 "2024-10-08T13:35:14Z")
**Posts on this page:** 12
**Page:** 1

<div class="post-metadata">

### Author: ![blacksun](https://avatars.discourse-cdn.com/v4/letter/b/b9bd4f/32.png) [@blacksun](https://community.localwp.com/u/blacksun)
#### Post date: [October 8, 2024, 1:35pm UTC](https://community.localwp.com/t/unable-to-add-a-new-site/44912/1 "2024-10-08T13:35:15Z")

</div>

Hello guys,  
I have error to add a new site, I tried to install into 2 mods, I tried different releases of DB.  
I didn’t find a solution in internet then I ask to community.  
I joined log file.  
Thank you to read it  
[local-logs.zip](https://community.localwp.com/uploads/short-url/7uz47sj3y9EBcOMRXMiFNqTN0UX.zip) (14.4 KB)

---

<div class="post-metadata">

### Author: ![Nick-B](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/nick-b/32/16140_2.png) [@Nick-B](https://community.localwp.com/u/Nick-B)
#### Post date: [October 8, 2024, 2:27pm UTC](https://community.localwp.com/t/unable-to-add-a-new-site/44912/2 "2024-10-08T14:27:22Z")

</div>

Hey @blacksun

Are you running this app as an admin user?

Do you have any security features that could be blocking Local?

> [@Help! I'm running into an EPERM error with the hosts file on Windows](https://community.localwp.com/t/help-im-running-into-an-eperm-error-with-the-hosts-file-on-windows/3508):
>
> This is usually caused by the hosts file being set to read-only or locked by anti-virus. 1. Remove Read-only Attribute Go to C:\Windows\System32\drivers\etc Right-click on the hosts file and go to “Properties” Uncheck “Read-only” Click “Apply” Re-open Local Screenshot 2. Anti-Virus/Internet Security Avira See [https://answers.avira.com/en/question/avira-blocks-hosts-file-what-can-i-do-90](https://answers.avira.com/en/question/avira-blocks-hosts-file-what-can-i-do-90)Kaspersky Total Security Open Kaspsersky Total Security Go to “More Tools” Go …

---

<div class="post-metadata">

### Author: ![blacksun](https://avatars.discourse-cdn.com/v4/letter/b/b9bd4f/32.png) [@blacksun](https://community.localwp.com/u/blacksun)
#### Post date: [October 8, 2024, 3:37pm UTC](https://community.localwp.com/t/unable-to-add-a-new-site/44912/3 "2024-10-08T15:37:36Z")

</div>

Hi Nick-B  
I install it in admin mode  
my “hosts” file have no attribute.  
I use only windows defender.  
I tried to unactivate it during generating process of LocalWP (same kind error)

---

<div class="post-metadata">

### Author: ![Nick-B](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/nick-b/32/16140_2.png) [@Nick-B](https://community.localwp.com/u/Nick-B)
#### Post date: [October 8, 2024, 4:09pm UTC](https://community.localwp.com/t/unable-to-add-a-new-site/44912/4 "2024-10-08T16:09:10Z")

</div>

The errors in the log seem like a permissions issue is at play.

```auto
{"class":"SiteProvisionerService","level":"error","message":"Unable to provision site.","stack":"Error: Command failed: %%userDataPath%%\\lightning-services\\mysql-5.7.28+4\\bin\\win64\\bin\\mysqld.exe --defaults-file=C:/Users/ArctiQ/AppData/Roaming/Local/run/madMANkqX/conf/mysql/my.cnf --initialize-insecure\nmysqld: Could not create or access the registry key needed for the MySQL application\r\nto log to the Windows EventLog. Run the application with sufficient\r\nprivileges once to create the key, add the key manually, or turn off\r\nlogging for that application.\r\n2024-10-08T13:16:52.304115Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).\r\n2024-10-08T13:16:52.306096Z 0 [ERROR] Cannot open Windows EventLog; check privileges, or start server with --log_syslog=0\r\n2024-10-08T13:16:52.312867Z 0 [ERROR] InnoDB: Unable to create temporary file; errno: 0\r\n2024-10-08T13:16:52.312898Z 0 [ERROR] InnoDB: Plugin initialization aborted with error Generic error\r\n2024-10-08T13:16:52.312912Z 0 [ERROR] Plugin 'InnoDB' init function returned error.\r\n2024-10-08T13:16:52.312916Z 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.\r\n2024-10-08T13:16:52.312920Z 0 [ERROR] Failed to initialize builtin plugins.\r\n2024-10-08T13:16:52.312923Z 0 [ERROR] Aborting\r\n\r\n\n at ChildProcess.exithandler (node:child_process:422:12)\n at ChildProcess.emit (node:events:517:28)\n at ChildProcess.emit (node:domain:489:12)\n at maybeClose (node:internal/child_process:1098:16)\n at ChildProcess._handle.onexit (node:internal/child_process:303:5)","thread":"main","timestamp":"2024-10-08T13:16:52.325Z"}

```

Some other items to check here:

Are you using a drive other than C? Like an external storage?

Does your drive have open permissions and enough disk space?

---

<div class="post-metadata">

### Author: ![blacksun](https://avatars.discourse-cdn.com/v4/letter/b/b9bd4f/32.png) [@blacksun](https://community.localwp.com/u/blacksun)
#### Post date: [October 8, 2024, 4:27pm UTC](https://community.localwp.com/t/unable-to-add-a-new-site/44912/5 "2024-10-08T16:27:29Z")

</div>

I have a single SSD hard drive. And I have 2 partitions.  
So in first I used a directory on partition D.  
LocalWP error.  
I uninstall LocaWP and use default install parameter.  
no result.  
Actually my install of localWP using default install parameters

I cleanse after unistall with regedit  
I just re install it  
same kind error  
[local-logs.zip](https://community.localwp.com/uploads/short-url/funC0SzZXpa4NXvqOTMsdEqg3C1.zip) (3.2 KB)

---

<div class="post-metadata">

### Author: ![Nick-B](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/nick-b/32/16140_2.png) [@Nick-B](https://community.localwp.com/u/Nick-B)
#### Post date: [October 8, 2024, 7:33pm UTC](https://community.localwp.com/t/unable-to-add-a-new-site/44912/6 "2024-10-08T19:33:24Z")

</div>

When you uninstalled did you follow the Window specific steps here?

> **[Uninstall Local](https://localwp.com/help-docs/troubleshooting/uninstalling-local/#uninstalling-local-on-windows)**
>
> We’re sorry to see you go! Follow the instructions below to remove Local. Table of Contents: There are three main parts to the Local app, and depending on what you are trying to do, you may want to…

---

<div class="post-metadata">

### Author: ![blacksun](https://avatars.discourse-cdn.com/v4/letter/b/b9bd4f/32.png) [@blacksun](https://community.localwp.com/u/blacksun)
#### Post date: [October 8, 2024, 9:31pm UTC](https://community.localwp.com/t/unable-to-add-a-new-site/44912/7 "2024-10-08T21:31:10Z")

</div>

Yes I did  
I followed these steps

---

<div class="post-metadata">

### Author: ![Nick-B](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/nick-b/32/16140_2.png) [@Nick-B](https://community.localwp.com/u/Nick-B)
#### Post date: [October 9, 2024, 1:00pm UTC](https://community.localwp.com/t/unable-to-add-a-new-site/44912/8 "2024-10-09T13:00:07Z")

</div>

When you create a site are you using any specific configurations or just the preferred set up?

Are you running other developer applications simultaneously? Apps like MAMP, XAMPP, or Docker for example.

---

<div class="post-metadata">

### Author: ![blacksun](https://avatars.discourse-cdn.com/v4/letter/b/b9bd4f/32.png) [@blacksun](https://community.localwp.com/u/blacksun)
#### Post date: [October 9, 2024, 1:09pm UTC](https://community.localwp.com/t/unable-to-add-a-new-site/44912/9 "2024-10-09T13:09:30Z")

</div>

I used preferred at firstime, error mysql  
unistall method, I tried custom mariaDB, another release of mysql.  
I tried ginx, apache.  
no way, in each case, database error

I don’t use MAMP or XAMPP or WAMPserver. Only LocalWP

---

<div class="post-metadata">

### Author: ![blacksun](https://avatars.discourse-cdn.com/v4/letter/b/b9bd4f/32.png) [@blacksun](https://community.localwp.com/u/blacksun)
#### Post date: [October 9, 2024, 1:11pm UTC](https://community.localwp.com/t/unable-to-add-a-new-site/44912/10 "2024-10-09T13:11:36Z")

</div>

I opened port 10004  
I stop running defender, I stop firewall too  
same error

---

<div class="post-metadata">

### Author: ![Nick-B](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/nick-b/32/16140_2.png) [@Nick-B](https://community.localwp.com/u/Nick-B)
#### Post date: [October 9, 2024, 1:50pm UTC](https://community.localwp.com/t/unable-to-add-a-new-site/44912/11 "2024-10-09T13:50:40Z")

</div>

Hi @blacksun

Thank you for checking everything here. It’s tough to say for sure as the logs are still pointing at some sort of permission issue.

Since you’ve done the uninstall/reinstall have you also done a full reboot of your machine?

Is this a personal machine you’re using? Or issued by your employer?

Do you have another machine you can test with?

---

<div class="post-metadata">

### Author: ![system](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/system/32/1_2.png) [@system](https://community.localwp.com/u/system)
#### Post date: [January 7, 2025, 1:51pm UTC](https://community.localwp.com/t/unable-to-add-a-new-site/44912/12 "2025-01-07T13:51:12Z")

</div>

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
