Local Community

Unable to provision site due to special characters in Windows username

Hey @chauque – do you have the exact error that mentions errors related to special characters within the Window’s username?

Can you provide an example of your username on the Bug Tracker for this bug:

As a workaround, if you are wanting to use the latest version of Local, you can create a new user or try editing the folder name for the user. See the updated topic description for more details:

Sorry for the frustration but:

HOW LONG WILL IT TAKE TO FIX THIS??? Do you want your software to be used?

I mean it’s been such a long time and still not fixed… At least admint you are not planning to do it then we can move to another software. This way you are just deciving customers.

I hate this kind of threatment.

Sincere regards,

Hey @Atalol, Welcome to the Local Community Forums and I’m sorry for the frustration that this is causing!

Due to the difficulty of fixing something like this it isn’t on our immediate roadmap of things to be worked on, but by upvoting the bug report mentioned in the opening topic, you can help increase the priority of getting something like this worked on.

Using Windows 10 ver. 2004 whenever I install LOCAL and try to create a new local site I get an error message: initialize-insecure

Also mysqld can not create directory (OS err no 2 - No such file or directory).

It can be due to the spanish letter “ñ” which is in my root because my name is “Iñigo”: I also get the message “The character set UTF8MB3 is deprecated and will be removed in a future release. Please consider using UTF8MB4 instead”.

I suggest that using the “ñ” should NOT be a problem because there are many different languages out there with special character sets and Local should work with all of them.

Is it me or is it the program? Anybody can Help? Thank you in advance.

Hey @ICP – Welcome to the community! I’ve moved the post to this topic since it’s a known issue.

You should be able to get an idea of a workaround by reading the summary at the top of this topic.

I recently installed the Local 5.7.2 and when I create a New Site I get this message error: Uh-oh! Unable to provision site. Error: Error: Command failed:…, here I put the print screen of this error. By the way, I have Kaspersky Antivirus, but I closed it before installing Local. Can you please tell me what I am doing wrong, in order to create a new site, please?, thanks a lot.
Sofia Perez

Hey @sofia.perez – Thanks for joining the Local forums and writing in! Since this is a known bug, I’ve merged your topic into this one. You should be able to review this topic’s description and upvote the bug as well as find a work around:

Than you Ben. Windows has this problems. And many more. The virtual Linux machine is just for coding. So what I will do is something different. I have tried using Ubuntu with a USB (https://ubuntu.com/tutorials/create-a-usb-stick-on-windows#1-overview) and it works. In some days I will install Ubuntu in my PC (two operative alternative systems, i.e. without unistalling Windows) and install Local version for Linux. Done. No Windows. Thanks anyway. I´ll tell you and the community how it runs. Not done yet. Iñigo.

1 Like

A post was split to a new topic: Unable to Provision site with MySQL error

J’ai le même problème, lors de la création d’un site.
L’erreur ci-dessous s’affiche dans une fenêtre Popup.
Impossible de provisionner le site
Je vous joins également le fichier local-lightning.log
local-lightning.log (35.9 KB)


This text will be hidden


This text will be hidden

Hey @Dede – Thanks for joining the Local forums and writing in! Since this is a known bug, I’ve merged your topic into this one. You should be able to review this topic’s description and upvote the bug as well as find a work around:

I got something that worked for me guys!
I right-clicked on Local shortcut on Desktop, went to Properties > Security > Edit
and then I granted all permissions to my user and that was it. Hope it helps.

Are you sure that doing this fixed the issue of the computer’s username having special characters in it?

I’m having trouble visualizing how granting additional permissions to the Local desktop would help with this bug.


I think I still have the error described here with special characters. Can you confirm that this is not yet solved ?

We haven’t released any fix for this and due to how low-level this is, there’s not much we can do about it at this time.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

I know that this is a very old thread and is something that is unresolved in Local.

We’re trying to update and streamline our communication around bug reporting and fixing issues in Local. Because of this, I’ve moved this topic into the “Bugs” category which allows it to be up-voted.

If this is a problem that affects you, please up-vote this topic by clicking the “Vote” button at the top of the page.

Creating the account with no special characters fixed it on Win 11 20000.318
Thank you

1 Like

It has been two years since this bug was reported, any news on the issue? It is quite annoying…

1 Like