Windows 10 Install will not launch

I also tried running with the --disable-gpu flag. Which did not have any effect. I’m going to try running it while in safe mode and see what happens.

OK I tried restarting in SafeMode and running Local, same effect. Running out of ideas here…

This is all very confusing for sure, and thanks for being persistent!

@trailblazer – Can you provide an updated version of the Local logs? I’d love to see if any of those changed start-up flags provided additional logging.

You know, one other thing that I’m wondering, what kinds of antivirus is installed on this computer, or even the LAN router?

Given that the updater window was blank, I wonder if something is preventing Local from reaching certain URLs?

In the case of the main Local window, it’s encouraging that the “Loading…” component is rendered with the correct styles, which means that the main app is “working.”

The fact that it doesn’t move past that Loading screen makes me wonder if the renderer window is having trouble reaching the GraphQL endpoint that the Local main thread serves.

I’ve ruled out the Anti-Virus and firewall. Tried temporarily disabling both. It was returning the correct version info when it was checking for updates, so I don’t think it was being restricted. Here is a summary of what has been tried.

  • Unlikely related to the GPU. I was able to figure out how to load the app with different GPUs. This had no effect. Also tried using --disable-gpu which is supposed to prevent electron applications from using the GPU.
  • Not related to Anti-Virus or Firewall. I disabled both temporarily and tried testing.
  • Tried launching the app with Administrator permissions to confirm its not a permissions based issue
  • Tried running the application while in safe mode, same effect

Does anyone know what other user preferences can be passed to user-preferences.json? Is there any documentation on this file? I’m curious what other settings might be configurable VIA .json files.

Considering the app was first hanging on the user confirming the TOS, and then was hanging on the update window, I’d hazard a guess there is something else similar that it is hanging on. In terms of the application launching, what is going on under the hood when it boots after the Updates have been checked? Is there maybe a login or something that it could be snagging on next?

> {"class":"addIpcAsyncListener","level":"warn","message":"Duplicate callback appears to be getting added to connectManifestWpeService:create","stringifiedCallback":"(e,t,i,n,s,r,a,o)=>this.create(e,t,i,n,s,r,a,o)","thread":"main","timestamp":"2024-06-11T17:48:07.864Z"}
> {"level":"info","message":"Finished maybeCopyBundledServices in 0.001s","thread":"main","timestamp":"2024-06-11T17:48:07.942Z"}
> {"class":"AddonLoaderService","level":"info","message":"Loading Add-on: %%userDataPath%%\\lightning-services\\mailpit-1.12.1+0\\lib\\main.js","thread":"main","timestamp":"2024-06-11T17:48:07.944Z"}
> {"class":"AddonLoaderService","level":"info","message":"Successfully Loaded Add-on: %%userDataPath%%\\lightning-services\\mailpit-1.12.1+0\\lib\\main.js","thread":"main","timestamp":"2024-06-11T17:48:07.947Z"}
> {"class":"AddonLoaderService","level":"info","message":"Loading Add-on: %%userDataPath%%\\lightning-services\\mariadb-10.4.10+4\\lib\\main.js","thread":"main","timestamp":"2024-06-11T17:48:07.948Z"}
> {"class":"AddonLoaderService","level":"info","message":"Successfully Loaded Add-on: %%userDataPath%%\\lightning-services\\mariadb-10.4.10+4\\lib\\main.js","thread":"main","timestamp":"2024-06-11T17:48:07.990Z"}
> {"class":"AddonLoaderService","level":"info","message":"Loading Add-on: %%userDataPath%%\\lightning-services\\mysql-8.0.16+6\\lib\\main.js","thread":"main","timestamp":"2024-06-11T17:48:07.991Z"}
> {"class":"AddonLoaderService","level":"info","message":"Successfully Loaded Add-on: %%userDataPath%%\\lightning-services\\mysql-8.0.16+6\\lib\\main.js","thread":"main","timestamp":"2024-06-11T17:48:08.032Z"}
> {"class":"AddonLoaderService","level":"info","message":"Loading Add-on: %%userDataPath%%\\lightning-services\\nginx-1.16.0+7\\lib\\main.js","thread":"main","timestamp":"2024-06-11T17:48:08.033Z"}
> {"class":"AddonLoaderService","level":"info","message":"Successfully Loaded Add-on: %%userDataPath%%\\lightning-services\\nginx-1.16.0+7\\lib\\main.js","thread":"main","timestamp":"2024-06-11T17:48:08.071Z"}
> {"class":"AddonLoaderService","level":"info","message":"Loading Add-on: %%userDataPath%%\\lightning-services\\php-8.1.23+0\\lib\\main.js","thread":"main","timestamp":"2024-06-11T17:48:08.072Z"}
> {"class":"AddonLoaderService","level":"info","message":"Successfully Loaded Add-on: %%userDataPath%%\\lightning-services\\php-8.1.23+0\\lib\\main.js","thread":"main","timestamp":"2024-06-11T17:48:08.112Z"}
> {"class":"AddonLoaderService","level":"info","message":"Add-on does not have \"productName\" specified in package.json: %%appPath%%\\node_modules\\@getflywheel\\local-components\\package.json","thread":"main","timestamp":"2024-06-11T17:48:08.113Z"}
> {"class":"AddonLoaderService","level":"info","message":"Add-on does not have \"productName\" specified in package.json: %%appPath%%\\node_modules\\@getflywheel\\localcert\\package.json","thread":"main","timestamp":"2024-06-11T17:48:08.113Z"}
> {"class":"AddonLoaderService","level":"info","message":"Add-on does not have \"productName\" specified in package.json: %%appPath%%\\node_modules\\@getflywheel\\localtunnel\\package.json","thread":"main","timestamp":"2024-06-11T17:48:08.114Z"}
> {"class":"AddonLoaderService","level":"info","message":"Add-on does not have \"main\" or \"renderer\" specified in package.json: %%appPath%%\\node_modules\\@getflywheel\\replacestream\\package.json","thread":"main","timestamp":"2024-06-11T17:48:08.114Z"}
> {"class":"GraphQLService","level":"verbose","message":"GraphQL server ready at http://127.0.0.1:4000/graphql","thread":"main","timestamp":"2024-06-11T17:48:08.166Z"}
> {"class":"GraphQLService","level":"verbose","message":"GraphQL subscriptions ready at ws://127.0.0.1:4000/graphql","thread":"main","timestamp":"2024-06-11T17:48:08.166Z"}
> {"level":"warn","linuxEdition":null,"localVersion":"9.0.3+6684","message":"Electron Event ready","osArch":"x64","osPlatform":"win32","osRelease":"10.0.19045","timestamp":"2024-06-11T17:48:08.362Z","windowsEdition":"Microsoft Windows 10 Pro"}
> {"class":"Updater","level":"info","message":"Checking for updates for: win32-ia32-production","thread":"main","timestamp":"2024-06-11T17:48:08.417Z"}
> {"class":"Updater","level":"debug","message":"Check for updates result","release":null,"thread":"main","timestamp":"2024-06-11T17:48:09.248Z"}

I tried installing on another windows box I have here, and it works fine…

Oh I forgot to mention I also found these 5 files:

  • showBlueprintsNewsBadge.json
  • showCreateSiteGroupCTA.json
  • showLiveLinksUpdateBanner.json
  • showLocalAccountsWelcomeScreen.json
  • showStarredSiteGroup.json

I tried reconfiguring all of these to have:

`{“show”:null}

They had previously been {"show":true}. This also did not appear to have any effect.

Running out of leads to follow. The only thing I can think of next would be to find another hard drive and try installing a fresh copy of windows and see what happens.

There isn’t much documentation around these files. They’re mostly used by various systems within Local to persist settings. Those other json files you mention are different settings, almost like feature flags. I’m guessing there wasn’t a change because in most of those cases, Local is just checking for the existence of that show key.

To your question of if Local has a login event happening – For the main window, Local does check if you are logged into Hub, but it shouldn’t hang on that and will fall back to being logged out if it can’t determine if it’s logged into Hub. The only consequence of not being logged into Hub would be that Backups and Live Links won’t work.

And anyway, that only happens on the main window, which wouldn’t account for the blank screen of the Updater window.

At this point, since it is working on another Windows machine, I’m out of ideas for what to try next. It might be a good idea to try this on a fresh install of Windows.