Windows Issue: Local's router is having trouble starting

Okay, after going through the process the PID for the program that is associated with Port 80 is 4 and it was only created last Wednesday, Sept. 11th. I have attached a screen shot. Am I safe to “End Task”?

Without knowing what the service is, I can’t really say if that is “safe” or not.

My hunch is that there is a service running that would be better to “stop” than to end the task there (though that might work perfectly fine as well).

Out of curiousity, what happens when you go to a browser and navigate to http://localhost:80?

There are a few ideas on this page about what might be using port 80 with PID 4 -

I experienced this issue. The solution I finally found at https://praveenpuglia.com/make-wamp-work-on-windows-10-technical-preview/ worked for me.

A different, better method to accomplish the same thing - https://stackoverflow.com/questions/30901434/iis-manager-in-windows-10

1 Like

I stopped World Wide Web Publishing Service and changed the setting from Automatic to Manual. Local is now working. Thanks.

1 Like

Similar issue here trying to run 5.0.6 on Windows 10. The router wont start

2019/10/04 12:59:34 [emerg] 10156#12756: bind() to 0.0.0.0:80 failed (10013: An attempt was made to access a socket in a way forbidden by its access permissions)

Ok - it was because iis was running on the laptop (for some reason). Problem resolved

2019/10/06 03:13:57 [emerg] 18400#17480: bind() to 0.0.0.0:443 failed (10013: An attempt was made to access a socket in a way forbidden by its access permissions)
2019/10/06 03:13:58 [emerg] 14152#7988: bind() to 0.0.0.0:443 failed (10013: An attempt was made to access a socket in a way forbidden by its access permissions)
2019/10/06 03:13:59 [emerg] 17844#10604: bind() to 0.0.0.0:443 failed (10013: An attempt was made to access a socket in a way forbidden by its access permissions)
2019/10/06 03:14:00 [emerg] 18216#17732: bind() to 0.0.0.0:443 failed (10013: An attempt was made to access a socket in a way forbidden by its access permissions)

This looks similar to the issue I had, where something else locally was using port 443, or port 80. Typically this is another webserver, IIS or Apache, running on the local machine.

Poppi,

Thanks for your advice, it works now.

In Laragon you can change ports… in Local can we change ports?

@bumperthose, not yet but it is something that we’re working on for an upcoming release.

I’m having the same issue on windows 10 and after looking around I still can’t find anything that works.
The solution found here just didn’t work for me because device manager doesn’t seem to have this option in Windows10.

2019/12/26 06:51:42 [emerg] 29060#27732: bind() to 0.0.0.0:80 failed (10013: An attempt was made to access a socket in a way forbidden by its access permissions)

Would appreciate any help on this.

Hey clockwood,
I was troubled by the same issues and since the morning was searching in google, youtube and posting here and other other forums, BUT finally I found your post with the link which describing how to disable port 80, and was done! really easy, just 2 steps and click to stop word wide web publishing … DONE!
Would like to express my warmest thanks and gratitude for proving and sharing such solution!
Thanks again my fiend!

I was having significant difficulty with Local’s router failing to start after upgrading to 5.2.3, same issues with attempting to bind to port 80 while currently in use. After doing some research, I found this article, which was incredibly helpful: http://www.devside.net/wamp-server/opening-up-port-80-f

Turns out the BranchCache Windows service was hogging port 80 to itself in my case. Disabling the service fixed the issue.

I am on Mac OS Catalina 10.15.3 with Local 5.2.4. and I am getting the same issue. This is a newly factory restore laptop without any other application installed.

I also tested on Mac OS Mojave with Local 5.2.3, same issue.error.log (307 Bytes)

had the same problem, indeed something was using port 80 and in the task manager the main thing that came in mind was vmware, so ended all processes and everything worked like usual

1 Like

Me, Local sets port automatically to 10005 (very high I felt…)
So there must be no conflict with regular 80 and 403 ports?
I use to have this problem with IIS and WAMP and I was able to switch, But I actually can’t find the issue , neighter clear reference on any blog…

Hi, i know this post is oldie, but maybe this info can help. Sometimes Skype takes the port 80, so check if you have the process running. You only need to configure skype to use another port.

I have answered this issue -->> HERE <<–. There are 2 workarounds that I’ve tested they both worked for me. Let me know if it works for you too.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.