# WP admin does not start and site not accessible

**URL:** <https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852>\
**Category:** Support\
**Created:** [May 8, 2023, 2:53pm UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852 "2023-05-08T14:53:13Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![moniquelocal](https://avatars.discourse-cdn.com/v4/letter/m/73ab20/32.png) [@moniquelocal](https://community.localwp.com/u/moniquelocal)\
**Post date:** [May 8, 2023, 2:53pm UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852/1 "2023-05-08T14:53:14Z")

</div>

### Issue Summary

_WP admin does not start and site not accessible when open site + error while loading pph\_imagick.dll._

#### Troubleshooting Questions

- Does this happen for all sites in Local, or just one in particular? several

- Are you able to create a new, plain WordPress site in Local and access it in a Browser? yes but a new site not all the older except if sometimes I succeeded to clone the site.

#### Replication

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

Summary :  
Simply when I have modified a site It could often happened that when I have logout wp admin and stop the site and come back again to access it, wp-admin does not sart and the site is not accessible. and at the same time there is an error with the loading of php\_imagick.dll but this error does not prevent to access wp admin.

Detailed description:

Good morning,

I come back to you for errors that persist using local by flywheel.  
Last year when I took the wordpress training, I had no problems with local and had built a first small site locally with several types of content and plugins.  
Since April 2023, I have wanted to create a new site intended to be hosted by a host for a company that is starting up, but I have encountered multiple errors while creating this new site without my being able to understand how they occur. doing everything so that such errors do not occur (login and logout of wp-admin, start/stop of my site under local, saving of my modifications).  
Most of these errors are manifested by inaccessibility to wp-admin of local preventing any modification of the site under construction.  
I found a workaround which is to clone the site not accessible by wp-admin and I regain access to wp-admin to the cloned site.  
I even lost access to my 2022 trial site in wp-admin because by logging in with the same admin name my password is no longer accepted even though I haven’t changed it; I can only open this site.  
So I managed to recover it but nothing assures me that the wp-admin not launching errors will not start again.

So I have two requests:  
– how to restore access to wp-admin or even repair the original sites that have become inaccessible either in wp-admin or in open site? which files should I consult? what checks should I make there (for example for the admin password which would have been modified when I did not touch it)?  
– how to develop reliably with wordpress? what other tools do you recommend without investing too much money?

In addition, I have a recurring error on all my sites with the php\_imagick.dll dll which seems not to be found even though it does exist in the directory where it is searched for, i.e. C:\Users\mgibe\AppData\Roaming\Local\ lightning-services\php-7.4.30+5\bin\win64\ext.

I am not a specialist in website development but my experience of several years in the field of computer development and debugging makes it easier for me to understand the answers if they are clearly explained.

Thank you very much for your thoughtful feedback. I intend to arrive at all costs to produce WordPress WEB sites.

#### System Details

- Which version of Local is being used? 6.7.1

- What Operating System (OS) and OS version is being used? windows 11

- _For example: macOS Catalina or Windows 10 Professional_

- Attach the Local Log. See this Help Doc for instructions on how to do so:

### Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.  
[local-logs.zip](https://community.localwp.com/uploads/short-url/lCL4LpeqkORFCYedlkDEKj4qdsG.zip) (17.4 KB)

---

<div class="post-metadata">

**Author:** ![sambrockway](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/sambrockway/32/18726_2.png) [@sambrockway](https://community.localwp.com/u/sambrockway)\
**Post date:** [May 9, 2023, 4:28pm UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852/2 "2023-05-09T16:28:44Z")

</div>

Hi there @moniquelocal -

To clarify, new Local sites are working fine it’s the older ones that you are having issues with?

Regarding the `php_imagick.dll` errors, please review this thread for more information:

> [@Win32: WP-CLI: Warning: PHP Startup: Unable to load dynamic library ‘php\_imagick.dll’](http://community.localwp.com/t/win32-wp-cli-warning-php-startup-unable-to-load-dynamic-library-php-imagick-dll/30087):
>
> Bug Summary On windows, opening a site shell results in a bunch of "Unable to load dynamic library ‘php\_imagick.dll’ " warnings to be printed. This happens both with the “command prompt” and “git bash” terminal setting. See also: [PHP 7.4.1 and Windows 10 lead to WP-CLI: Warning: PHP Startup: Unable to load dynamic library 'php\_imagick.dll'](http://community.localwp.com/t/php-7-4-1-and-windows-10-lead-to-wp-cli-warning-php-startup-unable-to-load-dynamic-library-php-imagick-dll/26371)[PHP Startup: Unable to load dynamic library 'php\_imagick.dll'](http://community.localwp.com/t/php-startup-unable-to-load-dynamic-library-php-imagick-dll/17523)[WP-CLI warnings with PHP 7.4.1 on Windows 10](http://community.localwp.com/t/wp-cli-warnings-with-php-7-4-1-on-windows-10/22987)[PHP imagick issue on Windows 10](http://community.localwp.com/t/php-imagick-issue-on-windows-10/28936)Steps to reprod…

Let me know about my question above and we’ll see where to go!

Sam

---

<div class="post-metadata">

**Author:** ![moniquelocal](https://avatars.discourse-cdn.com/v4/letter/m/73ab20/32.png) [@moniquelocal](https://community.localwp.com/u/moniquelocal)\
**Post date:** [May 13, 2023, 10:07am UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852/3 "2023-05-13T10:07:09Z")

</div>

Thank you very much for your reply and help.

Both old and new sites are affected with this error.  
But when I cannot accessed to them, Il clone them and I have access to the clones. So I clone them and their clones every time the error happens.  
I realised that it could happen if the navigator (google chrome) is shut down before I logg out the wp admin. do you have an idea for me to fix the access problem (a file to fix?).Any idea about how I could repair the error?

Otherwise, I will have a look at the links for the error about php\_imagick.dll.

Thanks a lot again  
BR  
Monique

---

<div class="post-metadata">

**Author:** ![Nick-B](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/nick-b/32/16140_2.png) [@Nick-B](https://community.localwp.com/u/Nick-B)\
**Post date:** [May 13, 2023, 4:45pm UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852/4 "2023-05-13T16:45:54Z")

</div>

Hi @moniquelocal

Some questions after looking over your log.

Does your machine have enough disk space and memory? Has it gone through any updates recently?

Do you have any antivirus, security, or firewall applications that could be blocking Local? Are you running other developer applications simultaneously? Apps like MAMP, XAMPP, or Docker for example.

More details about troubleshooting this here: [Router Mode](https://localwp.com/help-docs/advanced/router-mode/)

---

<div class="post-metadata">

**Author:** ![moniquelocal](https://avatars.discourse-cdn.com/v4/letter/m/73ab20/32.png) [@moniquelocal](https://community.localwp.com/u/moniquelocal)\
**Post date:** [May 14, 2023, 1:26pm UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852/5 "2023-05-14T13:26:08Z")

</div>

Hi Nick,

Does your machine have enough disk space and memory?  
Yes

 ![image.jpg](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/3X/1/0/1070ec3f2cab388cf9137b6ec389b1248127eb7d.jpeg)

Has it gone through any updates recently? My operating system is Windows11 and there are regular updates.

Do you have any antivirus, security, or firewall applications that could be blocking Local? Are you running other developer applications simultaneously? Apps like MAMP, XAMPP, or Docker for example.

My antivirus is Malwarebytes. There is no firewall application.

 ![image.png](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/3X/e/5/e5d0c5b27f89000188a685a77ec21c94e79d256e.png)

There are no other development applications on my PC. There are no other applications running simultaneously.  
The applications I have installed are for instance tools for genealogy (NIMEGUE3 that is shut down while local is ruuning), visioconference (Zoom, Teams) , remote access (Teamviewer), Winamp,etc… This kind of applications.

I succeed to have access to the clone sites. So I systematically clone the site and their clone to keep access to a copy of the site. It is the only means I have found to retrieve my inaccessible sites and I do not understand why it works.

Thanks a lot for your help and any other idea.  
BR

Monique

---

<div class="post-metadata">

**Author:** ![Nick-B](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/nick-b/32/16140_2.png) [@Nick-B](https://community.localwp.com/u/Nick-B)\
**Post date:** [May 16, 2023, 3:20pm UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852/6 "2023-05-16T15:20:38Z")

</div>

@moniquelocal

Are the front and back-end errors always the same? Can you send a screenshot?

Do all of your sites run the same WP and PHP versions? What are these set at?

Does disabling plugins help? If you open site shell and use WP-CLI commands to deactivate plugins or change out theme can you access the site? If you need more instructions on how to do this let me know!

---

<div class="post-metadata">

**Author:** ![moniquelocal](https://avatars.discourse-cdn.com/v4/letter/m/73ab20/32.png) [@moniquelocal](https://community.localwp.com/u/moniquelocal)\
**Post date:** [May 16, 2023, 5:39pm UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852/7 "2023-05-16T17:39:39Z")

</div>

Hello,

Yes the front and back end errors are always the same. But I have already delete all the sites that could be inaccessible so I cannot send any more screenshot.  
I have cloned the sites inacessible and I succeed to access to the clones.  
Since I’m careful to log out of wp-admin without my browser closing, I no longer have a site inaccessible with wp-admin.  
All of my sites do not run the same PHP versions because at the beginning of the problems I have seen that the pb of loading of immagick.dll could come from the version of PHP so I have tried to change the PHP version et the Mysql version. But I am working with the same version of WP (6.2). For some sites I have PHP 8.1.9 et Mysql 8.0.16 and for other ones I have PHP 7.4.30 et Mysql 5.7.28. I can try to have the same versions of all of my sites it is better. What do you think about?

At this time the residual errors are :

1. the pb with the dll php\_imagick.dll that is present but not found by WP!

 ![image](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/3X/e/6/e6fb9d881b1a1bea8b45f6b3ed7f8b469dbc410f.png)

1. Pb with the API rest : Lors du test de l’API REST, une erreur s’est produite :

Point de terminaison de l’API REST : [http://site-gene2.local/wp-json/wp/v2/types/post?context=edit](http://site-gene2.local/wp-json/wp/v2/types/post?context=edit)  
Réponse de l’API REST : (http\_request\_failed) cURL error 28: Operation timed out after 10009 milliseconds with 0 bytes received

Hope that could help to help me.  
BR  
Monique

---

<div class="post-metadata">

**Author:** ![Nick-B](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/nick-b/32/16140_2.png) [@Nick-B](https://community.localwp.com/u/Nick-B)\
**Post date:** [May 16, 2023, 8:20pm UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852/8 "2023-05-16T20:20:04Z")

</div>

To clarify, you cloned all of your sites and deleted the previous versions so now you don’t have issues accessing the sites or their admins any further?

But you’re still seeing the imagick error and an API error now?

Regarding the imagick error you’re seeing, did you review that link that Sam sent above? [Win32: WP-CLI: Warning: PHP Startup: Unable to load dynamic library ‘php\_imagick.dll’](http://community.localwp.com/t/win32-wp-cli-warning-php-startup-unable-to-load-dynamic-library-php-imagick-dll/30087)

Regarding the API error, it could be a connection error or some other problem happening. Can you share a new copy of your Local Log?

---

<div class="post-metadata">

**Author:** ![moniquelocal](https://avatars.discourse-cdn.com/v4/letter/m/73ab20/32.png) [@moniquelocal](https://community.localwp.com/u/moniquelocal)\
**Post date:** [May 17, 2023, 3:51pm UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852/9 "2023-05-17T15:51:42Z")

</div>

Hello,

yes when I cloned all of my sites and deleted the previous versions I don’t have issues accessing or their admins any further if I logg out correctly from wp-admin. it seems to me that if we disconnect badly from wp-admin, we no longer manage to have the login page the following times. we must corrupt a file which is reestablished when we clone the site.

Yes I am still seeing the imagick error (for all sites) and the API error (only within one site).  
I have a look to the link sent by Sam. I compared the two PhpService.js files and it appears that there are some differences like the missing bold lines (case win32 is missing) in my file:

get siteShellStartupBat() {  
return `\nSET PATH=${path_1.default.join(this.$PATH, 'ImageMagick', 'bin')};%PATH%\n`;  
}  
get siteShellStartupPOSIX() {  
let shellStartup = `\nexport MAGICK_CODER_MODULE_PATH="${this.imageMagickCodersDir}"\n`;  
switch (os\_1.default.platform()) {  
case ‘linux’:  
shellStartup += `\nexport LD_LIBRARY_PATH="${path_1.default.join(__dirname, '../bin', 'linux', 'shared-libs')}"\n`;  
**case ‘win32’:**  
\*\* ellStartup += `\nexport PATH="${this.toPOSIX(this.imageMagickBinDir)}:$PATH\"n`;  
}  
return shellStartup;

So should I replace my PhpService.js by the one where there is the missing line or add it in my file?

For the API rest, here is attached the local logs file  
[local-logs4.zip](https://community.localwp.com/uploads/short-url/iXUxmGHDYyNXdx0WxEb7PRso6u2.zip) (63.0 KB)

Thanks a lot for any help  
BR  
Monique

---

<div class="post-metadata">

**Author:** ![moniquelocal](https://avatars.discourse-cdn.com/v4/letter/m/73ab20/32.png) [@moniquelocal](https://community.localwp.com/u/moniquelocal)\
**Post date:** [May 20, 2023, 5:00pm UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852/10 "2023-05-20T17:00:00Z")

</div>

Hi,

I don’t have any issue with the imagick.dll not found since I modified the PhpService.js when adding a line missing for win32 (my PC is win64!) but I still have a problem that remains with imagick that is

- Avertissement Le module facultatif, imagick, n’est pas installé, ou a été désactivé.

I still have a problem with the API rest that is critical

Lors du test de l’API REST, une erreur s’est produite :

Point de terminaison de l’API REST : [http://gibsolessai6.local/wp-json/wp/v2/types/post?context=edit](http://gibsolessai6.local/wp-json/wp/v2/types/post?context=edit)  
Réponse de l’API REST : (http\_request\_failed) cURL error 28: Operation timed out after 10005 milliseconds with 0 bytes received

And I have another problem related to curl

La requête de bouclage sur votre site a échoué, ce qui signifie que les fonctionnalités qui s’appuient sur ces requêtes ne fonctionnent actuellement pas comme prévu.  
Erreur : cURL error 28: Operation timed out after 10012 milliseconds with 0 bytes received (http\_request\_failed)

Thantks for your help  
BR  
Monique

log :  
[local-logs5.zip](https://community.localwp.com/uploads/short-url/8KLYnGAWqV8eXnAFffyXabFMKvD.zip) (14.1 KB)

---

<div class="post-metadata">

**Author:** ![moniquelocal](https://avatars.discourse-cdn.com/v4/letter/m/73ab20/32.png) [@moniquelocal](https://community.localwp.com/u/moniquelocal)\
**Post date:** [May 21, 2023, 2:08pm UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852/11 "2023-05-21T14:08:56Z")

</div>

Thanks a lot.  
Since I did the modification of the PhpService.js following the links you sent to me, there is no more the error : unable to load dynamic 'php\_imagick.dll  
But I got a new error with imagick that is in French:

- Avertissement Le module facultatif, imagick, n’est pas installé, ou a été désactivé  
(translated = \* Warning The optional module, imagick, is not installed, or has been disabled)

I do not know why; this is not critrical but it could be improved.

Any help about this error?  
BR  
Monique

---

<div class="post-metadata">

**Author:** ![Nick-B](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/nick-b/32/16140_2.png) [@Nick-B](https://community.localwp.com/u/Nick-B)\
**Post date:** [May 27, 2023, 7:43pm UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852/12 "2023-05-27T19:43:20Z")

</div>

Hi @moniquelocal!

Are you still getting this error? Is it happening on one site or multiple sites? What PHP versions are the sites on?

---

<div class="post-metadata">

**Author:** ![moniquelocal](https://avatars.discourse-cdn.com/v4/letter/m/73ab20/32.png) [@moniquelocal](https://community.localwp.com/u/moniquelocal)\
**Post date:** [May 27, 2023, 9:43pm UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852/13 "2023-05-27T21:43:48Z")

</div>

Hi Nick,  
Yes on all sites with PHp version 8.1.9.  
Otherwise, the API error disapeared since I have updated WordPress to version 6.2.2.  
How can I fix the error with imagick.dll not activated or not installed ?  
Have you any idea ?  
Thanks a lot

---

<div class="post-metadata">

**Author:** ![moniquelocal](https://avatars.discourse-cdn.com/v4/letter/m/73ab20/32.png) [@moniquelocal](https://community.localwp.com/u/moniquelocal)\
**Post date:** [May 28, 2023, 5:09pm UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852/14 "2023-05-28T17:09:46Z")

</div>

Hi Nick,  
Unfortunately the error API rest is still present.  
and the Error with imagick is always there.  
BR  
Monique

---

<div class="post-metadata">

**Author:** ![Nick-B](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/nick-b/32/16140_2.png) [@Nick-B](https://community.localwp.com/u/Nick-B)\
**Post date:** [May 31, 2023, 3:47pm UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852/15 "2023-05-31T15:47:59Z")

</div>

Hi @moniquelocal

I’m a little confused because I saw that you mentioned the Imagick error was resolved:

```auto
Since I did the modification of the PhpService.js following the links you sent to me, there is no more the error : unable to load dynamic 'php_imagick.dll

```

And then the API error was resolved:

```auto
Otherwise, the API error disapeared since I have updated WordPress to version 6.2.2.

```

So what changes have taken place to bring the errors back? Did you revert any changes on the sites? Or are these showing up on new sites?

---

<div class="post-metadata">

**Author:** ![moniquelocal](https://avatars.discourse-cdn.com/v4/letter/m/73ab20/32.png) [@moniquelocal](https://community.localwp.com/u/moniquelocal)\
**Post date:** [June 2, 2023, 6:05pm UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852/16 "2023-06-02T18:05:05Z")

</div>

Hi Nick

I am travelling so I am late to reply.  
Unfortunately, the errors came back without no change on the same sites.  
But within imagick, the error not loading has disapeared and the error imagick not installed or not activated remains.  
The error API rest again came back!

An idea?  
Best regards  
Monique

---

<div class="post-metadata">

**Author:** ![Nick-B](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/nick-b/32/16140_2.png) [@Nick-B](https://community.localwp.com/u/Nick-B)\
**Post date:** [June 3, 2023, 7:51pm UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852/17 "2023-06-03T19:51:24Z")

</div>

Hi @moniquelocal - Can you share your updated Local Log so we can compare it?

---

<div class="post-metadata">

**Author:** ![moniquelocal](https://avatars.discourse-cdn.com/v4/letter/m/73ab20/32.png) [@moniquelocal](https://community.localwp.com/u/moniquelocal)\
**Post date:** [June 7, 2023, 2:15pm UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852/18 "2023-06-07T14:15:54Z")

</div>

Sorry I was not at home.  
Here are attached the logs  
[local-logs7.zip](https://community.localwp.com/uploads/short-url/bn8hkD5UAG3wkVtgKUmN5zwpuTm.zip) (40.1 KB)  
Thanks a lot  
Monique

---

<div class="post-metadata">

**Author:** ![Nick-B](https://sea1.discourse-cdn.com/flex019/user_avatar/community.localwp.com/nick-b/32/16140_2.png) [@Nick-B](https://community.localwp.com/u/Nick-B)\
**Post date:** [June 7, 2023, 7:38pm UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852/19 "2023-06-07T19:38:10Z")

</div>

I’m still seeing a lot of erroring in the log like something is blocking Local. Either antivirus or some other application.

Have you tried checking this yet?

> [@Help! I'm running into an EPERM error with the hosts file on Windows](http://community.localwp.com/t/help-im-running-into-an-eperm-error-with-the-hosts-file-on-windows/3508):
>
> This is usually caused by the hosts file being set to read-only or locked by anti-virus. 1. Remove Read-only Attribute Go to C:\Windows\System32\drivers\etc Right-click on the hosts file and go to “Properties” Uncheck “Read-only” Click “Apply” Re-open Local Screenshot 2. Anti-Virus/Internet Security Avira See [https://answers.avira.com/en/question/avira-blocks-hosts-file-what-can-i-do-90](https://answers.avira.com/en/question/avira-blocks-hosts-file-what-can-i-do-90)Kaspersky Total Security Open Kaspsersky Total Security Go to “More Tools” Go …

---

<div class="post-metadata">

**Author:** ![moniquelocal](https://avatars.discourse-cdn.com/v4/letter/m/73ab20/32.png) [@moniquelocal](https://community.localwp.com/u/moniquelocal)\
**Post date:** [June 18, 2023, 1:57pm UTC](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852/20 "2023-06-18T13:57:22Z")

</div>

Hello Nike,  
I was on a trip to Scotland and I was not available to answer you. I am sorry.  
I looked at the host file and I don’t know which properties to modify because it can be a security hole if I allow writing. I make two screenshots to show you the current configuration. You tell me if it’s correct.  
Otherwise I noticed that Local asks me to access the host file and I always answer OK.  
My antivirus is Malwarebytes. What should I do about its configuration because there are only access restrictions to websites but not to local applications?

 ![image](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/3X/a/5/a57f6f96c3325ec413795ef02eba5cba62fc7150.jpeg)  
 ![image](https://us1.discourse-cdn.com/flex019/uploads/lwpforums/original/3X/5/7/572182f6c2f1a621bda210c08bbeb47f4092e15e.png)

Thanks a lot  
Monique

[Next page](https://community.localwp.com/t/wp-admin-does-not-start-and-site-not-accessible/36852.md?page=2)
