Local Community

Xdebug config stopped working on new projects

yes I am aware of the listen for connections buttton as I have set this up for other environments, in fact I got it working fine with MAMP this morngin. The listen for connections button is enabled and it is not working.

Thanks for the screenshots!

Can you please try validating the Xdebug setup in PhpStorm? Here’s how:

  1. Click on “Local by Flywheel” next to the Start, Stop, Coverage, and Listen buttons.
  2. Go to “Edit Configurations”
  3. Click “Validate” in the middle of the window. See the screenshot below.
  4. Go through the steps to validate the setup. Here’s what it should look like with Local.

it looks like it validates fine, i just can’t understand why it won’t work

Got it, thanks for checking that!

Here’s what I’d try:

  1. Go to Chrome and disable the Xdebug Debug session
  2. Quit PhpStorm
  3. Restart the Local site
  4. Re-open PhpStorm
  5. Click on the bug icon beside “Local by Flywheel” in PhpStorm to start a debugging session directly from PhpStorm. It should pop open your default browser and append a query string such as ?XDEBUG_SESSION_START=18932. This will set a cookie. Don’t enable Debug in Chrome with the extension (yet).
  6. Make sure breakpoints aren’t muted by pressing Shift + Shift and then typing “Mute Breakpoints”
  7. Navigate around the site and test various breakpoints in PhpStorm.

Ok, i went through and did all that, breakpoints are not muted, i didn’t enable the chrome extension, restarted everything, used the “bug” icon to launch browser from phpstomr i have breakpoints all over the place, nothing worked

Thanks again for the screenshots.

I was searching around and came across this: https://stackoverflow.com/a/29174219

Based off of that, you could try changing the Xdebug port in the site’s conf/php-VERSION/php.ini file. Restart the site after making any changes in conf.

I really appreciate all the help, but that did not work either

I changed the port then restarted the site then clicked from the bug icon again in phpstorm and nothing I also changed the listening port in php storm

I don’t want to give up on local, but without xdebug i have to go back to using echo statements and get a much worse experience, i was so excited by local and i really want to make it work, I have no idea what could be going on. Like I said I was able to get xdebug working in MAMP but it just refuses to work with local

I appreciate your patience!

I’m still looking into other possible solutions.

Have you tried restarting the Local Machine and/or your computer? There may be a virtual networking issue at play here.

I have restarted everything several times over, the site, the computer, the local machine, etc… I have read everything I can find. Like I said I was just able to get it to work perfectly with MAMP on my machine, i have tried the autostart setting in xdebug, I noticed that in some of the material some were not able to get it to work unitl they set the remote host to the correct ip, im not sure what ip my local site is at so I am not able to try it. Could ir be something in virtual box?

I got it!!! I’m not sure what I actually did that worked but I believe it was turning off windows defender firewall. I’m sure there is a rule I can set somehow so I don’t have to completely turn it off, but I turned everything off then rebooted the machine. I also had set the remote host to the local domain in php.ini, though i don’t know if I needed to do that, i also set the port to 9123 which I saw in a forum somewhere, I also don’t know if I needed to do that. However it is now working.
This now brings me back to my original reason for posing which is the configure phpstorm button is not working in local. It worked for the very first site i made but after that it does nothing. I see in the original site i made that it created some config files for phpstorm, This is not happening with new custom sites. I can probably configure everything manually but it would be nice if that function worked. Also, thank you so much for your time and your help!

Rock on, glad to hear you got it sorted out! Thanks for sharing the solution too :slight_smile:


Regarding the Xdebug configure button not working, can you try clicking the button and then provide the local-by-flywheel.log file? See “How do I retrieve Local’s log file?” for instructions on how to get that file.

local-by-flywheel.log (321.2 KB)

I pressed the button several times, there doesn’t appear to be any corresponding info in the log about it though, it seems this
May 16, 2018, 4:42 PM EDT - info: [main/waitForMySQL] Querying MySQL
corresponds to when i click the button, then it does nothing