1 site is always auto-started local


One site is always on when starting local. I think it was imported from backup or cloned not sure. But it’s annoying bug.

Can’t find the reason why or how to solve it.

I have the same issue.
But I’ve wasted too much time trying to find out why I often have/had? 2 or 3 sites showing as running, but only 1 really is. I think that problem went away, but now I have the issue that seems the same as yours.
I’ve given up on the “little things” that don’t keep me from moving forward.
; j

Yeah, same here started happening months ago but got a minute over to add a post so just did a quick one.

For me, it even starts again as well even if I shut it down and stop it.

I suspect that you’re running into the issue covered in this thread:

Make sure you have the latest version of Local installed as that should prevent the issue from happening, but you’ll likely need to edit your sites.json file to clean up the erroneous entries that are already there.


Amazing! The funny though though. Most sites doesn’t seem to have a site.json file. looked through all local sites and would say 50% have and the other half doesn’t.

Isn’t that strange? So for this site in particular there is nothing to clean up and remove. I can maybe add one add one based on another site.

Hi @alriksson - :wave:

Just a heads up - there should only be one sites.json file for all of Local.

Depending on your OS, this lives at:

Mac/Linux: ~/Library/Application Support/Local/sites.json

Windows: %APPDATA%\Roaming\Local\sites.json

Maybe take a look there for sites.json and try out what @burt mentioned?

That said, this bug is definitely on the Local team’s radar, and you can follow along with that in this thread: Local UI Showing Websites in a "Start" State Incorrectly - macOS - #18 by NdnaJnz



macOS here but I found them in the sites folder. But no local have no folder om /Application Support/

Hi there @alriksson -

Have you tried entering this command in your spotlight search?

~/Library/Application Support

A Local folder should exist there.


Am I stupid, why is this not showing up when going to the user? There it was a lot more things, yeah.Thanks Sam!

And removing these unique fields: __typename - status - siteLastStartedTimestamp
solved the issue :partying_face:


Sweet @alriksson -

So glad to hear that!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.