405 Not Allowed

Issue Summary

Hi, I am trying to upload a plugin and I get error
405 Not Allowed nginx/1.16.0

I was using MacOS Catalina, I upgraded to Monterrey. Before everything worked perfect but now I can’t do it. Can you help me?

I also had a problem with the ssl certificates but I managed to solve it because it was a directory permissions issue, I solved it with a comment from someone in the community gave the solution. I don’t know if this is also a permissions issue but I don’t know how to give permissions on mac.

Thanks in advance.

Hi @maogomez! Thank you for reaching out. We may need some more details to help further.

  • What plugin are you trying to upload?
  • What steps are you taking to install it? Via a zip file or searching in the WP admin or something else?
  • Can you provide a copy of your Local Log? Retrieving Local’s Log File

Keep us posted and we’d be happy to help further!

Hi, thank you for your reply.
When I try to install any plugin and any theme, I do it from a .zip the only way that works is to install it directly unzipped from the app directory, but trying to install as you install a plugin or a normal WordPress theme, I get the error that I indicate.

I attach the log file that you indicate me to see if it can be solved. Thanks

local-logs1.zip (198.9 KB)


If you try changing your Router Mode to Localhost does it work normally?

Router Mode

Yes, changing your Router Mode will work normally. Is this the only way?

Hi @maogomez - using that help document I linked above you may need to do some troubleshooting and see if something on your machine is blocking a port and causing a conflict when you try to use site domains. Otherwise, you’ll have to use this as a workaround.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.