Aruba backup wordpress

What issue or error are you experiencing?

I’ve a tzst file (backup generated by the register “Aruba” in Italy…I need to create a local copy using “Local”…is there a way to import the whole site from the backup?


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version:

  • Operating System (OS) and OS version:

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @riccardo.beghin

If your Aruba site is a WordPress one it might be easier to install the free plugin WP Migrate Lite and create a site backup zip that you can easily drag and drop into Local. All Local really needs is a WP Content and SQL file bundled together. If you’re having trouble with that or the TZST file we can provide you some steps for a more manual import method.

I’ve got 2 files (the wordpress TZST file with wp-content directory etc…) and SQL (TZST file).

I cannot export the site from wordpress because the domin is down and I’ve to “replace” it.

I’m able to “explode” the TZST file but I’m not able to handle them to import in “local” :slight_smile:
Could you help me?


Are you able to extract the wp content and SQL and then combine those together in a new zip?

Otherwise, you may need to do a more manual import like this:

Unzip the file in a common location, like the desktop
Create a new, blank site in Local. Use whatever username/password you like since you’ll overwrite the DB with this site archive’s dump.
Copy the wp-content folder from the unzipped location to this newly created site’s location
Copy the correct SQL dump to the site root.
Within Local, open the site shell
Import the dump with wp db import <dumpfile>
If that works, now Search and replace the domains. wp search-replace ' ' 'http:mylocalsite.local'

I receive this error:

Riccardo@MacBook-Pro-2 public % wp db import h496613_wp_0fp6f_1
Error: Failed to get current SQL modes. Reason: ERROR 2003 (HY000): Can’t connect to MySQL server on ‘localhost’ (61)

sorry…I’m a newbie :slight_smile:

Could you provide some more details to help us take a further look?

  • What is your OS?

  • What version of Local are you on?

  • Please attach a copy of your Local Logs

Keep us posted and we’d be happy to help further!

Here I am! Thank you.

I’m using the latest version of Local on MacOS Ventura (latest version)

I attach some screenshots and local logs.

Riccardo. (26.9 KB)

Are you running other developer applications simultaneously? Apps like MAMP, XAMPP, or Docker for example. It looks like something might be blocking Local from working normally on your machine.

Do you have any antivirus, security, or firewall applications running? Those could also be causing an issue.

More details about troubleshooting this here: Router Mode

Tried to install under windows…another error…(picture attached)

Could you help me? :slight_smile: (7.5 KB)

…I really don’t know how but…solved (1st part)…
I can now see the site but I cannot access the dashboard (where can I find the password or set one new?)

Really thanks for your help!

1 Like

Everything is SOLVED!
Really thank you!

(for the PW I used MailHog)

1 Like

Hi @riccardo.beghin

Apologies for the delay as I’ve just been able to circle back to this. I’m glad to hear you were able to get your issues resolved! You know where to find us if you run into any other issues. Happy Developing :green_heart:

1 Like