Block plugin development using create-block package issue

What issue or error are you experiencing?

Hi I am new to WP block development, following the document here for creating a new block using create-block

I ran the npx command within the plugin directory mine local wp site and activated the plugin within WP admin but when I go to the block editor on a new page I can’t see the newly activated block within the block editor.

Am I missing something here?

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version:

  • Operating System (OS) and OS version:

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

For anyone else who have the same problem worked it out. Downgrade wordpress/scripts to version 27.9.0 seem to have resolve the problem

1 Like

Thank you for sharing the solution here @wplearner! :green_heart:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.